Page 1 of 1

PHP7.0.19 Broke My 3.1 Forum, Can't Access.... Help Please

Posted: Sat Apr 28, 2018 4:27 am
by kentaifina
My webhost updated to PHP7.0.19 last night and now I get the following error:

mysql_connect function does not exist, is mysql extension installed? []

I found the following on a discussion for v3.2 - would this help? does adding the "i" force it to use the mysqli-driver (already installed) and since I can't access the site how would I clear the board cache.

I appreciate any help thanks!

Re: PHP7.0.19 Broke My 3.1 Forum, Can't Access.... Help Please

Posted: Sat Apr 28, 2018 6:53 am
by Mick
You can try adding the ‘i’ to mysql in your config.php, it can’t hurt but as far as I can see the highest version of PHP for phpBB 3.1 is < 7.0-dev, you might have to get your host to back peddle if the above doesn’t work. You can clear the cache manually by deleting everything in the cache folder except index.htm and .htaccess.

Re: PHP7.0.19 Broke My 3.1 Forum, Can't Access.... Help Please

Posted: Sat Apr 28, 2018 4:28 pm
by stevemaury
This is one reason why 3.1.x is end-of-life and support will cease July 1.