Page 1 of 1

phpbb 3.1.2 prosilver file attachement upload problem

Posted: Wed Jan 21, 2015 10:16 am
by B€RN@RD
hello, Mick told me to post in this forum

I have set my phpbb 3.1.2 board settings for attachements up to 10mio

I have modified my board htaccess with:

php_value max_execution_time 1000
php_value max_input_time 1000
php_value upload_max_filesize 15M
php_value post_max_size 15M

I tried to upluad an attatchement over 5mio in a post:

- with prosilver or prosilver based theme I get a small tranfer status bar and the tranfer crashes with a
message " error parsing server response"
- with subsilver2 I get a popup window and the tranfer goes well.

does anybody experiment the same problem?

ps:
1/ for testing purpose
I replaced posting_attach_body.html file from prosilver with subsilver same file ( apart an error with the popup box) ......there is no problem for uploading attachement.

I really think the problem came from prosilver original file


2/ additionnal infos
Attachments
Allow attachments: Yes
Allow attachments in PMs: Yes
Upload directory: /files/
Upload directory permissions: 700
Attachment display order: Descending
Size of posted attachments: 5.63 MIB
Total attachment quota: 50 MIB
Maximum file size of 10 MIB less than estimated server PHP limit of 16 MIB
Maximum file size PMs: 256 KIB
Maximum attachments per post: 3
Maximum attachments per PM: 1
Check file mimetype: Yes
Secure downloads: No
Image attachments
Display images inline: Yes
Create thumbnail: Yes
Maximum thumbnail width: 400 px
Maximum thumbnail file size: 11.72 KIB
Imagemagick path:
Maximum image dimensions: 0 × 0 px (width × height)
Image link dimensions: 0 × 0 px (width × height)


PHP Values
PHP version: 5.4.0-1~dotdeb.1
PHP safe mode: Off
zlib.output_compression: Off
open_basedir restrictions: /home/web/abpphpbb.com/:/usr/share/squirrelmail/:/etc/squirrelmail:/var/lib/squirrelmail/data/:/var/spool/squirrelmail/:/etc/mailname:/usr/share/php/:/usr/share/roundcube/
upload_max_filesize: 15 MIB
post_max_size: 15 MIB
memory_limit: 16 MIB
∴ Estimated maximum file upload size: ≤ 16 MIB
max_file_uploads: 20
Max execution time: 600 secs
Max input time: 600 secs
max_input_vars: 1000
file_uploads: Enabled
allow_url_fopen: Enabled
imagick PHP extension not available
ImageMagick: not found
getimagesize remote: Working
getimagesize local: Working


3/ for testing purpose I have set to "0" attached file size in the admin panel of my board ====> and uploads over 5mio are going well with prosilver !!!!!
very strange ! when it is set to 10mio...it crasch !!.....despite in subsilver 2 there is no pb with 10mio


regards

Re: phpbb 3.1.2 prosilver file attachement upload problem

Posted: Sat Jan 24, 2015 6:15 pm
by B€RN@RD
up

Re: phpbb 3.1.2 prosilver file attachement upload problem

Posted: Sun Jan 25, 2015 9:40 am
by tangeryn78
I also have this problem: "error parsing server response"
Screenshot: http://goo.gl/u7MdKW

phpbb 3.1.2
fresh install
default settings

Ubuntu 12.04.5 (32bit) server
PHP Version 5.3.10-1 ubuntu3.15

Re: phpbb 3.1.2 prosilver file attachement upload problem

Posted: Wed Jan 28, 2015 6:13 pm
by mrgtb
All depends what your server host allows you to upload max size as? Makes no difference setting 15mb upload size if your hosting limits upload size to less than that. Have you checked "PHP Information" page that your host sets via Admin CP, look at upload_max_filesize on it

Adding those lines to an htaccess file makes no difference half the time, it will not override the php.ini file server host sets for max-upload size, you would need to contact your host and ask them to change it in INI file. Don't be fooled into thinking that anything you add in an htaccess file overrides things, most of time it won't work.

Re: phpbb 3.1.2 prosilver file attachement upload problem

Posted: Thu Jan 29, 2015 10:41 am
by B€RN@RD
see my php infos from my server in my first post ==> it seems oki

the problem remain only with prosilver which use plupload and when I set to zero
in the admin panel there is no pb with prosilver.

regards

Re: phpbb 3.1.2 prosilver file attachement upload problem

Posted: Fri Jan 30, 2015 10:23 pm
by Oyabun1
Do you run suPHP on the server?

Re: phpbb 3.1.2 prosilver file attachement upload problem

Posted: Sat Jan 31, 2015 8:04 pm
by Lear76
I have the same problem, and I don't use suPHP.

Re: phpbb 3.1.2 prosilver file attachement upload problem

Posted: Tue Feb 03, 2015 5:45 am
by Lear76
I was running an older version of PHP and when I upgraded the server (invluding PHP) the problem stopped. I also upgraded to 3.1.3 at the same time, so it might also have been that. Problem solved!