Theme colours not changed

For support and discussion related to templates, themes, and imagesets in phpBB 3.1.
Scam Warning
User avatar
daveb86
Registered User
Posts: 262
Joined: Tue Jul 03, 2012 4:31 am
Location: Lancashire, UK
Name: Dave B
Contact:

Theme colours not changed

Post by daveb86 »

Hi there

I've changed my forum colours in the colours.css file but my forum hasn't changed even after clearing the forum and browser cache.

Can anyone assist why?

Particularly the forumbg part

www.excelmasters.co.uk/forum
Currently working on Dutyhosts
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52127
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Theme colours not changed

Post by Brf »

You have not changed the gradient background image.
User avatar
daveb86
Registered User
Posts: 262
Joined: Tue Jul 03, 2012 4:31 am
Location: Lancashire, UK
Name: Dave B
Contact:

Re: Theme colours not changed

Post by daveb86 »

Thanks brf

Can i just remove the link for the gradient or would this be required to display correctly?

Unless there is somewhere i can generate a gradient with the colours I want.

Dave
Currently working on Dutyhosts
User avatar
Brf
Support Team Member
Support Team Member
Posts: 52127
Joined: Tue May 10, 2005 7:47 pm
Location: {postrow.POSTER_FROM}
Contact:

Re: Theme colours not changed

Post by Brf »

Try it and see.
User avatar
daveb86
Registered User
Posts: 262
Joined: Tue Jul 03, 2012 4:31 am
Location: Lancashire, UK
Name: Dave B
Contact:

Re: Theme colours not changed

Post by daveb86 »

Thanks brf

Last question on theme colours is

How do i change the colours of the following areas

1) Banner area
2) The actual forums area with the board name and description etc
3) The bar in the header that hold the quick links and login etc
4) The footer bar with the team page link and delete board cookies link

Could do with a "Style Map" something that shows the default board page and gives you the names of each area so you know which value to change in the CSS.

Cheers
Dave
Currently working on Dutyhosts
User avatar
Lumpy Burgertushie
Registered User
Posts: 68175
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Theme colours not changed

Post by Lumpy Burgertushie »

right click on whatever you want to change. choose "inspect element" that will pop up a box that will show you exactly what css is related to that spot on the page.
in that box you should be able to uncheck the boxes next to that element to see what happens.

those changes are not permanent so if you like what happens you still need to go edit the actual file.

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?
User avatar
daveb86
Registered User
Posts: 262
Joined: Tue Jul 03, 2012 4:31 am
Location: Lancashire, UK
Name: Dave B
Contact:

Re: Theme colours not changed

Post by daveb86 »

Lumpy Burgertushie wrote:right click on whatever you want to change. choose "inspect element" that will pop up a box that will show you exactly what css is related to that spot on the page.
in that box you should be able to uncheck the boxes next to that element to see what happens.

those changes are not permanent so if you like what happens you still need to go edit the actual file.

robert
Ahh perfect cheers :D
Currently working on Dutyhosts
User avatar
daveb86
Registered User
Posts: 262
Joined: Tue Jul 03, 2012 4:31 am
Location: Lancashire, UK
Name: Dave B
Contact:

Re: Theme colours not changed

Post by daveb86 »

Hi Lumpy

I have made a few changes to the colours.css file but nothing seems to have changed when viewing the page.

I have cleared the cache in the ACP, Changed the load settings to recompile and also cleared all browser settings deleted the cache and reloaded the page.

But still nothing has changed

Cheers
Currently working on Dutyhosts
User avatar
Lumpy Burgertushie
Registered User
Posts: 68175
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Theme colours not changed

Post by Lumpy Burgertushie »

exactly what changes have you made?
I see the green for the forabg

also, you have messed up the links somehow for the forum and topic titles etc.


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?
User avatar
daveb86
Registered User
Posts: 262
Joined: Tue Jul 03, 2012 4:31 am
Location: Lancashire, UK
Name: Dave B
Contact:

Re: Theme colours not changed

Post by daveb86 »

I have tried to change the variable with the quick links MCP and UCP to the same color as the forabg.

The html body background should be showing as white "FFFFFF" but still showing green for me

I did make a few changes to the templates but il be undoing those changes tomorrow although i cant see any issues with them myself

Maybe due to the issue ive posted about where im not seeing any changes that are made even after clearing temps and cache etc

Dave
Currently working on Dutyhosts
User avatar
Lumpy Burgertushie
Registered User
Posts: 68175
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Theme colours not changed

Post by Lumpy Burgertushie »

according to the colours.css file,( http://excelmasters.co.uk/forum/styles/ ... olours.css)
your body background is set to background-color:#F5F7FA;
not white and not green either.

not sure what you are changing or how you are changing it.

you should be downloading the prosilver/theme/colours.css file to your computer.
edit with a good text editor and upload back.

go to the admin panel and purge the cache.

go to your browser and hard refresh a couple of times.


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?
User avatar
daveb86
Registered User
Posts: 262
Joined: Tue Jul 03, 2012 4:31 am
Location: Lancashire, UK
Name: Dave B
Contact:

Re: Theme colours not changed

Post by daveb86 »

Lumpy Burgertushie wrote:according to the colours.css file,( http://excelmasters.co.uk/forum/styles/ ... olours.css)
your body background is set to background-color:#F5F7FA;
not white and not green either.

not sure what you are changing or how you are changing it.

you should be downloading the prosilver/theme/colours.css file to your computer.
edit with a good text editor and upload back.

go to the admin panel and purge the cache.

go to your browser and hard refresh a couple of times.


robert
Hi Robert

I have changed the colours.css back to the colour of 006400 using notepad++ and re-uploaded.

I have clicked on Purge the cache in the ACP and also pressed F12 on the forum to open the Developer Tools then right clicked on my refresh icon and selected "Empty Cache and Hard Reload" along with pressing all different variations of CTRL + R and F5.

Ive also tried using Click and Clean and deleting the cache that way as all advised via the following link >> http://superuser.com/questions/220179/h ... gle-chrome

But still none of the changes i make to the CSS files are being displayed.

Cheers
Dave
Currently working on Dutyhosts
User avatar
Lumpy Burgertushie
Registered User
Posts: 68175
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Theme colours not changed

Post by Lumpy Burgertushie »

click here:
http://excelmasters.co.uk/forum/styles/ ... olours.css
first, you must have edited that file with something strange for it to not have any spaces or line breaks in it.

look at the very first line, do you see the body background colour there?

it has not been changed from when I looked at it the other day and posted for you.

are you sure you are editing the correct file?
are you sure you are uploading it to the correct place on the server?
are you sure you are uploading the correct edited file to the server?

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?
User avatar
daveb86
Registered User
Posts: 262
Joined: Tue Jul 03, 2012 4:31 am
Location: Lancashire, UK
Name: Dave B
Contact:

Re: Theme colours not changed

Post by daveb86 »

Lumpy Burgertushie wrote:click here:
http://excelmasters.co.uk/forum/styles/ ... olours.css
first, you must have edited that file with something strange for it to not have any spaces or line breaks in it.

look at the very first line, do you see the body background colour there?

it has not been changed from when I looked at it the other day and posted for you.

are you sure you are editing the correct file?
are you sure you are uploading it to the correct place on the server?
are you sure you are uploading the correct edited file to the server?

robert
That is weird why its doing that.

I havent changed the body background color since i re-uploaded a fresh copy of the colours.css

If you take a look on line 4 i have changed the .forabg colour but that isnt displaying.

Yes im editing the Colours.css file in the prosilver themes folder
And yes because i save the file on my desktop which is clear of any other such files and i put it back in the same folder

I have only ever edited this file with notepad++ nothing else

Dave
Currently working on Dutyhosts
User avatar
Lumpy Burgertushie
Registered User
Posts: 68175
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Theme colours not changed

Post by Lumpy Burgertushie »

ok, I guess there was misunderstanding here. you said above that the body background color should be FFFFFF

that is not so. the default background color is: background-color: #F5F7FA;

when I go to your board I see the forabg color as green.

if you do not see that, then you must have some type of caching going on somewhere.

do you have another browser you can use to check/

I am using firefox and I see the green for the forabg color.


robert

EDIT:

I notice in the post from a long time ago you were having this same problem:
viewtopic.php?f=74&t=2171353

that shows me that for some reason you are not deleting the cookies and/or pulling a fresh page from the server when you refresh your browser etc.

click on the "delete all board cookies" link at the bottom of the page on your board and see what happens.


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?
Locked

Return to “[3.1.x] Styles Support & Discussion”