why a code that is in overall_hearder don't work in viewforum_body

For support and discussion related to templates, themes, and imagesets in phpBB 3.1.
Ideas Centre
Locked
User avatar
ouiouiphoto
Registered User
Posts: 91
Joined: Mon Jun 15, 2015 5:30 am
Contact:

why a code that is in overall_hearder don't work in viewforum_body

Post by ouiouiphoto »

Hello all

My level in phpbb is increasing but let say i'm a not at a very good level ;)

In my theme i have in the overall_header this code

Code: Select all

<ul id="nav-breadcrumbs" class="linklist navlinks" role="menubar">
	<!-- DEFINE $MICRODATA = ' itemtype="http://data-vocabulary.org/Breadcrumb" itemscope=""' -->
	<!-- EVENT overall_header_breadcrumbs_before -->
	<li class="small-icon icon-home breadcrumbs">
	<!-- IF U_SITE_HOME --><span class="crumb"><a href="{U_SITE_HOME}"{$MICRODATA} data-navbar-reference="home">{L_SITE_HOME}</a></span><!-- ENDIF -->
	<!-- EVENT overall_header_breadcrumb_prepend -->
	<span class="crumb"><a href="{U_INDEX}" accesskey="h"{$MICRODATA} data-navbar-reference="index">{L_INDEX}</a></span>
	<!-- BEGIN navlinks -->
	<!-- EVENT overall_header_navlink_prepend -->
	<span class="crumb"><a href="{navlinks.U_VIEW_FORUM}"{$MICRODATA}<!-- IF navlinks.MICRODATA --> {navlinks.MICRODATA}<!-- ENDIF -->>{navlinks.FORUM_NAME}</a></span>
	<!-- EVENT overall_header_navlink_append -->
	<!-- END navlinks -->
	<!-- EVENT overall_header_breadcrumb_append -->
	</li>
	<!-- EVENT overall_header_breadcrumbs_after -->			
</ul>
This code allow to show at the top of the forum a home icon and a sting that show the position in the forum and you can click on each string to go back. So i have something like

Index / Pictures / Show a picture

And you can click on Index or Picture or Show a picture

I want to have the same thing but at the bottom of the forum list. So i have just copy this code in the viewforum_Body.html file after the last row section. But it is not working. I have the icon with the index but not the Pictures or Show a picture.

So i assume that some variable that exist in the overall_hearder don't exist in the viewforum_body. But i don't know where to search.

Any help is welcome ;)
Paph
Registered User
Posts: 362
Joined: Tue Dec 25, 2007 7:58 am
Location: Georgia - USA
Contact:

Re: why a code that is in overall_hearder don't work in viewforum_body

Post by Paph »

Try putting that code in the overall_footer.
Hawk
User avatar
ouiouiphoto
Registered User
Posts: 91
Joined: Mon Jun 15, 2015 5:30 am
Contact:

Re: why a code that is in overall_hearder don't work in viewforum_body

Post by ouiouiphoto »

Paph wrote:Try putting that code in the overall_footer.
Thanks for your interest. it wortks in overall_footer or in jumbox. I have juste remove the event lines that was trigering some other extensions ;)

But when i'm inside a topic this is a bit far in the page because of similar topics extension. But hopefully this works also in quick reply.

So i'm all set. Thanks again ;)
User avatar
forumthemer
Registered User
Posts: 21
Joined: Mon Jan 11, 2016 7:00 am
Location: Europe
Name: Larvi E.
Contact:

Re: why a code that is in overall_hearder don't work in viewforum_body

Post by forumthemer »

As an answer to your question, the code doesn't work because it uses template variables which are not defined in every page :)

Template variables are the ALL CAPS things inside
<!-- IF U_SITE_HOME -->
Host your forum on a SSD cloud server at DigitalOcean - My refferal link helps you save $10

Eles - Responsive phpBB 3.1 Theme - Premium phpBB 3.1 theme for only $17
Paph
Registered User
Posts: 362
Joined: Tue Dec 25, 2007 7:58 am
Location: Georgia - USA
Contact:

Re: why a code that is in overall_hearder don't work in viewforum_body

Post by Paph »

Glad it was of some help.
Hawk
Locked

Return to “[3.1.x] Styles Support & Discussion”