Converter doesn't like MySQL 5.5.44

Converting from other board software? Good decision! Need help? Have a question about a convertor? Wish to offer a convertor package? Post here.
Locked
Tailhook
Registered User
Posts: 18
Joined: Mon Sep 01, 2008 3:33 am

Converter doesn't like MySQL 5.5.44

Post by Tailhook » Wed Apr 20, 2016 7:03 am

For the past year I have been doing test upgrade builds of an old 2.0.22 board to both 3.0.12 AND 3.1.x. I didn't keep the converted boards in the past because I didn't have a forum style for 3.1 but now I do. Up until recently, IPOWER decided to upgrade their MySQL database version to 5.5.44. Since then the converter 99.9% of the time now timeout's on the first conversion step. Installing 3.1.x works fine and doing the pre-conversion step works fine but the moment I hit 'Continue conversion' for the first step where it loads all the skip_rows, the converter just sits there for a solid 3-5 minutes and then throws a max_questions 300,000 queries 1226 error.

The stated above is on the official IPOWER server containing the database I want to upgrade. In the past, the conversion has worked perfectly fine converting to 3.0 and 3.1, now it doesn't. It keeps timing out on the first conversion step.

I run a copy of the old board database on my personal FatCow server for upgrade/style testing. FatCow apparently still runs MySQL 5.5.32. I believe IPOWER ran the same version before upgrading to 5.5.44. Doing the conversion to 3.1.9 works great on 5.5.32 without an issue and the converter loads to the first skip_rows page after hitting 'Continue conversion' within 30 seconds.

The PHP.INI for both IPOWER and FatCow servers are now identical and the issue persists so I am able to check that one off the list of causes. Both servers are running the default 5.3 config with the specified changes.

Code: Select all

memory_limit = 256M
upload_max_filesize = 128M
post_max_size = 256M
max_input_time = -1
max_execution_time = -1
default_socket_timeout = -1
FYI, IPOWER and FatCow are both owned by the same parent company and their control panels are exactly the same.

I've begun to wonder if the issue is caused by the database table type being MyISAM and collation being latin1_swedish_ci, BUT like I stated above, the conversion worked FINE before IPOWER upped to MySQL 5.5.44. I've also wondered if the conversion works fine on my FatCow server because the database was imported via BigDump in UTF-8. Both IPOWER and Fatcow phpMyAdmin show MySQL charset: UTF-8 Unicode (utf8) and MySQL connection collation: utf8_unicode_ci.

The only thing I haven't tried so far is exporting the old database and then re-importing it to a separate database on IPOWER via BigDump. If there is a language encoding issue causing the hiccup, that may or may not fix it. That said though, doing that would probably be my last effort at trying to get the conversion to work on MySQL 5.5.44. I'm just hesitant at using BigDump or anything risking a glitchy re-import.

User avatar
3Di
Former Team Member
Posts: 14482
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: Converter doesn't like MySQL 5.5.44

Post by 3Di » Wed Apr 20, 2016 7:11 am

Just do it in local, test it and if anything goes the right way you can export you local environment to the production one.

Make sure to have all the necessary backups kept in a safe place.

Isn't a question to be brave or not, isn't it?
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
✒️ Black Friday 2019 @ The Studio ▪️◾️

Locked

Return to “[3.1.x] Convertors”