Fatal installation error - functions_convert.php [ 658 ]

Converting from other board software? Good decision! Need help? Have a question about a convertor? Wish to offer a convertor package? Post here.
Locked
Hellmark
Registered User
Posts: 5
Joined: Sun Oct 02, 2016 10:56 pm

Fatal installation error - functions_convert.php [ 658 ]

Post by Hellmark » Sun Oct 02, 2016 11:03 pm

Ok, currently trying to upgrade phpbb2 to 3.1, and when running the convertor, I get the following error
Fatal installation error
Fatal installation error

functions_convert.php [ 658 ]

Note to developer: you must specify $convertor['smilies_path'] to use import_smiley().
So far, not had any luck looking around for a fix.

Anyone got a clue?

User avatar
KevC
Support Team Member
Support Team Member
Posts: 68093
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Fatal installation error - functions_convert.php [ 658 ]

Post by KevC » Mon Oct 03, 2016 8:11 am

Please post the links to both phpBB installations.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

Hellmark
Registered User
Posts: 5
Joined: Sun Oct 02, 2016 10:56 pm

Re: Fatal installation error - functions_convert.php [ 658 ]

Post by Hellmark » Mon Oct 03, 2016 6:47 pm

http://forum.socialdeviancy.com/ is the forum address.

On the server side, the old forum is located at /var/www/socialdeviancy.com/forum-old and /var/www/socialdeviancy.com/forum for the new forum.

User avatar
KevC
Support Team Member
Support Team Member
Posts: 68093
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Fatal installation error - functions_convert.php [ 658 ]

Post by KevC » Mon Oct 03, 2016 7:11 pm

The old board doesn't look like it's working
Could not connect: Access denied for user 'mysql_user'@'localhost' (using password: YES)

It needs to be.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

Hellmark
Registered User
Posts: 5
Joined: Sun Oct 02, 2016 10:56 pm

Re: Fatal installation error - functions_convert.php [ 658 ]

Post by Hellmark » Tue Oct 04, 2016 1:03 am

The old board isn't working. The system was recently upgraded, and is now running versions of PHP and Mysql that seem to be incompatible with PHPBB2. That's why I was asked to see about getting things moved over to PHPBB3 (the site and server is a friend's).

He still has the old VM image. Should I try and boot that up, attempt a migration to phpbb3, then move things over to the new VM?

User avatar
3Di
Registered User
Posts: 12695
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: Fatal installation error - functions_convert.php [ 658 ]

Post by 3Di » Tue Oct 04, 2016 3:06 am

phpBB 3.1.x's requirements server side:
docs/INSTALL.html#require
Want to compensate me for my interest? Donate
Please PM me only to request paid works. Thx.
Extensions, Scripts, MOD porting, Update/Upgrades
My development's activity º PhpStorm's proud user

Hellmark
Registered User
Posts: 5
Joined: Sun Oct 02, 2016 10:56 pm

Re: Fatal installation error - functions_convert.php [ 658 ]

Post by Hellmark » Tue Oct 04, 2016 4:35 am

Unfortunately, the old system is running PHP 5.2.6, and 3.1.x needs 5.3.3 or newer.

User avatar
KevC
Support Team Member
Support Team Member
Posts: 68093
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Fatal installation error - functions_convert.php [ 658 ]

Post by KevC » Tue Oct 04, 2016 7:51 am

You could go to 3.0.x first. That will run on the lower version of php.
Then you can upgrade php and to 3.1.x
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

Locked

Return to “[3.1.x] Convertors”

Who is online

Users browsing this forum: No registered users and 14 guests