Conversion from phpBB2 to anything new

Converting from other board software? Good decision! Need help? Have a question about a convertor? Wish to offer a convertor package? Post here.
Ivgoneridng
Registered User
Posts: 41
Joined: Mon Jan 16, 2017 6:23 pm

Conversion from phpBB2 to anything new

Post by Ivgoneridng » Mon Jan 16, 2017 6:36 pm

I've been trying to upgrade my forum software from phpBB2 to something newer but am struggling.

I have to say outright I am a phpBB admin newb, having taken ownership from someone else in the organisation so please forgive any stoopid questions.

I started by installing phpBB3 and db on my website, and that went well.

I have backed up my old forum files and DB then tried to run the conversion process. That went nowhere due to server timeouts and my ISP won't let me change them without changing my hosting package so I tried the offline method using the KB article. I am on Mac OS so downloaded MAMP and installed it.

I tried dumping my existing phpBB2 and 3 installations in the htdocs folder and editing the configs to point at the database. That worked for phpBB3 and I could access the forum and the acp but when I browse to the phpBB2 forum, all I get is a blank page. If I try and run Convert from the Install directory, I just get a blank page.

Then I tried a vanilla install. With BB3 it got almost to the end, then I got a blank screen. After that if I browse to the install page, I get install and convert options but the convert page is blank.

If I try a vanilla install of phpBB2, when i browse to the install directory, I just get a blank page.

Can anyone help please? I'd really like to upgrade my forum and need to keep the history available.

Thanks

User avatar
Mick
Support Team Member
Support Team Member
Posts: 18119
Joined: Fri Aug 29, 2008 9:49 am
Location: Cardiff

Re: Conversion from phpBB2 to anything new

Post by Mick » Mon Jan 16, 2017 6:41 pm

"The more connected we get the more alone we become" - Kyle Broflovski

There are no ‘threads’ in phpBB, they are topics.
Forza Garibaldi

Ivgoneridng
Registered User
Posts: 41
Joined: Mon Jan 16, 2017 6:23 pm

Re: Conversion from phpBB2 to anything new

Post by Ivgoneridng » Mon Jan 16, 2017 6:55 pm

Thanks, that's where I started, but it isn't working

User avatar
warmweer
Registered User
Posts: 484
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Belt ... well actually Belgium

Re: Conversion from phpBB2 to anything new

Post by warmweer » Mon Jan 16, 2017 7:28 pm

It wouldn't surprise me if you can't get phpBB2 running because the MAMP version (with php etc..) is too high.

read: http://www.cjhunter.com/cjhbb/docs/INSTALL.html

If you can find MAMP with the necessary (low enough) specifications, then install your phpBB backup. Test your board.
Only then go to a more recent version of MAMP, don't open pHPBB2 with the higher MAMP version but upgrade to 3.0 immediately.

Personally, I would then upgrade to 3.1 first, and only then upgrade to 3.2.

I know these last steps may seem a bit underzealous but at least in using that sequence you can take a backup for each succesful update (just in case something goed wrong).
A bug is a feature that didn't make it to the manual (yet)

Ivgoneridng
Registered User
Posts: 41
Joined: Mon Jan 16, 2017 6:23 pm

Re: Conversion from phpBB2 to anything new

Post by Ivgoneridng » Mon Jan 16, 2017 7:31 pm

Thank-you. What version of MAMP might i need? Or at least what specs should I be looking for?

User avatar
warmweer
Registered User
Posts: 484
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Belt ... well actually Belgium

Re: Conversion from phpBB2 to anything new

Post by warmweer » Mon Jan 16, 2017 7:40 pm

Ivgoneridng wrote:
Mon Jan 16, 2017 7:31 pm
Thank-you. What version of MAMP might i need? Or at least what specs should I be looking for?
I'm a PC guy and don't know MAMP but I see that the lowest php version currenbtly supported = 5.1.6. I'm not sure whether phpBB2 runs with 5.1.6 so I think you need an older version of MAMP

If you can also use Windows then you could look for Easyphp or Wampserver, AFAIR there where links to older versions.
A bug is a feature that didn't make it to the manual (yet)

Ivgoneridng
Registered User
Posts: 41
Joined: Mon Jan 16, 2017 6:23 pm

Re: Conversion from phpBB2 to anything new

Post by Ivgoneridng » Mon Jan 16, 2017 7:45 pm

Ok, thanks.

There are older versions of mamp available so i'll just download the oldest version and see if it works.

User avatar
warmweer
Registered User
Posts: 484
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Belt ... well actually Belgium

Re: Conversion from phpBB2 to anything new

Post by warmweer » Mon Jan 16, 2017 7:55 pm

Good luck.
And don't forget, once phBB3.0 works, take a backup because your older version of MAMP probably won't be able to run PHPBB3.1 or higher, and you don't want to have to reinstall en re-update you phpbBB2 again and again ;-)
A bug is a feature that didn't make it to the manual (yet)

Ivgoneridng
Registered User
Posts: 41
Joined: Mon Jan 16, 2017 6:23 pm

Re: Conversion from phpBB2 to anything new

Post by Ivgoneridng » Mon Jan 16, 2017 8:07 pm

Good point. :D It looks like i can get php 5.1 for mamp v4 so might not need to install different versions (fingers crossed).

Should I be able to just copy my live files into the folder structure and populate the db tables and expect everything to work? I have various MODS in my ver2 forum that I don't want to have to reinstall.

User avatar
warmweer
Registered User
Posts: 484
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Belt ... well actually Belgium

Re: Conversion from phpBB2 to anything new

Post by warmweer » Mon Jan 16, 2017 8:21 pm

Ivgoneridng wrote:
Mon Jan 16, 2017 8:07 pm
Good point. :D It looks like i can get php 5.1 for mamp v4 so might not need to install different versions (fingers crossed).

Should I be able to just copy my live files into the folder structure and populate the db tables and expect everything to work? I have various MODS in my ver2 forum that I don't want to have to reinstall.
First: requirements for PHPBB2:
PHP (3.0.9 and above or preferably 4.x running as a module) with support for the database you intend to use above
As I said before, I doubt phpbb2 will run with PHP 5 (various stuff is deprecated by now). BUT you can try and even if you can't start the phpBB2 forum, you may be able to start the update to 3.0 (3 works with PHP 5.1)

Next: By upgrading from 2 to 3.0 or higher you will lose the MODS (100% sure). And since you've got a long way to go, I'ld forget about those MODS at this time. Once you've got a 3.1 (or 3.2 running) then you can start thinking about extensions.

Strictly speaking you don't even need the phpBB2 files (except for the config file). Just install the DB, put the phpBB3.0 files in place and run the database update.

Mind you, I'm going by memory here, it's been 10 years since I've opened phpBB2 so I can't guarantee anything (which is why emphasise "Backup" ;)
A bug is a feature that didn't make it to the manual (yet)

Ivgoneridng
Registered User
Posts: 41
Joined: Mon Jan 16, 2017 6:23 pm

Re: Conversion from phpBB2 to anything new

Post by Ivgoneridng » Mon Jan 16, 2017 8:27 pm

Oh, that's interesting. Thank-you. I won't get to play with this for a couple of days now so will update once i've made progress or not.

I thought 5.1 might work, based on a forum thread i saw about phpbb2 not working after php updated to 5.3.

User avatar
warmweer
Registered User
Posts: 484
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Belt ... well actually Belgium

Re: Conversion from phpBB2 to anything new

Post by warmweer » Mon Jan 16, 2017 8:35 pm

Ivgoneridng wrote:
Mon Jan 16, 2017 8:27 pm
...
I thought 5.1 might work, based on a forum thread i saw about phpbb2 not working after php updated to 5.3.
It's possible (I can't recall a post stating that but if you saw that then yes don't bother with older versions). However, phpBB3.2 does have a mimimum requirement of PHP >= 5.3.3, PHP < 7.0-dev, so once you've got 3.0 running you might have to install a more recent version (I would say 5.6 so that 3.1 and 3.2 can function (3.1 won't work with PHP7).
A bug is a feature that didn't make it to the manual (yet)

Ivgoneridng
Registered User
Posts: 41
Joined: Mon Jan 16, 2017 6:23 pm

Re: Conversion from phpBB2 to anything new

Post by Ivgoneridng » Mon Jan 16, 2017 8:37 pm

Cool.

I'm not going to 3.2 straight away because at least one of the extensions we need doesn't work yet.

User avatar
warmweer
Registered User
Posts: 484
Joined: Fri Jul 04, 2003 6:34 am
Location: Van Allen Belt ... well actually Belgium

Re: Conversion from phpBB2 to anything new

Post by warmweer » Mon Jan 16, 2017 8:42 pm

Ivgoneridng wrote:
Mon Jan 16, 2017 8:37 pm
Cool.

I'm not going to 3.2 straight away because at least one of the extensions we need doesn't work yet.
[Oops]Good luck (but I wouldn't - I'ld go to 3.1 first)[/Oops]

edit: I misread and thought you were going for 3.2 immediately
A bug is a feature that didn't make it to the manual (yet)

User avatar
3Di
Registered User
Posts: 11865
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milano - Frankfurt
Name: Marco
Contact:

Re: Conversion from phpBB2 to anything new

Post by 3Di » Mon Jan 16, 2017 9:37 pm

If I am not mistaken all what you need is the phpBB2 DB imported (MySQL (3.22 or higher))
and the related DB connector (PHPBB_ROOT/config.php) file to let the converter be able to act.

If you have the backuped files all what you need, later, is to copy the content of the images folder onto the 3.x.x new install (and files folder or whatever if you had the attachments MOD installed, those are automatically handled by the converter as well for the Birthdays MOD, if present).

I don't think you need to INSTALL a phpBB2, you need the config.php file and the DB installed/imported.

Not tested though.
Want to compensate me for my interest? Donate
Please PM me only to request paid works. Thx.
Extensions, Scripts, MOD porting, Update/Upgrades

Post Reply

Return to “[3.1.x] Convertors”

Who is online

Users browsing this forum: No registered users and 3 guests