[ABD] [3.1] [pre]fixed - Topic Prefixes extension

Any abandoned Extensions will be moved to this forum.

WARNING: Extensions in this forum are not currently being supported or maintained by the original Extension author. Proceed at your own risk.
Forum rules
IMPORTANT: Extension Development Forum rules

WARNING: Extensions in this forum are not currently being supported nor updated by the original Extension author. Proceed at your own risk.
Locked
Kinsman
Registered User
Posts: 207
Joined: Sun Jan 02, 2005 6:04 am
Contact:

Re: [BETA][3.1] [pre]fixed - Topic Prefixes extension

Post by Kinsman » Wed Sep 14, 2016 11:06 am

Where does one acquire 3.1.10-RC, or just wait for the release?

User avatar
kinerity
Community Team Member
Community Team Member
Posts: 2308
Joined: Mon Sep 01, 2014 1:00 am
Location: sudo rm -rf /
Name: Kailey Truscott
Contact:

Re: [BETA][3.1] [pre]fixed - Topic Prefixes extension

Post by kinerity » Wed Sep 14, 2016 11:18 am

You'll have to wait, they haven't even started building the packages yet.
Kailey Truscott - Community Team

User avatar
imkingdavid
Former Team Member
Posts: 2667
Joined: Sun Jul 26, 2009 7:59 pm
Location: EST
Name: David King

Re: [BETA][3.1] [pre]fixed - Topic Prefixes extension

Post by imkingdavid » Wed Sep 14, 2016 4:37 pm

Right, they haven't released it yet so you'd need to wait until they do. I don't have any idea what sort of timeline they've got in mind for that.

In the meantime, you can apply the change yourself (really only adding a line or two in a template file) if you need to use the extension. That being said, while I'm not aware of any glaring issues or bugs caused by this extension, I still don't recommend using it on a live board yet.

I'm hoping to polish a few more things and then it should be ready for a release after 3.1.10 and/or 3.2.0 come out.
Don't forget to smile today. :)
Please do NOT contact for support via PM or email.
Remember, the enemy's gate is down.

Kinsman
Registered User
Posts: 207
Joined: Sun Jan 02, 2005 6:04 am
Contact:

Re: [BETA][3.1] [pre]fixed - Topic Prefixes extension

Post by Kinsman » Sat Sep 17, 2016 11:06 am

Could I please confirm that forums and groups are comma separated?

Like forums 1,4,8 and groups 30,32,2,12 etc etc

User avatar
imkingdavid
Former Team Member
Posts: 2667
Joined: Sun Jul 26, 2009 7:59 pm
Location: EST
Name: David King

Re: [BETA][3.1] [pre]fixed - Topic Prefixes extension

Post by imkingdavid » Sun Sep 18, 2016 4:10 am

Yes, currently users, forums, and group are all comma separated IDs as in the examples you gave. I plan on improving that feature to be more user-friendly.
Don't forget to smile today. :)
Please do NOT contact for support via PM or email.
Remember, the enemy's gate is down.

Kinsman
Registered User
Posts: 207
Joined: Sun Jan 02, 2005 6:04 am
Contact:

Re: [BETA][3.1] [pre]fixed - Topic Prefixes extension

Post by Kinsman » Mon Sep 19, 2016 11:10 am

Cool, thanks for that, I had a good play around with this on my test board and it was working great, so put it on another board with a load of extensions and looks like I found a conflict.

Code: Select all

SQL ERROR [ mysqli ]

Not unique table/alias: 't' [1066]

SQL

SELECT f.*, ft.mark_time, t.icon_id, t.topic_id AS forum_last_post_topic_id FROM (phpbb_forums f) LEFT JOIN phpbb_forums_track ft ON (ft.user_id = 4 AND ft.forum_id = f.forum_id) LEFT JOIN phpbb_topics t ON (f.forum_last_post_id = t.topic_last_post_id) LEFT JOIN phpbb_posts p ON (f.forum_last_post_id = p.post_id) LEFT JOIN phpbb_topics t ON (t.topic_id = p.topic_id) ORDER BY f.left_id

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 855
CALL: trigger_error()

FILE: [ROOT]/phpbb/db/driver/mysqli.php
LINE: 193
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/phpbb/db/driver/factory.php
LINE: 329
CALL: phpbb\db\driver\mysqli->sql_query()

FILE: [ROOT]/includes/functions_display.php
LINE: 151
CALL: phpbb\db\driver\factory->sql_query()

FILE: [ROOT]/index.php
LINE: 75
CALL: display_forums()
Any thoughts how I narrow this down, or is it the old disable extensions one by one until I find which one it is?

User avatar
imkingdavid
Former Team Member
Posts: 2667
Joined: Sun Jul 26, 2009 7:59 pm
Location: EST
Name: David King

Re: [BETA][3.1] [pre]fixed - Topic Prefixes extension

Post by imkingdavid » Mon Sep 19, 2016 5:03 pm

That specific error is coming from this:
LEFT JOIN phpbb_topics t ON (f.forum_last_post_id = t.topic_last_post_id) LEFT JOIN phpbb_posts p ON (f.forum_last_post_id = p.post_id) LEFT JOIN phpbb_topics t ON (t.topic_id = p.topic_id)
You'll see it's trying to LEFT JOIN the phpbb_topics table twice, both times using the alias "t".

It may be helpful to do as you mentioned, disabling extensions until you find which one is incompatible, but I'll also look for that code in my extension to see if I can fix it to be compatible regardless.

What page are you on when you get that error?
Don't forget to smile today. :)
Please do NOT contact for support via PM or email.
Remember, the enemy's gate is down.

User avatar
imkingdavid
Former Team Member
Posts: 2667
Joined: Sun Jul 26, 2009 7:59 pm
Location: EST
Name: David King

Re: [BETA][3.1] [pre]fixed - Topic Prefixes extension

Post by imkingdavid » Mon Sep 19, 2016 5:07 pm

As an update, I just did a search in the extension codebase and I only see one LEFT JOIN, and it doesn't look like either of those joins (it's joining the topics table using alias 't', but it is joining "ON t.poster_id = u.user_id").

So i'm not positive that the error you're seeing is from my extension. Can you try disabling [pre]fixed and see if the error keeps occurring?
Don't forget to smile today. :)
Please do NOT contact for support via PM or email.
Remember, the enemy's gate is down.

Kinsman
Registered User
Posts: 207
Joined: Sun Jan 02, 2005 6:04 am
Contact:

Re: [BETA][3.1] [pre]fixed - Topic Prefixes extension

Post by Kinsman » Mon Sep 19, 2016 8:31 pm

My bad, the moment I activate your extension this happens, if I deactivate it the problem goes away. I activated debug, but it didn't reveal any further information unfortunately.

It's not your extension per se, it's a clash with another one. Yours works fine on a forum with only 4 other extensions. The above is happening on a forum with 50 extensions.

Kinsman
Registered User
Posts: 207
Joined: Sun Jan 02, 2005 6:04 am
Contact:

Re: [BETA][3.1] [pre]fixed - Topic Prefixes extension

Post by Kinsman » Mon Sep 19, 2016 10:15 pm

Ok it didn't take long to find, once I disable Topic Icon on Index everything is fine.

https://www.phpbb.com/customise/db/exte ... _on_index/

User avatar
imkingdavid
Former Team Member
Posts: 2667
Joined: Sun Jul 26, 2009 7:59 pm
Location: EST
Name: David King

Re: [BETA][3.1] [pre]fixed - Topic Prefixes extension

Post by imkingdavid » Tue Sep 20, 2016 1:19 pm

Thanks for following up on that. I'll try to take a look at that extension to see if I can fix the clash, so you would be able to use both extensions.
Don't forget to smile today. :)
Please do NOT contact for support via PM or email.
Remember, the enemy's gate is down.

User avatar
kinerity
Community Team Member
Community Team Member
Posts: 2308
Joined: Mon Sep 01, 2014 1:00 am
Location: sudo rm -rf /
Name: Kailey Truscott
Contact:

Re: [BETA][3.1] [pre]fixed - Topic Prefixes extension

Post by kinerity » Tue Sep 20, 2016 2:43 pm

David, you could create a function that checks for this. Have a look at my best answer extension for how it was accomplished.

Event listener lines 220 - 227 and lines 488-499
Kailey Truscott - Community Team

User avatar
imkingdavid
Former Team Member
Posts: 2667
Joined: Sun Jul 26, 2009 7:59 pm
Location: EST
Name: David King

Re: [BETA][3.1] [pre]fixed - Topic Prefixes extension

Post by imkingdavid » Wed Sep 21, 2016 2:39 pm

Thanks kinerity, I'll take a look.
Don't forget to smile today. :)
Please do NOT contact for support via PM or email.
Remember, the enemy's gate is down.

ndmccain
Registered User
Posts: 3
Joined: Wed Apr 18, 2012 6:09 pm

Re: [BETA][3.1] [pre]fixed - Topic Prefixes extension

Post by ndmccain » Mon Oct 10, 2016 5:13 pm

I have a little problem. I installed it just fine. However, the drop down is hidden behind the post buttons! I've tried changing the z-index put it doesn't work.

I'm using a premium theme called "Canvas" and it's prosilver based.

Any help is great!

germano1
Registered User
Posts: 14
Joined: Mon Oct 10, 2016 10:30 pm

Re: [BETA][3.1] [pre]fixed - Topic Prefixes extension

Post by germano1 » Mon Oct 10, 2016 11:03 pm

Hi,
I have times your extension on a test forum installed, but it is not. In the ACP, although I can adjust this, see screen, but I see nothing in the indicated forum. The IDs should be correct, oh those of the test forum.
Image

Locked

Return to “Abandoned Extensions”