Page 5 of 12

Re: [DEV] Reputation System

Posted: Tue Oct 28, 2014 9:35 pm
by Pico88
The reputation table will be converted during update. No data will be lost.

Re: [DEV] Reputation System

Posted: Tue Oct 28, 2014 9:38 pm
by moviehive
Do you have an EST on an update?

Re: [DEV] Reputation System

Posted: Tue Oct 28, 2014 9:44 pm
by Pico88
ATM, no.
I can say/write that some featereus from version for 3.0.12 is going to be lost such as highlight or hide post and some will be added in the future like ranks.

Re: [DEV] Reputation System

Posted: Wed Oct 29, 2014 12:28 pm
by JupiterGPL
The demo URL no longer works.

Re: [DEV] Reputation System

Posted: Wed Oct 29, 2014 8:28 pm
by ..777..
Pico88 wrote:The reputation table will be converted during update. No data will be lost.
Thank you for your reply.

In panic because my forum was going haywire after failed upgrade I used stk and cleaned the database. Would there be a way for me to pull the reputation tables out of the old db backup and put it into the new database?

I sincerely appreciate your time.

Re: [DEV] Reputation System

Posted: Wed Oct 29, 2014 8:48 pm
by Pico88
Just make a backup of reputations table and restore it on new db? That will be the best option ATM - I think.


I'll set a new demo in the future - have to set up new server.

Re: [DEV] Reputation System

Posted: Sun Nov 02, 2014 3:56 pm
by rrbailey89
im not sure this is working. A member posted and i tried to rate the post (thumbs up) but nothing happened. at least nothing that i could see.

not sure if this helps but i think this is the error i get

Code: Select all

General Error
SQL ERROR [ mysql4 ]

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND rep_to = 53 AND post_id != 0 AND time > 1414941335' at line 4 [1064]

SQL

SELECT COUNT(rep_id) AS rep_per_day FROM jcp_reputations WHERE rep_from = AND rep_to = 53 AND post_id != 0 AND time > 1414941335

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 855
CALL: trigger_error()

FILE: [ROOT]/phpbb/db/driver/mysql.php
LINE: 181
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/phpbb/db/driver/factory.php
LINE: 329
CALL: phpbb\db\driver\mysql->sql_query()

FILE: [ROOT]/ext/pico/reputation/controller/rating_controller.php
LINE: 266
CALL: phpbb\db\driver\factory->sql_query()

FILE: (not given by php)
LINE: (not given by php)
CALL: pico\reputation\controller\rating_controller->post()

FILE: [ROOT]/vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpKernel.php
LINE: 117
CALL: call_user_func_array()

FILE: [ROOT]/vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpKernel.php
LINE: 61
CALL: Symfony\Component\HttpKernel\HttpKernel->handleRaw()

FILE: [ROOT]/app.php
LINE: 33
CALL: Symfony\Component\HttpKernel\HttpKernel->handle()

Re: [DEV] Reputation System

Posted: Thu Nov 06, 2014 4:26 am
by JupiterGPL
FYI....
Received this error when I rated someone while the rating was in the collapsed menu. AKA mobile. Probably part of the "Responsive" work that you are still working on.

Code: Select all

General Error
SQL ERROR [ mysql4 ]

Unknown column 'rep_to' in 'where clause' [1054]

SQL

SELECT SUM(reputation_points) AS points FROM phpbb_reputations WHERE rep_to = 3760

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 855
CALL: trigger_error()

FILE: [ROOT]/phpbb/db/driver/mysql.php
LINE: 181
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/phpbb/db/driver/factory.php
LINE: 329
CALL: phpbb\db\driver\mysql->sql_query()

FILE: [ROOT]/ext/pico/reputation/core/reputation_manager.php
LINE: 236
CALL: phpbb\db\driver\factory->sql_query()

FILE: [ROOT]/ext/pico/reputation/core/reputation_manager.php
LINE: 214
CALL: pico\reputation\core\reputation_manager->check_max_min()

FILE: [ROOT]/ext/pico/reputation/controller/rating_controller.php
LINE: 470
CALL: pico\reputation\core\reputation_manager->store_reputation()

FILE: (not given by php)
LINE: (not given by php)
CALL: pico\reputation\controller\rating_controller->post()

FILE: [ROOT]/vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpKernel.php
LINE: 117
CALL: call_user_func_array()

FILE: [ROOT]/vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpKernel.php
LINE: 61
CALL: Symfony\Component\HttpKernel\HttpKernel->handleRaw()

FILE: [ROOT]/app.php
LINE: 33
CALL: Symfony\Component\HttpKernel\HttpKernel->handle()

Re: [DEV] Reputation System

Posted: Thu Nov 06, 2014 7:35 am
by Pico88
It's still in dev so it has a couple of bugs. ;)

Re: [DEV] Reputation System

Posted: Thu Nov 06, 2014 8:35 am
by Pico88
Ok.
I did some updates.
I also prepere built-in converter from 0.7.0 version. I'll be glad if someone can test if it works.

Re: [DEV] Reputation System

Posted: Thu Nov 06, 2014 10:46 am
by soomster
When I click on "Enable" í get this error message:
Something went wrong during the request and an exception was thrown. The changes made before the error occurred were reversed to the best of our abilities, but you should check the board for errors.
The permission role "ROLE_ADMIN_FULL" unexpectedly does not exist.
Return to the extension list
I also get the exact message when I try to enable the "Board Rules".

Extensions that are currently working are: Auto database backup, Board Statistics and Post Statistics.

This error started after upgrading phpBB3.1 to phpBB3.1.1

Any thoughts?

Re: [DEV] Reputation System

Posted: Thu Nov 06, 2014 11:03 am
by SuperFedya
This extension is a port of my MOD from phpBB 3.0.x. Both version are not compatible together.
Is there a update path from 3.0.x version?

Re: [DEV] Reputation System

Posted: Thu Nov 06, 2014 12:58 pm
by Pico88
soomster wrote:When I click on "Enable" í get this error message:
Something went wrong during the request and an exception was thrown. The changes made before the error occurred were reversed to the best of our abilities, but you should check the board for errors.
The permission role "ROLE_ADMIN_FULL" unexpectedly does not exist.
Return to the extension list
I also get the exact message when I try to enable the "Board Rules".

Extensions that are currently working are: Auto database backup, Board Statistics and Post Statistics.

This error started after upgrading phpBB3.1 to phpBB3.1.1

Any thoughts?
Did you remove the basic admin role, which is created during phpBB instalation?
That messages claims that you deleted it, so create new admin role set and call it "ROLE_ADMIN_FULL".
SuperFedya wrote:
This extension is a port of my MOD from phpBB 3.0.x. Both version are not compatible together.
Is there a update path from 3.0.x version?
As I wrote ealier, Ext includes built-in converter.

Re: [DEV] Reputation System

Posted: Thu Nov 06, 2014 1:30 pm
by denis4o
Hi! Great extension.

I have a rather stupid question:
- I have enabled post rating
- I have enabled user rating
- I see the post's rating (0 - zero)
- I can rate the user from the user's profile

What I can't do though (or can't figure out how to) is to rate a post ... I click on the "0" of the post but the popup just shows rating info. There are no buttons. There are no buttons in the post body as well.

Image

Re: [DEV] Reputation System

Posted: Thu Nov 06, 2014 1:38 pm
by Pico88
Set user permission in forums - can rate post etc.