[ABD] Portal Extension for phpBB 3.1.x

Any abandoned Extensions will be moved to this forum.

WARNING: Extensions in this forum are not currently being supported or maintained by the original Extension author. Proceed at your own risk.
Forum rules
IMPORTANT: Extension Development Forum rules

WARNING: Extensions in this forum are not currently being supported nor updated by the original Extension author. Proceed at your own risk.
Locked
User avatar
michaelo
Registered User
Posts: 1292
Joined: Thu Jun 13, 2002 3:49 am
Location: Dublin, Ireland
Name: Michael O'Toole
Contact:

Re: [DEV] Portal Extension for phpBB 3.1.x

Post by michaelo »

Known Issues:
The portal link in the header will on occasion link to ...app.php/portal.php and when this happens, paths to block icons will be missing... Pressing the index link in header will temporarily correct the problems...

It depends on which code is processed as I use two separate code segments depending on the page to be processed... this is where the problem lies...

The main extension code (used to process the main portal page) works every time but the code used to process other phpBB pages doesn't work as expected...

I am working on a fix...
Contributions: Mods & Styles Extensions
(site is down): Kiss Portal Engine

User avatar
jjoosterbaan
Registered User
Posts: 16
Joined: Thu May 28, 2015 9:09 pm
Contact:

Re: [DEV] Portal Extension for phpBB 3.1.x

Post by jjoosterbaan »

I realy hope you can fix it, this extension is in my opinion a must have for every forum. Many possibilities to inform members :)

User avatar
michaelo
Registered User
Posts: 1292
Joined: Thu Jun 13, 2002 3:49 am
Location: Dublin, Ireland
Name: Michael O'Toole
Contact:

Re: [DEV] Portal Extension for phpBB 3.1.x

Post by michaelo »

The fixes are complete and I even managed to clean up duplicated code too... I've asked one of my guys to test it before committing to Git...
Mike
Contributions: Mods & Styles Extensions
(site is down): Kiss Portal Engine

Miri4ever
Registered User
Posts: 415
Joined: Sat Mar 07, 2015 11:18 am

Re: [DEV] Portal Extension for phpBB 3.1.x

Post by Miri4ever »

Finally it's workinmg with portal site. Yes

But the footer images are still missing. Some translations inside the permissions setup seems missing and I got an error message if I try the to edit the welcome message modul block.

At least it's now show off if permissions for guests are setup. Still need some time for modding to my theme and translating everything to german, but most ext having those problems, too.

Test Site
Homepage: Terra Oceanica

Lazy2000
Registered User
Posts: 13
Joined: Sun Apr 26, 2015 11:33 am

Re: [DEV] Portal Extension for phpBB 3.1.x

Post by Lazy2000 »

hello michaelo, 3.1.4 here.
i downloaded the last version and i am getting a 404 at portal.php
my forum is installed at the root of the server.
if you want breakfast in bed, sleep in the kitchen.

User avatar
michaelo
Registered User
Posts: 1292
Joined: Thu Jun 13, 2002 3:49 am
Location: Dublin, Ireland
Name: Michael O'Toole
Contact:

Re: [DEV] Portal Extension for phpBB 3.1.x

Post by michaelo »

@Miri4ever, I still see the issues with app.php/portal.php, it's fixed in the latest code... also, change .box class in the css to

Code: Select all

.box {
    background: rgba(130, 133, 135, 0) none repeat scroll 0px 0px;
    text-align: left;
    margin-top: 5px;
    padding: 2px;
    overflow: hidden;
    width: auto;
    clear: both;
    border: 1px solid rgba(213, 181, 43, 0.63);
And for block title text try:

Code: Select all

.block_title {
    color: rgba(171, 142, 60, 0.85);
    font-family: Arial,Helvetica,sans-serif;
    font-size: 1em;
    padding-bottom: 2px;
    padding-top: 2px;
    line-height: 1em;
    text-transform: uppercase;
    font-weight: bold;
}
Lazy2000 wrote:hello michaelo, 3.1.4 here.
i downloaded the last version and i am getting a 404 at portal.php
my forum is installed at the root of the server.
Git Updated!
Fixes include.... consolidated code so that build process is the same for all ...
Portal link in the header now call portal.php and not app.exe/portal.php
A few other minor fixes and some small language updates...
Generally, the code should be a little faster...
Mike

PS, none of the guys had time to test it and I only did one install after fixes but everything appears to work better... Next I will look at the welcome block as I gather there's a problem with it...
Contributions: Mods & Styles Extensions
(site is down): Kiss Portal Engine

User avatar
michaelo
Registered User
Posts: 1292
Joined: Thu Jun 13, 2002 3:49 am
Location: Dublin, Ireland
Name: Michael O'Toole
Contact:

Re: [DEV] Portal Extension for phpBB 3.1.x

Post by michaelo »

Notes on Welcome Block:
  • The main welcome text is stored in language files for better multi language support and can be altered to suit...
  • The welcome message can contain config or portal variables such as sitename or version as they will be parsed...
  • You can add up to 255 characters to the welcome message in the ACP > BLOCKS > Welcome Block, it will appear just before the last line of the welcome text...
This should be enough flexibility to suite everyone ;)
Mike

PS, the previously noted problem when editing welcome text has been fixed, it resulted because I had no default name in the database for the welcome variable code...

Git Updated...
Contributions: Mods & Styles Extensions
(site is down): Kiss Portal Engine

Miri4ever
Registered User
Posts: 415
Joined: Sat Mar 07, 2015 11:18 am

Re: [DEV] Portal Extension for phpBB 3.1.x

Post by Miri4ever »

Ok I updated on my test board and you are right the app.php is not display anymore inside the link and some fixes done while editing welcome message. But I'm still having a few errors. I switched on my site to standard template to see if result from my style or still from the exentsion. To make it more clear, if have added some screens from what I found:

Here is the welcome block if I edit settings and pressing submit button I still got this error displayed for a second and then it continue working.

Image

Here the 3 missing images at the footer and standart style. And inside the user profile there is a missing image aswell, but I not uploaded an avatar to this one yet. It should display no image or at least the no avatar image there instead.

Image

I don't know what missing language got updated, but I still didn't see here any translations done inside the permissions setup needed to display the portal block. I uploaded the new extension und cleared the cache, but still those looks missing.

Image

Those two buttons mark all und unmark all. Should they work ?? Nothing happens there if I press them to select all pages to get run.

Image

Sorry always bothering with errors but I think I really could use it exentsion and still having enough work to fix it for my style, but for this all errors should be done.

Is it possible to add custom blocks like at another portal extension. I mean an empty block filled with BBCode Text or custom HTML Code inside to display ??
Homepage: Terra Oceanica

User avatar
michaelo
Registered User
Posts: 1292
Joined: Thu Jun 13, 2002 3:49 am
Location: Dublin, Ireland
Name: Michael O'Toole
Contact:

Re: [DEV] Portal Extension for phpBB 3.1.x

Post by michaelo »

Taking each in turn let's try fix them...

The welcome error will appear if you just copied the latest files over and did not disable and uninstall the portal.. you can then add it again... The other option would be to manually add "k_welcome_vars.html" to the phpbb_k_blocks table for the Welcome block var_file_name entry...

As for the footer images, I have not check these and chances are the path is not correct... will check my code... FIXED!

I'll recheck language files for missing entries but mine are complete...

The check/uncheck error may be down to javascript conflict, I'll check that out too...

You can add custom blocks just as we did with 3.0 version... more on this later...
Mike
Contributions: Mods & Styles Extensions
(site is down): Kiss Portal Engine

Miri4ever
Registered User
Posts: 415
Joined: Sat Mar 07, 2015 11:18 am

Re: [DEV] Portal Extension for phpBB 3.1.x

Post by Miri4ever »

Hi Mike,

I'm using extensions uploader here from the forum to upload everything. It disables everything before updating and I think it work for most of the exentsions fine. I downloaded the latest build and tested twice a time with disable, uninstall, delete, uploading and activation to be sure making no error at all.

The error message editing welcome message and submit seems to be gone.
Missing pictures are now displayed.
Avatar is displayed aswell (as you told)
Javascript buttons not checked for now

But I'm having still this 3 missing translations inside the usergroup permissions to setup the portal is displayed to guests or not. I deleted and uploaded everything twice, used latest build but no texts coming here at my to be displayed at all. If I found time to check will doing inside your language files, those things could be found very quick with a search if they inside. But I tested a lot of extensions from others and those seems often to be forgotten somehow.
Homepage: Terra Oceanica

User avatar
michaelo
Registered User
Posts: 1292
Joined: Thu Jun 13, 2002 3:49 am
Location: Dublin, Ireland
Name: Michael O'Toole
Contact:

Re: [DEV] Portal Extension for phpBB 3.1.x

Post by michaelo »

Will check it out...

I have removed some permissions as we no longer use them, now we have:
Full Admin (automatically set) to allow portal administration etc... and...
User (group) permissions to set access (which groups can see and use the portal)...
As UCP permissions are only available to members, no need for access control there...

Git updated... As usual, remove then re add extension...
Contributions: Mods & Styles Extensions
(site is down): Kiss Portal Engine

Miri4ever
Registered User
Posts: 415
Joined: Sat Mar 07, 2015 11:18 am

Re: [DEV] Portal Extension for phpBB 3.1.x

Post by Miri4ever »

I setup new testing board and uploaded the newest extension again to see whats done.

I saw some permissions moved to Admin site and removed from normal groups permission. So far so fine. But I still got trouble not see the english text and got again this missing texts errors. I thought dammed, this could not be right.

So I did another test coming to my mind and I uploaded all your english language files to my german files. I created an DE folder inside your extension and uploaded all languages again, and restartet the ext with the restart tool and see all missing texts are now shown in english between my german like it should be.

Don't know if people with other languages having the same problems. Normally PHPBB did not care if an translation is missing an display english instead if no others found. Don't know if this come now from your extension not checking if other languages installed or if this is caused by PHPBB itself. I only know I got a lot of extensions not matching my used language of the board and still display correctly their english texts if no others found.
Homepage: Terra Oceanica

User avatar
michaelo
Registered User
Posts: 1292
Joined: Thu Jun 13, 2002 3:49 am
Location: Dublin, Ireland
Name: Michael O'Toole
Contact:

Re: [DEV] Portal Extension for phpBB 3.1.x

Post by michaelo »

If you can post a couple of the images showing the missing text I can better chase it up... I think we have a German translation for portal extension as one of my guys at main site did one... not sure if he uploaded it yet but we should have it soon...

Latest Updates:
  • Some decent clean up to php code and lots of updates to template files...
  • Removed original main_controller and replaced with main.php (controller), this removed a lot of globals we don't need now...
  • Removed one template folder as it was not needed...
  • Corrected more image and other paths...
  • Template event files updated and much cleaner/simpler...
  • Fixed Show/Hide icons (top of page to show/hide bocks)...
GIT updated...

Next part is the javascripts and css clean up... already made a start... and test subsilver type styles...

Items requiring a little work:
  • Fix missing language entries...
  • Show/Hide cookie fix required...
  • Cache deletion in ACP on edit/change...
Contributions: Mods & Styles Extensions
(site is down): Kiss Portal Engine

cisco007
Translator
Posts: 129
Joined: Mon Jul 14, 2008 1:49 am
Contact:

Re: [DEV] Portal Extension for phpBB 3.1.x

Post by cisco007 »

slide1.png and slide2.png not showing,
<img src="{EXT_TEMPLATE_PATH}theme/images/slide2.png" width="12" height="12" alt="" class="left_blocks_col_show" />
it calls for it here, but that image is only on the images folder of the extension directory, the only way they show is if i copy them to the theme/images/folder, and they show on the portal, but on the forum index the image does not show,
Image
if i right click to open image in new tab i get this:
Image
Image

Paul
Infrastructure Team Leader
Infrastructure Team Leader
Posts: 25708
Joined: Sat Dec 04, 2004 3:44 pm
Location: The netherlands.
Name: Paul Sohier
Contact:

Re: [DEV] Portal Extension for phpBB 3.1.x

Post by Paul »

Add a / between the template variable and theme/
Knock knock
Race condition
Who's there?

My BlogMy Photosmy phpBB Extensionscustom phpBB work & Development

Locked

Return to “Abandoned Extensions”