Page 10 of 16

Re: [DEV] Board Statistics

Posted: Mon May 11, 2015 8:43 pm
by nav56
Any news on this one ?

Re: [DEV] Board Statistics

Posted: Tue May 12, 2015 4:33 pm
by PMVanDomelen
Retried with the Aero Theme installed, still getting same wonky screen with the error codes at top.

That's the latest on my end.

Re: [DEV] Board Statistics

Posted: Tue May 12, 2015 5:08 pm
by Thunder_one
hi

How do I delete the table?

Image

Many Thanks.

Re: [DEV] Board Statistics

Posted: Wed May 13, 2015 6:22 am
by John connor
PMVanDomelen wrote:
John connor wrote:Maybe that is why my prosilver theme was messed up. I use the Aro theme and that works fine. But I now don't have this ext on anymore. I'll have to enable prosilver again and see if I still have the same results.
Do you know where I can find the Aro Theme so I can give it a try? I tried searching through the Styles database here, but couldn't come up with anything.

Sorry about not responding earlier. I don't know why I didn't see this notification. Anyway, I misspelled the theme name it's Aero. Looks like you found it though. I don't use this ext anymore as it was creating a huge log.

Re: [DEV] Board Statistics

Posted: Sun Jun 14, 2015 10:51 am
by Midway
Hi

Have you the this one for phpBB3.0.xx ?

Re: [DEV] Board Statistics

Posted: Mon Jun 15, 2015 7:21 pm
by John connor
The author hasn't responded since last December and if it doesn't say for 3.0 it's not for 3.0. This extension gave me all kinds of problems and I got no response.

Re: [DEV] Board Statistics

Posted: Mon Jun 15, 2015 10:09 pm
by Midway
ok thank you

Re: [DEV] Board Statistics

Posted: Sat Jun 20, 2015 12:18 am
by PMVanDomelen
Is 3.1.0-RC5 still the latest release? In my overview, there are still a hand full of areas that still say Not Yet Implemented.

Just curious if I need an update (or even if there is one available).

Thank you,
-Patrick V.

Re: [DEV] Board Statistics

Posted: Tue Jun 30, 2015 1:23 pm
by wkuzma
I don't use this ext anymore as it was creating a huge log.
I have the same problem of creating a huge admin log I hope it gets fixed before i use it again.

Re: [DEV] Board Statistics

Posted: Tue Jul 14, 2015 2:12 pm
by bahramewe
Very useful extension.
While I'm familiar with the definition of a cron job, I'm unfamiliar with how it applies to forums. So, forgive me if my questions seem ignorant. They probably are.

Is it possible to never reset statistics or only reset them manually? We'd like to have a running total of user visits and their location, etc?

Is it possible to export the information to a file? Possibly a CSV database file or something similar?

Is it possible to ignore certain users? We are using our forum primarily for support, so admin and moderator usage is much heavier than average users and guests. As such, our results are severely skewed by our own visits, edits, and modifications.

Still getting used to some of the functions, but really like the extension so far!

Re: [DEV] Board Statistics

Posted: Sat Aug 08, 2015 10:48 pm
by Puchahawa
Just tried this again after a few months time. downloaded the current version (3.1.0 RC5) and activated it. This on a test board of course. :lol: I have the cron status extension on that board and noticed an interesting entry.

I'm thinking this may have something to do with the extension constantly running the cron to prune stats. Looks like it is having a problem with the dates.

Image

Re: [DEV] Board Statistics

Posted: Sun Aug 09, 2015 6:17 pm
by John P
I finnaly found why this could happen and put a new version on github.
For those who don't want a log, you can switch it off now.

Needs a reinstall or altering the config table and add a boolean collumn named log in it.

Re: [DEV] Board Statistics

Posted: Sun Aug 09, 2015 7:03 pm
by Puchahawa
Things are looking up John. Doing some testing and came across a few issues.

First when I tried to change the log option to enabled I got this error

Code: Select all

General Error
SQL ERROR [ mysqli ]

Champ 'log' inconnu dans field list [1054]

SQL

UPDATE phpbb_statistics_config SET log = "1"

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 855
CALL: trigger_error()

FILE: [ROOT]/phpbb/db/driver/mysqli.php
LINE: 193
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/phpbb/db/driver/factory.php
LINE: 329
CALL: phpbb\db\driver\mysqli->sql_query()

FILE: [ROOT]/ext/forumhulp/statistics/vendor/stat_functions.php
LINE: 1274
CALL: phpbb\db\driver\factory->sql_query()

FILE: [ROOT]/ext/forumhulp/statistics/acp/statistics_module.php
LINE: 159
CALL: stat_functions::config()

FILE: [ROOT]/includes/functions_module.php
LINE: 674
CALL: forumhulp\statistics\acp\statistics_module->main()

FILE: [ROOT]/adm/index.php
LINE: 81
CALL: p_master->load_active()
Second is this minor language issue

Image

Keep up the good work! Your almost there. :D

Re: [DEV] Board Statistics

Posted: Sun Aug 09, 2015 7:15 pm
by John P
Stupid, its uploading

Re: [DEV] Board Statistics

Posted: Sun Aug 09, 2015 8:03 pm
by Puchahawa
Downloaded. Errors gone. Logging enabled. 8-)

For anyone else that is testing the newest version when I disabled the old version to update, I had to delete data too. If I didn't I got the general error again.

Now everything looks to be on track. :D

Will be checking the log over the next few days but it's LOOKING GOOD!

One insignificant thing. The version is showing 3.1.0.RC5 and the board is saying Board Statistics is not up to date - Re-Check version Latest version Version: 3.1.0.RC6

3.1.0.RC6 is what I downloaded. Probably a minor edit somewhere.