[ABD] Board Statistics

Any abandoned Extensions will be moved to this forum.

WARNING: Extensions in this forum are not currently being supported or maintained by the original Extension author. Proceed at your own risk.
Forum rules
IMPORTANT: Extension Development Forum rules

WARNING: Extensions in this forum are not currently being supported nor updated by the original Extension author. Proceed at your own risk.
Locked
User avatar
Puchahawa
Registered User
Posts: 768
Joined: Sat Jan 01, 2011 10:33 pm
Name: Randy

Re: [DEV] Board Statistics

Post by Puchahawa » Mon Sep 07, 2015 4:50 pm

Puchahawa wrote:I do have one question. On the referrer page, all I'm seeing is pages of the board. Is that expected behavior when people go from page to page on the board? It was my understanding that it would show when a person clicked a link to the board from some other site.
John P wrote:@Puchahawa What is your servername?
It search for the servername in referrer and if found it will not log the referrer.
Morning John. Hope your having a good day. Uploaded v7 yesterday and things look good. I'm still having most of the entries on the referrer page showing from the board. I'm not sure what you mean by servername? The board is hosted by wizardofthenorth.ca who gets their space from http://www.canadianwebhosting.com/

If your looking for something else in ref to servername let me know and I'll dig it out for you. It's just the referrer that isn't working for me. everything else is great.

Edit 9/11 to add that the cron job hasn't run since the 8th. :?: I activated the ext on the 6th.
Avatar courtesy of artist Faith Coyotë

User avatar
John P
Registered User
Posts: 1237
Joined: Mon Jan 21, 2008 3:55 pm
Location: Netherlands
Name: John
Contact:

Re: [DEV] Board Statistics

Post by John P » Tue Sep 15, 2015 1:07 pm

The serve name is the domain your forum is running.
Look in ACP General - Server Configuration - Server settings - Domain name
Image
Webhosting, Custom MODs, Technical management, MOD installation and Webdesign

User avatar
Puchahawa
Registered User
Posts: 768
Joined: Sat Jan 01, 2011 10:33 pm
Name: Randy

Re: [DEV] Board Statistics

Post by Puchahawa » Tue Sep 15, 2015 5:15 pm

This could be part of the issue. :lol:

The board was moved last January and the owner never changed the domain to the new server. So the domain is still pointed to the old host with a forward in place to the new host. The entry for the Server settings - Domain name is www.freedomcrowsnest.org. The board is actually at freedomcrowsnest.wizardofthenorth.ca

We've been hoping she would take the time to re-point the domain but she hasn't yet. :x
Avatar courtesy of artist Faith Coyotë

User avatar
John P
Registered User
Posts: 1237
Joined: Mon Jan 21, 2008 3:55 pm
Location: Netherlands
Name: John
Contact:

Re: [DEV] Board Statistics

Post by John P » Thu Sep 17, 2015 1:28 pm

Let us know if the problem stays.
Image
Webhosting, Custom MODs, Technical management, MOD installation and Webdesign

User avatar
Puchahawa
Registered User
Posts: 768
Joined: Sat Jan 01, 2011 10:33 pm
Name: Randy

Re: [DEV] Board Statistics

Post by Puchahawa » Tue Sep 22, 2015 5:27 pm

Morning John, hope your having a great day. Just wanted to check in and let you know that the challenge I was having with the referrer is resolved and the glitch or whatever it was that caused the cron job to not work is resolved. Loving the extension! Thanks for the hard work.

using RC8 on 3.1.6
Avatar courtesy of artist Faith Coyotë

User avatar
John P
Registered User
Posts: 1237
Joined: Mon Jan 21, 2008 3:55 pm
Location: Netherlands
Name: John
Contact:

Re: [DEV] Board Statistics

Post by John P » Wed Sep 23, 2015 6:12 pm

Good to hear, thanks
Image
Webhosting, Custom MODs, Technical management, MOD installation and Webdesign

..777..
Registered User
Posts: 150
Joined: Tue Oct 28, 2014 5:43 pm

Re: [DEV] Board Statistics

Post by ..777.. » Wed Sep 23, 2015 6:48 pm

Installed extension and was really impressed. Except for some reason the search words were not working, and when I went and clicked on "users" it locked my board up for a few minutes. Needless to say I went ahead and uninstalled it.

User avatar
cece74
Registered User
Posts: 498
Joined: Mon Jan 12, 2015 8:55 pm

Re: [DEV] Board Statistics

Post by cece74 » Wed Sep 23, 2015 6:53 pm

It works well, thanks.

..777..
Registered User
Posts: 150
Joined: Tue Oct 28, 2014 5:43 pm

Re: [DEV] Board Statistics

Post by ..777.. » Wed Sep 23, 2015 8:05 pm

..777.. wrote:Installed extension and was really impressed. Except for some reason the search words were not working, and when I went and clicked on "users" it locked my board up for a few minutes. Needless to say I went ahead and uninstalled it.
Definitely want to give it another try though and try to work out the bugs I am having. :D

edit: installed again and here is what i found wrong so far.

-on the last visits page when I click on the link of where the person is at on the forum, its broken, for some reason it leaves out the /forum/ part.

-search terms not showing up

-after the extension ran all night, I woke up this morning and then clicked on "users" and it locked the board up. Thats the first time thats ever happened.

User avatar
alhitary
Registered User
Posts: 868
Joined: Wed Jan 17, 2007 7:51 am
Location: ROY
Name: Basil Taha Alhitary
Contact:

Re: [DEV] Board Statistics

Post by alhitary » Sat Oct 03, 2015 2:24 pm

Maximum records in view display before pagination is in order, in table maximum records for pruning
Can you explain this line plz to I understand it more

Taka51
Registered User
Posts: 22
Joined: Sun Mar 22, 2015 3:26 pm
Location: Reims (51) - France
Contact:

Re: [DEV] Board Statistics

Post by Taka51 » Sun Oct 04, 2015 6:48 pm

Hi,

I end up with an error message that appears at the top of the index finger of my forum my homepage
[phpBB Debug] PHP Warning: in file [ROOT]/ext/forumhulp/statistics/event/listener.php on line 184: fsockopen(): unable to connect to http://www.ip-api.com:80 (Connection refused)
Cordially

jurgis
Registered User
Posts: 11
Joined: Mon May 18, 2015 7:15 pm

Re: [DEV] Board Statistics

Post by jurgis » Mon Oct 05, 2015 3:12 am

Thanks, very useful extension.

Previously i used WP and there was one plugin which shows how many users are using adblock.
I think it is useful information.
Do you plan to add statistics about adblock in your extension?

User avatar
John P
Registered User
Posts: 1237
Joined: Mon Jan 21, 2008 3:55 pm
Location: Netherlands
Name: John
Contact:

Re: [DEV] Board Statistics

Post by John P » Mon Oct 05, 2015 8:21 pm

@alhitary the pagination will have 20 records for example per page, the archive tables are pruned by 200 records for example.

@ Taka51 Seems ip-api.com was offline

@ jurgis i will think about this
Image
Webhosting, Custom MODs, Technical management, MOD installation and Webdesign


User avatar
John P
Registered User
Posts: 1237
Joined: Mon Jan 21, 2008 3:55 pm
Location: Netherlands
Name: John
Contact:

Re: [DEV] Board Statistics

Post by John P » Fri Oct 09, 2015 1:08 pm

Thanks alhitary
Image
Webhosting, Custom MODs, Technical management, MOD installation and Webdesign

Locked

Return to “Abandoned Extensions”