[ABD] Upload Image

Any abandoned Extensions will be moved to this forum.

WARNING: Extensions in this forum are not currently being supported or maintained by the original Extension author. Proceed at your own risk.
Forum rules
IMPORTANT: Extension Development Forum rules

WARNING: Extensions in this forum are not currently being supported nor updated by the original Extension author. Proceed at your own risk.
User avatar
dmzx
Registered User
Posts: 770
Joined: Fri Sep 05, 2014 6:48 am
Location: The Netherlands
Contact:

Re: [DEV] Upload Image

Post by dmzx » Tue Jan 19, 2016 10:46 pm

spaceace wrote:
dmzx wrote:https://github.com/ForumHulp/helper and click on download zip.
Install it as en extension in forumhulp/helper
so you have to install an extra extension to use this one now?

edit: so why not just include it with the extensions?
dunno ask the author ;)
Contact me on dmzx-web.net
 Need a Host or buy me a beer Donate and try binance.com

User avatar
John P
Registered User
Posts: 1237
Joined: Mon Jan 21, 2008 3:55 pm
Location: Netherlands
Name: John
Contact:

Re: [DEV] Upload Image

Post by John P » Fri Jan 29, 2016 2:07 pm

It's because a lot of my extensions use font awesome or highchart for example.
In this way you only need these files once and save space on your server. If the extension needs one or more of these packages it will warn you to also install forumhulp/helper extension. If the forumhulp/helper extension already is installed you can install your extension without problems.
Image
Webhosting, Custom MODs, Technical management, MOD installation and Webdesign

User avatar
Fast_Eddie
Registered User
Posts: 206
Joined: Tue Jun 09, 2015 8:32 pm
Name: Ed

Re: [DEV] Upload Image

Post by Fast_Eddie » Fri Jan 29, 2016 9:07 pm

Do both extensions need to be in the same directory? I have both installed in separate directories

Code: Select all

ext/forumhulp/helper

Code: Select all

ext/forumhulp/uploadimage
And i see no link to upload a image or any mention of it anywhere in the ACP (except for the custom tab)
Would be great if I could get this to work as it sounds very useful! I took a look at your board and made a account. But I can only read English.

User avatar
John P
Registered User
Posts: 1237
Joined: Mon Jan 21, 2008 3:55 pm
Location: Netherlands
Name: John
Contact:

Re: [DEV] Upload Image

Post by John P » Fri Jan 29, 2016 9:11 pm

That's ok, it should look as in the picture on the first page.
Image
Webhosting, Custom MODs, Technical management, MOD installation and Webdesign

User avatar
KlausiMaus
Registered User
Posts: 133
Joined: Sat Nov 15, 2014 4:55 pm

Re: [DEV] Upload Image

Post by KlausiMaus » Sun Feb 07, 2016 2:32 pm

When I try to see details of this extension I get this:

Code: Select all

[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/lock/flock.php on line 74: file_exists(): open_basedir restriction in effect. File(./../cache/data_versioncheck_forumhulp.com-extindex.php?id=40.php.lock) is not within the allowed path(s): (E:/www/vhosts/kuhnert.ch/;C:/Windows/Temp/)
 {"status":"success","action":"details","result":"Upload Extensions<\/a> » Erweiterungen verwalten<\/a> » Upload image<\/strong>\n<\/i><\/a>\n
seems to be the same as in Board Statistics viewtopic.php?f=456&t=2258476&start=195#p14342846
Maybe there is a general fault in your extensions.
Klaus (http://forum.kuhnert.ch/) :: Keep it simple, stupid :!:

User avatar
FuGu
Registered User
Posts: 21
Joined: Fri Nov 05, 2010 10:11 am

Re: [DEV] Upload Image

Post by FuGu » Sun Feb 21, 2016 5:39 pm

The rights of an uploaded image are set to 600... i think this is since the update to 3.1.7-pl1.
Any idea to fix this?

User avatar
supanet
Registered User
Posts: 234
Joined: Sat Dec 15, 2012 4:20 pm
Location: UK
Contact:

Re: [DEV] Upload Image

Post by supanet » Wed Jun 22, 2016 9:26 am

Can you specify a custom folder for the upload, if not would you consider adding this feature?

User avatar
John P
Registered User
Posts: 1237
Joined: Mon Jan 21, 2008 3:55 pm
Location: Netherlands
Name: John
Contact:

Re: [DEV] Upload Image

Post by John P » Fri Jun 24, 2016 8:44 pm

Looking into it
Image
Webhosting, Custom MODs, Technical management, MOD installation and Webdesign

User avatar
John P
Registered User
Posts: 1237
Joined: Mon Jan 21, 2008 3:55 pm
Location: Netherlands
Name: John
Contact:

Re: [DEV] Upload Image

Post by John P » Fri Jun 24, 2016 8:45 pm

Looking into it
Image
Webhosting, Custom MODs, Technical management, MOD installation and Webdesign

User avatar
supanet
Registered User
Posts: 234
Joined: Sat Dec 15, 2012 4:20 pm
Location: UK
Contact:

Re: [DEV] Upload Image

Post by supanet » Sat Jun 25, 2016 2:43 pm

Ok thanks. :D

User avatar
John P
Registered User
Posts: 1237
Joined: Mon Jan 21, 2008 3:55 pm
Location: Netherlands
Name: John
Contact:

Re: [DEV] Upload Image

Post by John P » Fri Jul 01, 2016 8:22 pm

Download from github, see first post.
Image
Webhosting, Custom MODs, Technical management, MOD installation and Webdesign

User avatar
supanet
Registered User
Posts: 234
Joined: Sat Dec 15, 2012 4:20 pm
Location: UK
Contact:

Re: [DEV] Upload Image

Post by supanet » Sun Jul 03, 2016 1:50 pm

still testing :mrgreen:

User avatar
supanet
Registered User
Posts: 234
Joined: Sat Dec 15, 2012 4:20 pm
Location: UK
Contact:

Re: [DEV] Upload Image

Post by supanet » Sun Jul 03, 2016 2:15 pm

Trying to specify a folder outside of the images folder but it still keeps putting it in

Code: Select all

./images/ui/ 

I want it in

Code: Select all

styles/Subway/theme/nivo-slider/images
What am I doing wrong. :?

User avatar
John P
Registered User
Posts: 1237
Joined: Mon Jan 21, 2008 3:55 pm
Location: Netherlands
Name: John
Contact:

Re: [DEV] Upload Image

Post by John P » Tue Jul 05, 2016 8:40 pm

You should not upload in styles folders. If you change your style all links don't work anymore.
That's why it is in images folder in root.
Image
Webhosting, Custom MODs, Technical management, MOD installation and Webdesign

User avatar
supanet
Registered User
Posts: 234
Joined: Sat Dec 15, 2012 4:20 pm
Location: UK
Contact:

Re: [DEV] Upload Image

Post by supanet » Wed Jul 06, 2016 9:24 pm

John P wrote:You should not upload in styles folders. If you change your style all links don't work anymore.
That's why it is in images folder in root.
Well it still doesn't work if I use another folder for the images :( it still puts it in ./images/ui/

However for this extension to do what I want, I need it to store the images in styles/Subway/theme/nivo-slider/images
This way I can let my moderators upload images to the Novo-slider built into my style without having to give them access to the server.
(Images must be in this folder to be displayed on the slider on the index page)

I appreciate all the work you are doing but if this extension cant do this then I will have to look for something else. :(

Locked

Return to “Abandoned Extensions”