[ABD] Advanced SearchBox

Any abandoned Extensions will be moved to this forum.

WARNING: Extensions in this forum are not currently being supported or maintained by the original Extension author. Proceed at your own risk.
Forum rules
IMPORTANT: Extension Development Forum rules

WARNING: Extensions in this forum are not currently being supported nor updated by the original Extension author. Proceed at your own risk.
User avatar
Wolfsblvt
Registered User
Posts: 634
Joined: Sun Oct 26, 2014 9:12 pm
Location: Solingen, Germany
Contact:

Re: [BETA] Advanced SearchBox

Post by Wolfsblvt » Sun Nov 23, 2014 11:56 pm

Yes, I've implemented this check in all of my extensions.
I'd say it is sad that the requirements check is not part of the core. I mean.. We should not change the core, to keep it easy to update. Same goes for extensions. We should provide events in our extensions, so people can extend them. They just have to create a new extension. But in this case, they'll get problems if the extension they are extending gets deactivated. So they have to check in every place of their code and validate that it is working. And then, the problems with different versions.. what if you update the extension and that causes problems with one dependency?

So yeah, for advanced searchbox it is maybe not needed, you are right. But for other extensions it should be.
Maybe I can change the code so that it only write "its dependecies" if there were some, otherwise use the normal text.
If you have a specific extension request and you are willing to pay for, you can write me a PM.
My extensions (Trending: @Mention SystemAdvanced PollsUser Online Time)

»Du kamst zu uns. Deine Stimme kam. Du zeigtest uns die Sterne. Sie funkelten. Wir konnten sehen.«

User avatar
Jessica
Former Team Member
Posts: 4341
Joined: Sun Jul 18, 2010 2:53 pm
Location: Pennsylvania, USA
Name: Jessica
Contact:

Re: [BETA] Advanced SearchBox

Post by Jessica » Mon Nov 24, 2014 1:27 am

Looks very cool. Will try it out when I find the time

EDIT: This extension seems to change the styling of the breadcrumb menu from the Breadcrumb Menu Extension...
Please do not PM me for support unless it is absolutely necessary
Pro-choice, Atheist, Pro-LGBT rights

Everybody is a genius. But if you judge a fish by its ability to climb a tree, it will live its whole life believing that it is stupid. - Albert Einstein

User avatar
Wolfsblvt
Registered User
Posts: 634
Joined: Sun Oct 26, 2014 9:12 pm
Location: Solingen, Germany
Contact:

Re: [BETA] Advanced SearchBox

Post by Wolfsblvt » Mon Nov 24, 2014 8:03 am

Jessica wrote:EDIT: This extension seems to change the styling of the breadcrumb menu from the Breadcrumb Menu Extension...
Can you post a screenshot maybe, or better link the test forum? Or post a link of this extension. I'll check it out then. I would say it can be cause of jQueryUI. Does this extension use it?
If you have a specific extension request and you are willing to pay for, you can write me a PM.
My extensions (Trending: @Mention SystemAdvanced PollsUser Online Time)

»Du kamst zu uns. Deine Stimme kam. Du zeigtest uns die Sterne. Sie funkelten. Wir konnten sehen.«

leschek
Registered User
Posts: 789
Joined: Tue Jul 18, 2006 12:49 pm
Contact:

Re: [BETA] Advanced SearchBox

Post by leschek » Mon Nov 24, 2014 2:49 pm

Wolfsblvt wrote:...
Maybe I can change the code so that it only write "its dependecies" if there were some, otherwise use the normal text.
That would be great.

leschek
Registered User
Posts: 789
Joined: Tue Jul 18, 2006 12:49 pm
Contact:

Re: [BETA] Advanced SearchBox

Post by leschek » Thu Nov 27, 2014 11:10 am

After update to phpBB 3.1.2 I'm not able to enable your core extension (I disabled it, because I have this problem). When I try to enable it I get:
The selected extension cannot be enabled, please verify the extension’s requirements.
I'm using php 5.4.31, so it should be OK.

User avatar
Wolfsblvt
Registered User
Posts: 634
Joined: Sun Oct 26, 2014 9:12 pm
Location: Solingen, Germany
Contact:

Re: [BETA] Advanced SearchBox

Post by Wolfsblvt » Thu Nov 27, 2014 11:29 am

I'll take a look into it later today. I haven't installed 3.1.2, so I need to check that first.
Let's hope it is a small problem.

Otherwise I just can tell you to wait. After a few talks with members of the Extension Team I decided to get rid of the core extension and include all needed stuff in the extension itself. This can take some time, so I can't promise a date.
If you have a specific extension request and you are willing to pay for, you can write me a PM.
My extensions (Trending: @Mention SystemAdvanced PollsUser Online Time)

»Du kamst zu uns. Deine Stimme kam. Du zeigtest uns die Sterne. Sie funkelten. Wir konnten sehen.«

leschek
Registered User
Posts: 789
Joined: Tue Jul 18, 2006 12:49 pm
Contact:

Re: [BETA] Advanced SearchBox

Post by leschek » Thu Nov 27, 2014 11:45 am

Wolfsblvt wrote:After a few talks with members of the Extension Team I decided to get rid of the core extension and include all needed stuff in the extension itself. This can take some time, so I can't promise a date.
No worries, take your time.

User avatar
Jessica
Former Team Member
Posts: 4341
Joined: Sun Jul 18, 2010 2:53 pm
Location: Pennsylvania, USA
Name: Jessica
Contact:

Re: [BETA] Advanced SearchBox

Post by Jessica » Thu Nov 27, 2014 4:28 pm

Wolfsblvt wrote:
Jessica wrote:EDIT: This extension seems to change the styling of the breadcrumb menu from the Breadcrumb Menu Extension...
Can you post a screenshot maybe, or better link the test forum? Or post a link of this extension. I'll check it out then. I would say it can be cause of jQueryUI. Does this extension use it?
viewtopic.php?f=456&t=2238161

Before this extension (Advanced SearchBox) is installed, the menu looks like the screenshot posted in the above link's first post. But after Advanced Searchbox is installed, it changes to look more like the menu of the advanced search.
Please do not PM me for support unless it is absolutely necessary
Pro-choice, Atheist, Pro-LGBT rights

Everybody is a genius. But if you judge a fish by its ability to climb a tree, it will live its whole life believing that it is stupid. - Albert Einstein

User avatar
Wolfsblvt
Registered User
Posts: 634
Joined: Sun Oct 26, 2014 9:12 pm
Location: Solingen, Germany
Contact:

Re: [BETA] Advanced SearchBox

Post by Wolfsblvt » Thu Nov 27, 2014 5:39 pm

This extension includes jquery-ui too, without checking if it is already included.
That's a problem that will be difficult to handle in 3.1, there is no good way to solve this.

If I find a bit time, I'll install this extension and try to check if there is a way to solve this.

The point is, the Breadcrumb Menu Extension uses the jQueryUI menu, wich I use for the advanced searchbox too. My extension also includes a style for this extension, wich is applied to all jQueryUI menus. (Thats the jQuery UI theming)
So it will be difficult to get different looking menus.
If you have a specific extension request and you are willing to pay for, you can write me a PM.
My extensions (Trending: @Mention SystemAdvanced PollsUser Online Time)

»Du kamst zu uns. Deine Stimme kam. Du zeigtest uns die Sterne. Sie funkelten. Wir konnten sehen.«

User avatar
Lumpy Burgertushie
Registered User
Posts: 66238
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: [BETA] Advanced SearchBox

Post by Lumpy Burgertushie » Thu Nov 27, 2014 6:03 pm

you might want to change the language file . there are no "threads" in phpbb. there are topics and posts


robert
I am available for custom work on a donation basis. Please send me a PM with your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

OK, so what's the speed of dark?

FrankPereiro
Registered User
Posts: 59
Joined: Tue Nov 16, 2004 3:36 pm
Location: Spain

Re: [BETA] Advanced SearchBox

Post by FrankPereiro » Wed Jan 28, 2015 10:59 am

Hi there, I love your ext's

There are a couple con ext's that's giving me errors. One is the "Advanced SerachBox" ext (version 1.0.1):

Code: Select all

Parse error: syntax error, unexpected '(' in /**********/ext/wolfsblvt/advancedsearchbox/ext.php on line 64
And the other is the "Wolsblvt's Library - Core Functions" ext (version 1.0.0) as well:

Code: Select all

Parse error: syntax error, unexpected '[' in /**********/ext/wolfsblvt/core/core/requirements_helper.php on line 125
Am I doing something wrong?

User avatar
Wolfsblvt
Registered User
Posts: 634
Joined: Sun Oct 26, 2014 9:12 pm
Location: Solingen, Germany
Contact:

Re: [BETA] Advanced SearchBox

Post by Wolfsblvt » Wed Jan 28, 2015 11:53 am

FrankPereiro wrote:Hi there, I love your ext's
Thank you :D
FrankPereiro wrote:Am I doing something wrong?
Yes and no.
This extension requires PHP 5.4 to work. I think you don't have that installed so this lines aren't used correctly.

As I have mentioned already (I hope I have) I will rework this extension, and cut it from the core extension. This extension will work standalone. I will improve some features as well and fix some problems.
So somewhere soon I'll release the next version of this extension.
But I won't go for PHP 5.3, so you have to have at least 5.4.
If you have a specific extension request and you are willing to pay for, you can write me a PM.
My extensions (Trending: @Mention SystemAdvanced PollsUser Online Time)

»Du kamst zu uns. Deine Stimme kam. Du zeigtest uns die Sterne. Sie funkelten. Wir konnten sehen.«

FrankPereiro
Registered User
Posts: 59
Joined: Tue Nov 16, 2004 3:36 pm
Location: Spain

Re: [BETA] Advanced SearchBox

Post by FrankPereiro » Wed Jan 28, 2015 11:59 am

Wolfsblvt wrote:But I won't go for PHP 5.3, so you have to have at least 5.4.
Ok, sound great. I'll keep that in mind.

Thanks, great work!!!

Paul
Infrastructure Team Leader
Infrastructure Team Leader
Posts: 25182
Joined: Sat Dec 04, 2004 3:44 pm
Location: The netherlands.
Name: Paul Sohier
Contact:

Re: [ABD] Advanced SearchBox

Post by Paul » Tue Oct 06, 2015 1:06 pm

This topic has been marked as [ABD] - Abandoned as the extension author has not been active recently. If the extension author wishes to continue development, please PM anyone on the Extensions Team to request this topic be unlocked.

Notice!
We do not recommend that a user of the phpBB software install this extension, or any other extension that is marked as “abandoned” or “in development”, on a live forum. Doing so may cause your forum to not perform in the manner it should.


Thank you,
The phpBB Extensions Team
Knock knock
Race condition
Who's there?

My BlogMy Photosmy phpBB Extensionscustom phpBB work & Development

Locked

Return to “Abandoned Extensions”