[ABD] @Mention System

Any abandoned Extensions will be moved to this forum.

WARNING: Extensions in this forum are not currently being supported or maintained by the original Extension author. Proceed at your own risk.
Forum rules
IMPORTANT: Extension Development Forum rules

WARNING: Extensions in this forum are not currently being supported nor updated by the original Extension author. Proceed at your own risk.
User avatar
Oroton
Registered User
Posts: 70
Joined: Wed Oct 17, 2012 10:40 am

Re: [DEV] @Mention System

Post by Oroton » Sat Apr 25, 2015 2:32 pm

sorry, I meant 3.1.4 isn't stable.

And 3.1.3 is the current release.

still having trouble because of the prerequisites.

open composer.json

Find

Code: Select all


	"require": {
		"php": ">=5.4.0"
	},
	"extra": {
		"display-name": "@Mention System",
		"soft-require": {
			"phpbb/phpbb": ">=3.1.4,<3.2.*@dev"

Replace

Code: Select all

	"require": {
		"php": ">=5.3.0"
	},
	"extra": {
		"display-name": "@Mention System",
		"soft-require": {
			"phpbb/phpbb": ">=3.1.3,<3.2.*@dev"
Now it's working perfectly. Except for the avatars section on load.

It doesn't bring the dropdown on quick reply but it does parse it when it's posted.

User avatar
Wolfsblvt
Registered User
Posts: 634
Joined: Sun Oct 26, 2014 9:12 pm
Location: Solingen, Germany
Contact:

Re: [DEV] @Mention System

Post by Wolfsblvt » Sat Apr 25, 2015 10:55 pm

Oroton wrote:It doesn't bring the dropdown on quick reply but it does parse it when it's posted.
Strange, thought it should still be 3.1.3, but okay, thanks for the mention.

Quick reply isn't working, currently. My goal was to add the full functionality and let it be tested by people as a development version. Wich is done now.
I will fix all the mentioned problems in the future and release a new dev version. If this is more stable, I will add the missing features (like quick reply), and then release the extension (:
If you have a specific extension request and you are willing to pay for, you can write me a PM.
My extensions (Trending: @Mention SystemAdvanced PollsUser Online Time)

»Du kamst zu uns. Deine Stimme kam. Du zeigtest uns die Sterne. Sie funkelten. Wir konnten sehen.«

User avatar
Oroton
Registered User
Posts: 70
Joined: Wed Oct 17, 2012 10:40 am

Re: [DEV] @Mention System

Post by Oroton » Sat Apr 25, 2015 10:59 pm

honestly i don't mind it not working in quick reply. it makes it quicker.

It is complient for 3.1.4, but i edited the composer, to allow it to install on my 3.1.3 board.

And it is working.

ONLY thing is, I Don't like the format

"@" "Avatar" "username"

Would prefere

"@" "Username" "Avatar"

Would look cleaner for those that don't have avatars.

Beautiful work.

Also, as a side note, i couldn't install your 'core' either.

User avatar
Wolfsblvt
Registered User
Posts: 634
Joined: Sun Oct 26, 2014 9:12 pm
Location: Solingen, Germany
Contact:

Re: [DEV] @Mention System

Post by Wolfsblvt » Sat Apr 25, 2015 11:34 pm

Oroton wrote:Would look cleaner for those that don't have avatars.

Beautiful work.
Avaters in posts can be disabled in ACP with a simple option.
Users with no avatars should have a default avatar displayed. There is a bug with that, that will be fixed.

I have put the avatar in front of it, cause it is the same in prosilver header for the logged in user, and it seems like this is the general format, if avatar is displayed.

Thank you (:
Oroton wrote:Also, as a side note, i couldn't install your 'core' either.
Core is "deprecated" and will be removed from all of my extensions in the future.
If you have a specific extension request and you are willing to pay for, you can write me a PM.
My extensions (Trending: @Mention SystemAdvanced PollsUser Online Time)

»Du kamst zu uns. Deine Stimme kam. Du zeigtest uns die Sterne. Sie funkelten. Wir konnten sehen.«

User avatar
Oroton
Registered User
Posts: 70
Joined: Wed Oct 17, 2012 10:40 am

Re: [DEV] @Mention System

Post by Oroton » Sat Apr 25, 2015 11:39 pm

no worries,

Good news about the core then.

I like the look of your mods, they seem simple but very useful.

I am now running this live on my 3.1.3 board.

Everything seems to be working fine for the moment.

User avatar
Wolfsblvt
Registered User
Posts: 634
Joined: Sun Oct 26, 2014 9:12 pm
Location: Solingen, Germany
Contact:

Re: [DEV] @Mention System

Post by Wolfsblvt » Sat Apr 25, 2015 11:40 pm

Oroton wrote:Everything seems to be working fine for the moment.
Great to hear (:
This extension here will even work better in the future, when I have reworked the stuff :P
If you have a specific extension request and you are willing to pay for, you can write me a PM.
My extensions (Trending: @Mention SystemAdvanced PollsUser Online Time)

»Du kamst zu uns. Deine Stimme kam. Du zeigtest uns die Sterne. Sie funkelten. Wir konnten sehen.«

pjpjr6
Registered User
Posts: 9
Joined: Tue Mar 24, 2015 9:48 pm

Re: [DEV] @Mention System

Post by pjpjr6 » Wed Apr 29, 2015 2:07 am

How do I fix this issue?

Image

We don't use avatars.

Willeos
Registered User
Posts: 35
Joined: Fri Feb 27, 2015 11:26 pm

Re: [DEV] @Mention System

Post by Willeos » Wed Apr 29, 2015 2:16 am

It works in Mchat, but doesn't work in posts. Is it normal? Link to my foru, : http://gamingfx.890m.com
Don't mind- though it would be fun to have a preview of what we wright, cause when I click preview, I only see the BBCode.

User avatar
Oroton
Registered User
Posts: 70
Joined: Wed Oct 17, 2012 10:40 am

Re: [DEV] @Mention System

Post by Oroton » Wed Apr 29, 2015 9:49 am

pjpjr6 wrote:How do I fix this issue?

Image

We don't use avatars.

you can't atm i believe it's addressed in the next update.

Willeos
Registered User
Posts: 35
Joined: Fri Feb 27, 2015 11:26 pm

Re: [DEV] @Mention System

Post by Willeos » Wed Apr 29, 2015 11:49 am

Oroton wrote:
pjpjr6 wrote:How do I fix this issue?

Image

We don't use avatars.

you can't atm i believe it's addressed in the next update.
You CAN disable avatars though in the extension bar in ACP. ACP -> EXTENSION -> @Mention -> Disable use of bpavatars

pjpjr6
Registered User
Posts: 9
Joined: Tue Mar 24, 2015 9:48 pm

Re: [DEV] @Mention System

Post by pjpjr6 » Wed Apr 29, 2015 12:21 pm

Willeos wrote:
Oroton wrote:
pjpjr6 wrote:How do I fix this issue?

Image

We don't use avatars.

you can't atm i believe it's addressed in the next update.
You CAN disable avatars though in the extension bar in ACP. ACP -> EXTENSION -> @Mention -> Disable use of bpavatars
I did that and I'm still getting that same issue.

User avatar
Wolfsblvt
Registered User
Posts: 634
Joined: Sun Oct 26, 2014 9:12 pm
Location: Solingen, Germany
Contact:

Re: [DEV] @Mention System

Post by Wolfsblvt » Wed Apr 29, 2015 12:27 pm

pjpjr6 wrote:I did that and I'm still getting that same issue.
This will be fixed in the next version.
If you have a specific extension request and you are willing to pay for, you can write me a PM.
My extensions (Trending: @Mention SystemAdvanced PollsUser Online Time)

»Du kamst zu uns. Deine Stimme kam. Du zeigtest uns die Sterne. Sie funkelten. Wir konnten sehen.«

pjpjr6
Registered User
Posts: 9
Joined: Tue Mar 24, 2015 9:48 pm

Re: [DEV] @Mention System

Post by pjpjr6 » Wed Apr 29, 2015 12:32 pm

Dumb question that I'm sure has been asked...when is the next version?

User avatar
Wolfsblvt
Registered User
Posts: 634
Joined: Sun Oct 26, 2014 9:12 pm
Location: Solingen, Germany
Contact:

Re: [DEV] @Mention System

Post by Wolfsblvt » Wed Apr 29, 2015 12:54 pm

pjpjr6 wrote:Dumb question that I'm sure has been asked...when is the next version?
It's done when it's done :P
Sorry, I can't give you an exact time.
If you have a specific extension request and you are willing to pay for, you can write me a PM.
My extensions (Trending: @Mention SystemAdvanced PollsUser Online Time)

»Du kamst zu uns. Deine Stimme kam. Du zeigtest uns die Sterne. Sie funkelten. Wir konnten sehen.«

Khaos-Rage
Registered User
Posts: 71
Joined: Sun Jul 13, 2008 4:31 am

Re: [DEV] @Mention System

Post by Khaos-Rage » Wed May 13, 2015 8:21 pm

So I'm using your extension on my site (Yes, my responsibility for using an in development extension on a live board ;) ).

I have found a bug in that a certain user, on our forums, has the | 'pipe' character in his name and if you use the @mention the user it errors out (white screen) the topic page that the post was on, ONLY if the poster types text after the @mention that contains the | 'pipe' character. Using the [mention] bbcode works fine, and you can type text after the mention that way.

This is the error in the apache server log.

Code: Select all

PHP Fatal error:  Maximum execution time of 30 seconds exceeded in /.truncated./includes/utf/utf_tools.php on line 1843

Locked

Return to “Abandoned Extensions”