Page 18 of 21

Re: [DEV] @Mention System

Posted: Sat Apr 25, 2015 2:32 pm
by Oroton
sorry, I meant 3.1.4 isn't stable.

And 3.1.3 is the current release.

still having trouble because of the prerequisites.

open composer.json

Find

Code: Select all


	"require": {
		"php": ">=5.4.0"
	},
	"extra": {
		"display-name": "@Mention System",
		"soft-require": {
			"phpbb/phpbb": ">=3.1.4,<3.2.*@dev"

Replace

Code: Select all

	"require": {
		"php": ">=5.3.0"
	},
	"extra": {
		"display-name": "@Mention System",
		"soft-require": {
			"phpbb/phpbb": ">=3.1.3,<3.2.*@dev"
Now it's working perfectly. Except for the avatars section on load.

It doesn't bring the dropdown on quick reply but it does parse it when it's posted.

Re: [DEV] @Mention System

Posted: Sat Apr 25, 2015 10:55 pm
by Wolfsblvt
Oroton wrote:It doesn't bring the dropdown on quick reply but it does parse it when it's posted.
Strange, thought it should still be 3.1.3, but okay, thanks for the mention.

Quick reply isn't working, currently. My goal was to add the full functionality and let it be tested by people as a development version. Wich is done now.
I will fix all the mentioned problems in the future and release a new dev version. If this is more stable, I will add the missing features (like quick reply), and then release the extension (:

Re: [DEV] @Mention System

Posted: Sat Apr 25, 2015 10:59 pm
by Oroton
honestly i don't mind it not working in quick reply. it makes it quicker.

It is complient for 3.1.4, but i edited the composer, to allow it to install on my 3.1.3 board.

And it is working.

ONLY thing is, I Don't like the format

"@" "Avatar" "username"

Would prefere

"@" "Username" "Avatar"

Would look cleaner for those that don't have avatars.

Beautiful work.

Also, as a side note, i couldn't install your 'core' either.

Re: [DEV] @Mention System

Posted: Sat Apr 25, 2015 11:34 pm
by Wolfsblvt
Oroton wrote:Would look cleaner for those that don't have avatars.

Beautiful work.
Avaters in posts can be disabled in ACP with a simple option.
Users with no avatars should have a default avatar displayed. There is a bug with that, that will be fixed.

I have put the avatar in front of it, cause it is the same in prosilver header for the logged in user, and it seems like this is the general format, if avatar is displayed.

Thank you (:
Oroton wrote:Also, as a side note, i couldn't install your 'core' either.
Core is "deprecated" and will be removed from all of my extensions in the future.

Re: [DEV] @Mention System

Posted: Sat Apr 25, 2015 11:39 pm
by Oroton
no worries,

Good news about the core then.

I like the look of your mods, they seem simple but very useful.

I am now running this live on my 3.1.3 board.

Everything seems to be working fine for the moment.

Re: [DEV] @Mention System

Posted: Sat Apr 25, 2015 11:40 pm
by Wolfsblvt
Oroton wrote:Everything seems to be working fine for the moment.
Great to hear (:
This extension here will even work better in the future, when I have reworked the stuff :P

Re: [DEV] @Mention System

Posted: Wed Apr 29, 2015 2:07 am
by pjpjr6
How do I fix this issue?

Image

We don't use avatars.

Re: [DEV] @Mention System

Posted: Wed Apr 29, 2015 2:16 am
by Willeos
It works in Mchat, but doesn't work in posts. Is it normal? Link to my foru, : http://gamingfx.890m.com
Don't mind- though it would be fun to have a preview of what we wright, cause when I click preview, I only see the BBCode.

Re: [DEV] @Mention System

Posted: Wed Apr 29, 2015 9:49 am
by Oroton
pjpjr6 wrote:How do I fix this issue?

Image

We don't use avatars.

you can't atm i believe it's addressed in the next update.

Re: [DEV] @Mention System

Posted: Wed Apr 29, 2015 11:49 am
by Willeos
Oroton wrote:
pjpjr6 wrote:How do I fix this issue?

Image

We don't use avatars.

you can't atm i believe it's addressed in the next update.
You CAN disable avatars though in the extension bar in ACP. ACP -> EXTENSION -> @Mention -> Disable use of bpavatars

Re: [DEV] @Mention System

Posted: Wed Apr 29, 2015 12:21 pm
by pjpjr6
Willeos wrote:
Oroton wrote:
pjpjr6 wrote:How do I fix this issue?

Image

We don't use avatars.

you can't atm i believe it's addressed in the next update.
You CAN disable avatars though in the extension bar in ACP. ACP -> EXTENSION -> @Mention -> Disable use of bpavatars
I did that and I'm still getting that same issue.

Re: [DEV] @Mention System

Posted: Wed Apr 29, 2015 12:27 pm
by Wolfsblvt
pjpjr6 wrote:I did that and I'm still getting that same issue.
This will be fixed in the next version.

Re: [DEV] @Mention System

Posted: Wed Apr 29, 2015 12:32 pm
by pjpjr6
Dumb question that I'm sure has been asked...when is the next version?

Re: [DEV] @Mention System

Posted: Wed Apr 29, 2015 12:54 pm
by Wolfsblvt
pjpjr6 wrote:Dumb question that I'm sure has been asked...when is the next version?
It's done when it's done :P
Sorry, I can't give you an exact time.

Re: [DEV] @Mention System

Posted: Wed May 13, 2015 8:21 pm
by Khaos-Rage
So I'm using your extension on my site (Yes, my responsibility for using an in development extension on a live board ;) ).

I have found a bug in that a certain user, on our forums, has the | 'pipe' character in his name and if you use the @mention the user it errors out (white screen) the topic page that the post was on, ONLY if the poster types text after the @mention that contains the | 'pipe' character. Using the [mention] bbcode works fine, and you can type text after the mention that way.

This is the error in the apache server log.

Code: Select all

PHP Fatal error:  Maximum execution time of 30 seconds exceeded in /.truncated./includes/utf/utf_tools.php on line 1843