[ABD] WP Phpbb Unicorn - bridges

Any abandoned Extensions will be moved to this forum.

WARNING: Extensions in this forum are not currently being supported or maintained by the original Extension author. Proceed at your own risk.
Forum rules
IMPORTANT: Extension Development Forum rules

WARNING: Extensions in this forum are not currently being supported nor updated by the original Extension author. Proceed at your own risk.
Locked
defer
Registered User
Posts: 7
Joined: Sun Sep 20, 2015 3:34 pm

Re: [ALPHA] WP Phpbb Unicorn - bridges

Post by defer » Wed Sep 23, 2015 7:40 pm

Hello, me too returns the same error (in addition to those already mentioned).

mijean
Registered User
Posts: 26
Joined: Tue Sep 08, 2015 8:42 am

Re: [ALPHA] WP Phpbb Unicorn - bridges

Post by mijean » Thu Sep 24, 2015 9:53 am

hello,

I manually added CACHE directory under the INC directory.
So the 3 files are created without error.
Only 3 information messages (see below)
But always the problem with UCP?

and after the bridge don't work.

Best regards

Warning: unlink(/home/www/f22ac1c930210554683e86017ef32597/web/test/wordpress/wp-content/plugins/wpbbu/inc/cache/functions_content.php): No such file or directory in /home/www/f22ac1c930210554683e86017ef32597/web/test/wordpress/wp-content/plugins/wpbbu/inc/Proxy.php on line 8

Warning: unlink(/home/www/f22ac1c930210554683e86017ef32597/web/test/wordpress/wp-content/plugins/wpbbu/inc/cache/common.php): No such file or directory in /home/www/f22ac1c930210554683e86017ef32597/web/test/wordpress/wp-content/plugins/wpbbu/inc/Proxy.php on line 9

Warning: unlink(/home/www/f22ac1c930210554683e86017ef32597/web/test/wordpress/wp-content/plugins/wpbbu/inc/cache/functions_user.php): No such file or directory in /home/www/f22ac1c930210554683e86017ef32597/web/test/wordpress/wp-content/plugins/wpbbu/inc/Proxy.php on line 10
WP phpBB Bridge - Settings

The folder ucp does not exists in the path you have enter

mijean
Registered User
Posts: 26
Joined: Tue Sep 08, 2015 8:42 am

Re: [ALPHA] WP Phpbb Unicorn - bridges

Post by mijean » Thu Sep 24, 2015 9:59 am

If I try again setting the plugin WP: no information messages. (normal because the files exist ...)
Only UCP problem.
And nothing happens with the bridge
WP phpBB Bridge - Settings

The folder ucp does not exists in the path you have enter

mijean
Registered User
Posts: 26
Joined: Tue Sep 08, 2015 8:42 am

Re: [ALPHA] WP Phpbb Unicorn - bridges

Post by mijean » Fri Sep 25, 2015 10:50 am

Sorry for disturbing.
The problem is that I have a .htaccess file that protects the testing site.
Without the .htaccess works!
Why not change the validation of the URL?
Thank you

Wardormeur
Registered User
Posts: 142
Joined: Sun Jan 27, 2013 9:22 am

Re: [ALPHA] WP Phpbb Unicorn - bridges

Post by Wardormeur » Fri Sep 25, 2015 12:57 pm

Hey Mijean,
Sorry for the delay, quite busy weeks.
The validation is done upon a header() request, to valid the presence of the file. We need an url here to validate it (because that's what's used afterwards :)) so no real alternative I can come with atm.
If you have any advice, i'm taking :)
BTW :
i was supposed to have fixed the /inc directory issue, I'll look at it again : git doesn't allow by default empty folders, so we're gonna hack through :)

elawrenc
Registered User
Posts: 121
Joined: Thu Jul 21, 2011 2:41 pm

Re: [ALPHA] WP Phpbb Unicorn - bridges

Post by elawrenc » Fri Sep 25, 2015 1:04 pm

In the ACP, if you do not provide a correct URL, it breaks the extension and there are errors on the ACP. Not good.
So really what is needed is codE to handle the error gracefully and just give display some text "File not found!"

Otherwise, I have to deactivate the extension, Delete Date and then re-enable it and try again.


For me, the user parts work and I even see the widgets for forum "Latest Posts" in Wordpress. Very nice!


Avatar is broken but you had already mentioned that. It would be nice to see it working in the future.
:D

mijean
Registered User
Posts: 26
Joined: Tue Sep 08, 2015 8:42 am

Re: [ALPHA] WP Phpbb Unicorn - bridges

Post by mijean » Fri Sep 25, 2015 1:17 pm

Thanks for the reply, Wardormeur
I have yet solved the problem by changing your is_url_ok () function.
She always returns True ....
So I can continue testing.
I can not remove the .htaccess
I send you a PM in french in a few days.
Thanks

defer
Registered User
Posts: 7
Joined: Sun Sep 20, 2015 3:34 pm

Re: [ALPHA] WP Phpbb Unicorn - bridges

Post by defer » Fri Sep 25, 2015 1:39 pm

Hello Wardormeur, suggested change from Mijean is fine for my case?

Wardormeur
Registered User
Posts: 142
Joined: Sun Jan 27, 2013 9:22 am

Re: [ALPHA] WP Phpbb Unicorn - bridges

Post by Wardormeur » Sat Sep 26, 2015 8:07 am

@Defer : it's not related, no. I'm looking at it right now, should have a fix for that and the empty folder by this WE normally

Wardormeur
Registered User
Posts: 142
Joined: Sun Jan 27, 2013 9:22 am

Re: [ALPHA] WP Phpbb Unicorn - bridges

Post by Wardormeur » Sun Sep 27, 2015 10:15 am

Hey
Update : fix for php 5.5 to avoid namespace warnings in proxifier classes
fix for the avatar to display "sortof properly" -> mijean, can you confirm it also works for you? I'm having some doubt with your htaccess usage
Fix to change disconnection redirection to /blog instead of /forum on widgets
Fix to add the cache directory even if "sortof" empty

elawrenc
Registered User
Posts: 121
Joined: Thu Jul 21, 2011 2:41 pm

Re: [ALPHA] WP Phpbb Unicorn - bridges

Post by elawrenc » Sun Sep 27, 2015 6:44 pm

When I tried to deactivate the plugin in Wordpress, got the following error:

Fatal error: Call to undefined method Unicorn::remove_permission() in /home/xxxxxx/public_html/blog/wp-content/plugins/wpphpbbunicorn/wpphpbbunicorn.php on line 270

defer
Registered User
Posts: 7
Joined: Sun Sep 20, 2015 3:34 pm

Re: [ALPHA] WP Phpbb Unicorn - bridges

Post by defer » Sun Sep 27, 2015 8:25 pm

Hi Wardormeur,

I upgraded wordpress plugin, but when active keeps me from login redirects to the login in the forum.
In addition on phpbb when I try to import users wordpress I receive the errors that you see in the image. They are still the errors in the header.

What can I do? it is possible that the wordpress theme is not compatible?

Image
Image

Wardormeur
Registered User
Posts: 142
Joined: Sun Jan 27, 2013 9:22 am

Re: [ALPHA] WP Phpbb Unicorn - bridges

Post by Wardormeur » Sun Sep 27, 2015 9:35 pm

Okay, sorry, I didn't get you were speaking of the phpbbToWp plugin, and not the opposite. I'll fix this warning also for the phpbb plugin.

Regarding the login on WP, it's the behavior researched : so that users are shared between phpbb & WP. However I understand it's unconvenient not to have both WP login & phpbb Login on WP, I'll be searching it once it'll be more stable

mijean
Registered User
Posts: 26
Joined: Tue Sep 08, 2015 8:42 am

Re: [ALPHA] WP Phpbb Unicorn - bridges

Post by mijean » Mon Sep 28, 2015 8:17 am

hello
mijean, can you confirm it also works for you? I'm having some doubt with your htaccess usage
Yes it's OK for avatar with .htaccess and without.

But problem with the widget "last post on the forum" (with and without .htaccess)
There is a mix between PHPBB absolute path and site root.

Example :
"http://test.rm-asso.org/home/www/xxxxxx ... p/?f=3&t=6"

Another thing to do: Rename the language files (wpphpbbu.po)
wpbbu.po not working !

I continue my tests !
Last edited by mijean on Tue Sep 29, 2015 7:10 am, edited 1 time in total.

elawrenc
Registered User
Posts: 121
Joined: Thu Jul 21, 2011 2:41 pm

Re: [ALPHA] WP Phpbb Unicorn - bridges

Post by elawrenc » Mon Sep 28, 2015 6:22 pm

When I updated the WORPRESS plugin, my last error went away. It will deactivate and re-activate with no problem.

Locked

Return to “Abandoned Extensions”