[ABD] Advanced Polls 1.2

Any abandoned Extensions will be moved to this forum.

WARNING: Extensions in this forum are not currently being supported or maintained by the original Extension author. Proceed at your own risk.
Forum rules
IMPORTANT: Extension Development Forum rules

WARNING: Extensions in this forum are not currently being supported nor updated by the original Extension author. Proceed at your own risk.
Locked
User avatar
javiexin
Code Contributor
Posts: 1157
Joined: Wed Oct 12, 2011 11:46 pm
Location: Madrid, Spain
Name: Javier
Contact:

Re: [BETA] Advanced Polls 1.2

Post by javiexin » Wed Aug 05, 2015 1:23 am

But having the duplicate means that the Javascript is not working correctly for scoring either.

Ok, I will look for alternatives that do not require JS for this, as it might be cumbersome in some cases (like this one). But it won't be too short term, as it requires major rewrite of the template code. I have to say that it works perfectly in my test system with both prosilver and pbtech with javascript, but, I will look for alternatives. In the meantime, do not turn on poll end.

-javiexin

rrbailey89
Registered User
Posts: 248
Joined: Fri Oct 24, 2014 3:00 pm

Re: [BETA] Advanced Polls 1.2

Post by rrbailey89 » Wed Aug 05, 2015 1:50 am

javiexin wrote:But having the duplicate means that the Javascript is not working correctly for scoring either.

Ok, I will look for alternatives that do not require JS for this, as it might be cumbersome in some cases (like this one). But it won't be too short term, as it requires major rewrite of the template code. I have to say that it works perfectly in my test system with both prosilver and pbtech with javascript, but, I will look for alternatives. In the meantime, do not turn on poll end.

-javiexin
Thank you for looking into this. I'm curious if others have had the same issues.. I'm also curious why it works in your system but not mine lol.

Either way thank you.

User avatar
javiexin
Code Contributor
Posts: 1157
Joined: Wed Oct 12, 2011 11:46 pm
Location: Madrid, Spain
Name: Javier
Contact:

Re: [BETA] Advanced Polls 1.2

Post by javiexin » Wed Aug 05, 2015 10:37 am

I think I have identified the problem with your installation, and the reason why this was not working.

Your file ext/wolfsblvt/advancedpolls/styles/prosilver/template/lib/jxtools.js is broken.
Well, not really, it only has all the line endings stripped, and that means that all code is commented out, so that is why it is not executing.

Remove the file from your system, and copy a new, fresh copy of that file. Make sure that it has appropriate line endings for your hosting OS, but at least, it HAS line endings.

When you do that, enable everything and test again. It should work. Hope this time is the good one. Sorry for making you test so much, but as you see, in the end it was something on your side, and difficult to see...

Best regards,
-javiexin

PS: I have a version in the works that does not require (as much) JS, but it will require 3.1.6 at least (new events), so I will not release it in the near future.

rrbailey89
Registered User
Posts: 248
Joined: Fri Oct 24, 2014 3:00 pm

Re: [BETA] Advanced Polls 1.2

Post by rrbailey89 » Thu Aug 06, 2015 12:26 am

javiexin wrote:I think I have identified the problem with your installation, and the reason why this was not working.

Your file ext/wolfsblvt/advancedpolls/styles/prosilver/template/lib/jxtools.js is broken.
Well, not really, it only has all the line endings stripped, and that means that all code is commented out, so that is why it is not executing.

Remove the file from your system, and copy a new, fresh copy of that file. Make sure that it has appropriate line endings for your hosting OS, but at least, it HAS line endings.

When you do that, enable everything and test again. It should work. Hope this time is the good one. Sorry for making you test so much, but as you see, in the end it was something on your side, and difficult to see...

Best regards,
-javiexin

PS: I have a version in the works that does not require (as much) JS, but it will require 3.1.6 at least (new events), so I will not release it in the near future.
So upon furtuer inspection and some tests for whatever reason the jxtools.js file on my server was UTF-8 and not UTF-8 w/o BOM. I'm not sure how this happened and feel it was happening automatically since I didn't edit that file at all. So how did I figure this out? I noticed the file size was different immediately upon uploading that file. So How did I fix it? I copied and pasted the info from the original jxtools.js and within notepad++ converted it to UTF-8 w/o BOM. And now everything is working out just fine :).

However now I get this error when trying to edit the original poll that started all this

Code: Select all

General Error

SQL ERROR [ mysqli ]

Out of range value for column 'poll_start' at row 1 [1264]

SQL

UPDATE jcp_topics SET forum_id = 21, icon_id = 0, topic_title = 'August In Game Event', topic_first_poster_name = 'Serena Eclipse', topic_type = 2, topic_time_limit = 1036800, poll_title = 'What Would You Like The In Game FC Event To Be For August', poll_start = -86400, poll_max_options = 1, poll_length = 86400, poll_vote_change = 0, topic_last_view_time = 1438821427, topic_attachment = 0, wolfsblvt_poll_votes_hide = 1, wolfsblvt_poll_voters_show = 1, wolfsblvt_poll_voters_limit = 0, wolfsblvt_poll_show_ordered = 1, wolfsblvt_poll_max_value = 1, wolfsblvt_poll_total_value = 1 WHERE topic_id = 269

BACKTRACE


FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 855
CALL: trigger_error()

FILE: [ROOT]/phpbb/db/driver/mysqli.php
LINE: 193
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/phpbb/db/driver/factory.php
LINE: 329
CALL: phpbb\db\driver\mysqli->sql_query()

FILE: [ROOT]/includes/functions_posting.php
LINE: 1943
CALL: phpbb\db\driver\factory->sql_query()

FILE: [ROOT]/posting.php
LINE: 1400
CALL: submit_post()

User avatar
javiexin
Code Contributor
Posts: 1157
Joined: Wed Oct 12, 2011 11:46 pm
Location: Madrid, Spain
Name: Javier
Contact:

Re: [BETA] Advanced Polls 1.2

Post by javiexin » Thu Aug 06, 2015 9:33 am

Glad it worked. I just double checked that on my end, and in the repository, it is UTF-8 w/o BOM. I always edit with Notepad++, and have it configured so that every file is UTF-8 w/o BOM by default. And I did review the copies of the file, and all show up this way.

Anyhow, this is fixed. Now for the other problem. This is something that originated when the other problem was active, so let's fix it the rough way, and then you test with new polls, but with everything working. If the problem reproduces with a new poll, we will take a deeper look.

The first option is if you do NOT care about the already existing votes, then I would suggest to remove the poll, and start it again. But if you do want to keep the votes, then we should do something directly into the database.

Go into your phpmyadmin, and run the following command:

Code: Select all

UPDATE jcp_topics SET forum_id = 21, icon_id = 0, topic_title = 'August In Game Event', topic_first_poster_name = 'Serena Eclipse', topic_type = 2, topic_time_limit = 1036800, poll_title = 'What Would You Like The In Game FC Event To Be For August', poll_start = 1438821427-86400, poll_max_options = 1, poll_length = 0, poll_vote_change = 0, topic_last_view_time = 1438821427, topic_attachment = 0, wolfsblvt_poll_votes_hide = 1, wolfsblvt_poll_voters_show = 1, wolfsblvt_poll_voters_limit = 0, wolfsblvt_poll_show_ordered = 1, wolfsblvt_poll_max_value = 1, wolfsblvt_poll_total_value = 1 WHERE topic_id = 269
This will make the poll unlimited, but then you will be able to adjust the length as you wish in the normal way.

Best regards,
-javiexin

koraldon
Registered User
Posts: 511
Joined: Sat Jun 30, 2007 12:42 pm

Re: [BETA] Advanced Polls 1.2

Post by koraldon » Mon Aug 24, 2015 6:16 pm

Hi Javier,
Any news about a new release?
I'm still using 1.1b1, I saw the github, but there is no "release"

User avatar
javiexin
Code Contributor
Posts: 1157
Joined: Wed Oct 12, 2011 11:46 pm
Location: Madrid, Spain
Name: Javier
Contact:

Re: [BETA] Advanced Polls 1.2

Post by javiexin » Mon Aug 24, 2015 8:51 pm

Not yet, sorry.

User avatar
Hippie459MN
Registered User
Posts: 918
Joined: Mon Oct 15, 2007 10:13 pm
Location: Minnesota, USA
Contact:

Re: [BETA] Advanced Polls 1.2

Post by Hippie459MN » Sun Sep 06, 2015 4:35 am

Thanks for this. Was using it on 3.0.x and just found it here. :)

koraldon
Registered User
Posts: 511
Joined: Sat Jun 30, 2007 12:42 pm

Re: [BETA] Advanced Polls 1.2

Post by koraldon » Sun Sep 13, 2015 2:47 pm

updated new version, latest from github.
Now it seems the first options field and the third option field are identical? both ask how many options each voter can vote for ? or is it a translation issue?

Also, it appears that all polls that the option to view users are now not showing any users. Even polls that show them on the previous version. It seems this function no longer works :(
This option is enable as default on the ACP, but it the checkbox is off when I edit the poll and I cannot seem to activate it.
Can you please fix it? or should I still stick with version 1.1 for now?

User avatar
javiexin
Code Contributor
Posts: 1157
Joined: Wed Oct 12, 2011 11:46 pm
Location: Madrid, Spain
Name: Javier
Contact:

Re: [BETA] Advanced Polls 1.2

Post by javiexin » Sun Sep 13, 2015 2:59 pm

Don't update from github.
Half made changes.
You can use 1.2, but not latest from github.
I cannot make any updates for now, but I will as soon as I come back online.

Nully
Registered User
Posts: 453
Joined: Thu Jan 29, 2009 10:11 pm
Location: France
Contact:

Re: [BETA] Advanced Polls 1.2

Post by Nully » Sun Sep 13, 2015 3:30 pm

Really?
I have v. 1.2.1-b1 installed. It works fine.

koraldon
Registered User
Posts: 511
Joined: Sat Jun 30, 2007 12:42 pm

Re: [BETA] Advanced Polls 1.2

Post by koraldon » Sun Sep 13, 2015 8:30 pm

Where can I find 1.2?
First post in this topics says to download from github, I didn't see any releases there...

User avatar
javiexin
Code Contributor
Posts: 1157
Joined: Wed Oct 12, 2011 11:46 pm
Location: Madrid, Spain
Name: Javier
Contact:

Re: [BETA] Advanced Polls 1.2

Post by javiexin » Sun Sep 13, 2015 8:36 pm

My mistake, I mixed extensions.
Github download is ok.

However, as I said, no fix until I am back online. Cannot say when that is going to be.

Of course, this is NOT abandoned.

Nully
Registered User
Posts: 453
Joined: Thu Jan 29, 2009 10:11 pm
Location: France
Contact:

Re: [BETA] Advanced Polls 1.2

Post by Nully » Sun Sep 13, 2015 8:39 pm

javiexin wrote: Of course, this is NOT abandoned.
I hope :D

koraldon
Registered User
Posts: 511
Joined: Sat Jun 30, 2007 12:42 pm

Re: [BETA] Advanced Polls 1.2

Post by koraldon » Sun Sep 13, 2015 11:17 pm

Quick update:
After refreshing my prosilver (see here: viewtopic.php?f=466&p=14200061#p14200061) I can once again see who voted. Also, now I only see one time the field for how many options per user. Everything seems good.
I did clear the cache before, so that's not related. Not sure what was the connection, but it is.

Locked

Return to “Abandoned Extensions”