Page 2 of 3

Re: [RC] Off-site Image Upload

Posted: Thu Oct 08, 2015 1:11 pm
by uruguayito
nextgen wrote:
uruguayito wrote:Is possible change the language "add image to post"??

In spanish is: Agregar una imagen al mensaje ..... :roll:
Download this script http://mod.postimage.org/phpbb3-english ... -family.js and upload in your own server, open and find var postimage_add_text="Add image to post";, change Add image to post to your translation.
tky nextgen... when you say "in your own server"....excatly where? :?

Re: [RC] Off-site Image Upload

Posted: Thu Oct 08, 2015 4:24 pm
by null2
*** Please, delete this post. ***

Re: [RC] Off-site Image Upload

Posted: Thu Oct 08, 2015 5:31 pm
by nextgen
uruguayito wrote:
nextgen wrote:
uruguayito wrote:Is possible change the language "add image to post"??

In spanish is: Agregar una imagen al mensaje ..... :roll:
Download this script http://mod.postimage.org/phpbb3-english ... -family.js and upload in your own server, open and find var postimage_add_text="Add image to post";, change Add image to post to your translation.
tky nextgen... when you say "in your own server"....excatly where? :?
In your root/styles/your_style/template/js maybe? :roll:

Re: [RC] Off-site Image Upload

Posted: Wed Oct 14, 2015 1:14 am
by null2
uruguayito wrote:Is possible change the language "add image to post"??

In spanish is: Agregar una imagen al mensaje ..... :roll:
My forum has 3 languages, so, I solved that in an ugly way, but worked.

I changed 2 files inside ext\eben80\offsiteimageupload\styles\all\template\event:

posting_editor_subject_before.html
quickreply_editor_panel_before.html

I put this code inside them:

Code: Select all

<!-- IF S_USER_LANG eq "pt-br" --><script type='text/javascript' src='http://mod.postimage.org/phpbb3-portuguese_brazil-hotlink-family.js' charset='utf-8'></script>
<!-- ELSEIF S_USER_LANG eq "es" --><script type='text/javascript' src='http://mod.postimage.org/phpbb3-spanish-hotlink-family.js' charset='utf-8'></script>
<!-- ELSE --><script type='text/javascript' src='http://mod.postimage.org/phpbb3-english-hotlink-family.js' charset='utf-8'></script><!-- ENDIF -->
Last command will be default case, just in case you install a new language and forget to update these files.

Insert ELSEIF statements for each language behind 2. If your forum has only 2, remove ELSEIF statement.

You may see available languages here: http://postimage.org/languages.php

Its not beautiful, but solved my problem.

Re: [RC] Off-site Image Upload

Posted: Wed Oct 14, 2015 12:40 pm
by uruguayito
tky very much null2 :mrgreen:

Re: [RC] Off-site Image Upload

Posted: Tue Dec 08, 2015 4:38 pm
by Swen
Could it be that https was not supported yet? Since https activation on my board the link disappear.

Re: [RC] Off-site Image Upload

Posted: Thu Dec 10, 2015 7:26 pm
by GoBieN
The JS file can also be download using https. you might have to find the line in the extension files and change
http://mod.postimage.org/phpbb3-english ... -family.js
to
https://mod.postimage.org/phpbb3-englis ... -family.js

Or I think you can also use src="://mod.postimage.org/phpbb3-english-hotlink-family.js" but not sure about the syntax.

Re: [RC] Off-site Image Upload

Posted: Tue Dec 15, 2015 4:58 pm
by Swen
Roger, thats it. Thanks!

Re: [RC] Off-site Image Upload

Posted: Fri Jan 15, 2016 6:03 pm
by null2
postimage.org is not working anymore, at least to Brazil.

Any news about that?

Re: [RC] Off-site Image Upload

Posted: Sun Jan 17, 2016 12:04 am
by GoBieN
Seems fine here (Europe).

Re: [RC] Off-site Image Upload

Posted: Sun Jan 17, 2016 1:35 am
by null2
Right now, Im 300 km far from the city where I live. Its not working here too, using another computer and network.

Weird...

Re: [RC] Off-site Image Upload

Posted: Thu Jan 21, 2016 1:58 pm
by null2
postimage.org is still not working.

It looks like a kind ot block.

Re: [RC] Off-site Image Upload

Posted: Thu Jan 21, 2016 11:19 pm
by GoBieN
The site postimage.org is loading fine here (West-Europe)

Re: [RC] Off-site Image Upload

Posted: Fri Jan 22, 2016 3:48 am
by null2
Im going to contact them.

Re: [RC] Off-site Image Upload

Posted: Fri Jan 22, 2016 3:23 pm
by null2
Postimage team did some tests and said:

"Dear friend:

We have confirmed that your ISP is blocking all TCP traffic
to our CloudFlare frontend ip (108.162.203.60).

The picture itself is accessible from the server it is stored at.
We are trying to contact GVT and make them unblock it, but so far they haven't
answered our mails, our phone calls and even our Facebook messages.

We will continue trying to contact GVT and will be grateful for any suggestions you have.
Thank you

-PostImage.org team"