[ABD] Topic/Post Reactions(like, happy, thanks, angry)

Any abandoned Extensions will be moved to this forum.

WARNING: Extensions in this forum are not currently being supported or maintained by the original Extension author. Proceed at your own risk.
Forum rules
IMPORTANT: Extension Development Forum rules

WARNING: Extensions in this forum are not currently being supported nor updated by the original Extension author. Proceed at your own risk.
Locked
lifeguard81
Registered User
Posts: 147
Joined: Tue Dec 04, 2007 10:11 am

Re: [DEV][3.2] Topic/Post Reactions(like, happy, thanks, angry)

Post by lifeguard81 » Fri Mar 31, 2017 2:37 pm

null2 wrote:
Fri Mar 31, 2017 1:31 pm
I cant open ACP settings to this extension. I get a HTTP ERROR 500. Why?

I have the same. When i go to the extensionpage i also get 500 error.
php 7 , i use
On php 5.6 it works fine :)

I think i do something wrong.
When i hover over the image i see only a ?
Last edited by lifeguard81 on Fri Mar 31, 2017 3:01 pm, edited 1 time in total.
Bye phpBB, hello Compo.sr A complete website package with news, forum, chat, gallery and much more!

User avatar
Steve
Registered User
Posts: 992
Joined: Tue Apr 07, 2009 7:48 pm
Location: UK ,up north!!
Name: Steven Clark
Contact:

Re: [DEV][3.2] Topic/Post Reactions(like, happy, thanks, angry)

Post by Steve » Fri Mar 31, 2017 2:39 pm

php level is set at 5.6 unfortunately so I cant reproduce the error, any information in server logs?

lifeguard81
Registered User
Posts: 147
Joined: Tue Dec 04, 2007 10:11 am

Re: [DEV][3.2] Topic/Post Reactions(like, happy, thanks, angry)

Post by lifeguard81 » Fri Mar 31, 2017 3:02 pm

When i hover over the image i see only a ?
Bye phpBB, hello Compo.sr A complete website package with news, forum, chat, gallery and much more!

User avatar
Steve
Registered User
Posts: 992
Joined: Tue Apr 07, 2009 7:48 pm
Location: UK ,up north!!
Name: Steven Clark
Contact:

Re: [DEV][3.2] Topic/Post Reactions(like, happy, thanks, angry)

Post by Steve » Fri Mar 31, 2017 3:08 pm

lifeguard81 wrote:
Fri Mar 31, 2017 3:02 pm
When i hover over the image i see only a ?
what image? What page? viewtopic? do you have a have a Screenshot? the only thing i can think of is the cursor applied:

Code: Select all

.reaction_info {
	cursor: help;
}
may not work in your browser? or device.

lifeguard81
Registered User
Posts: 147
Joined: Tue Dec 04, 2007 10:11 am

Re: [DEV][3.2] Topic/Post Reactions(like, happy, thanks, angry)

Post by lifeguard81 » Fri Mar 31, 2017 3:58 pm

Steve wrote:
Fri Mar 31, 2017 3:08 pm
lifeguard81 wrote:
Fri Mar 31, 2017 3:02 pm
When i hover over the image i see only a ?
what image? What page? viewtopic? do you have a have a Screenshot? the only thing i can think of is the cursor applied:

Code: Select all

.reaction_info {
	cursor: help;
}
may not work in your browser? or device.
Nope, its me.... i thought i have to press the red 0 for emoji. I did not see that it was on top off the message to select a emoji.
Please, call me stupid :D

Thanks for this extension. it realy nice!
Bye phpBB, hello Compo.sr A complete website package with news, forum, chat, gallery and much more!

User avatar
Steve
Registered User
Posts: 992
Joined: Tue Apr 07, 2009 7:48 pm
Location: UK ,up north!!
Name: Steven Clark
Contact:

Re: [DEV][3.2] Topic/Post Reactions(like, happy, thanks, angry)

Post by Steve » Fri Mar 31, 2017 4:13 pm

It's ok I'm stupid also, but don't call me I'm drinking 🍺😝

User avatar
SalazarAG
Registered User
Posts: 665
Joined: Mon Mar 30, 2015 10:48 am

Re: [DEV][3.2] Topic/Post Reactions(like, happy, thanks, angry)

Post by SalazarAG » Fri Mar 31, 2017 4:43 pm

Steve wrote:
Fri Mar 31, 2017 5:37 am
maras2626 wrote:
Thu Mar 30, 2017 10:14 pm
Steve wrote:
Thu Mar 30, 2017 11:36 am
I have a added a download link in the 1st post for testing ;)
Hi, Steve
acp - settings error:

Code: Select all

Fatal error: 'break' not in the 'loop' or 'switch' context in .../forum/ext/steve/postreactions/controller/acp_controller.php on line 346
regards
Fixed.
null2 wrote:
Fri Mar 31, 2017 3:06 am
Translation to Portuguese-Brazil: https://www.sendspace.com/file/7njljc
Thanks
SalazarAG wrote:
Fri Mar 31, 2017 4:21 am
HI! Is it possible to add in the forum index a list of the 5 most reactive users?

I used Pico extension and the users of my forum were accustomed to see in the index the most reputed.

Or give me a way to do this?

Thanks!
Possibly in the future.
Thanks a lot!
I'm sorry for my English. Google Translator does a bad job. :D

User avatar
null2
Registered User
Posts: 472
Joined: Wed Jan 20, 2010 11:03 am

Re: [DEV][3.2] Topic/Post Reactions(like, happy, thanks, angry)

Post by null2 » Fri Mar 31, 2017 10:07 pm

Steve wrote:
Fri Mar 31, 2017 2:39 pm
php level is set at 5.6 unfortunately so I cant reproduce the error, any information in server logs?
Yes, problem is exactly that.

I set my forum to 5.6 and could access ACP options. Using 7.1, I was not able to access it. But... after changed settings, I could go to 7.1 again and everything is working fine. Problem is just in ACP.

Updated Portuguese-Brazil translation (minor changes): https://www.sendspace.com/file/fm7mq0
Updated English translation (just some "there" to "their"): https://www.sendspace.com/file/dc4unq

In info_acp_reactions.php, there is something confuse:

'ACP_REACTION_ENABLE_PAGE' => 'Enable View Reactions Page',
'ACP_REACTION_ENABLE_PAGES' => 'Enable View Post Reactions Pages',

I think, it should be something like that:

'ACP_REACTION_ENABLE_PAGE' => 'Enable View Reactions Page', (no changes)
'ACP_REACTION_ENABLE_PAGES' => 'Enable View Who Reacted to Post',

What do you think? Im not an English native so, I believe there is a better "translation/meaning" than this mine to this string.

=============

More: This is useless in common.php:

//pre populated reactions
'REACTION_CRY' => 'Cry',
'REACTION_DISLIKE' => 'Dislike',
'REACTION_FUNNY' => 'Funny',
'REACTION_HAPPY' => 'Happy',
'REACTION_LIKE' => 'Like',
'REACTION_LOVE' => 'Love',
'REACTION_MAD' => 'Mad',
'REACTION_NEUTRAL' => 'Neutral',
'REACTION_SAD' => 'Sad',
'REACTION_SURPRISED' => 'Surprised',
'REACTION_UNHAPPY' => 'Unhappy',
Sorry for my bad english. I'm from USA.

User avatar
Steve
Registered User
Posts: 992
Joined: Tue Apr 07, 2009 7:48 pm
Location: UK ,up north!!
Name: Steven Clark
Contact:

Re: [DEV][3.2] Topic/Post Reactions(like, happy, thanks, angry)

Post by Steve » Sat Apr 01, 2017 8:01 am

The Pre populated reactions are used in the migration file.

niwes
Registered User
Posts: 30
Joined: Fri Feb 22, 2013 12:48 am

Re: [DEV][3.2] Topic/Post Reactions(like, happy, thanks, angry)

Post by niwes » Sat Apr 01, 2017 11:08 am

lifeguard81 wrote:
Fri Mar 31, 2017 2:37 pm
null2 wrote:
Fri Mar 31, 2017 1:31 pm
I cant open ACP settings to this extension. I get a HTTP ERROR 500. Why?

I have the same. When i go to the extensionpage i also get 500 error.
php 7 , i use
On php 5.6 it works fine :)

I think i do something wrong.
When i hover over the image i see only a ?
hej there nice extention i like it ;)

but i get on my testboard the HTTP ERROR 500 when i click in acp on Extentions ,im using php7.1
the lang. fix dont work for me

User avatar
Hartenheer
Registered User
Posts: 768
Joined: Fri Jan 23, 2015 12:23 pm
Location: The Netherlands
Name: Willem Hartman
Contact:

Re: [DEV][3.2] Topic/Post Reactions(like, happy, thanks, angry)

Post by Hartenheer » Sat Apr 01, 2017 11:22 am

tried to install
In setting I get error


Fatal error: 'break' not in the 'loop' or 'switch' context in /home/willem2q/aandeanderekantvanhetglasbazaar.nl/testforum/ext/steve/postreactions/controller/acp_controller.php on line 346
Sorry English is not my native language :oops:
regards: Willem

https://bierfijnproevers.nl/bierforum

User avatar
Steve
Registered User
Posts: 992
Joined: Tue Apr 07, 2009 7:48 pm
Location: UK ,up north!!
Name: Steven Clark
Contact:

Re: [DEV][3.2] Topic/Post Reactions(like, happy, thanks, angry)

Post by Steve » Sat Apr 01, 2017 11:26 am

thats been fixed in the next version, I'm just setting up another test server with php 7.1 to see if i can solve this 500 error. a new version will be released monday.

User avatar
null2
Registered User
Posts: 472
Joined: Wed Jan 20, 2010 11:03 am

Re: [DEV][3.2] Topic/Post Reactions(like, happy, thanks, angry)

Post by null2 » Sat Apr 01, 2017 2:07 pm

niwes wrote:
Sat Apr 01, 2017 11:08 am
hej there nice extention i like it ;)

but i get on my testboard the HTTP ERROR 500 when i click in acp on Extentions ,im using php7.1
the lang. fix dont work for me
Set your php to 5.6, make changes in acp and set again to 7.1
Sorry for my bad english. I'm from USA.

niwes
Registered User
Posts: 30
Joined: Fri Feb 22, 2013 12:48 am

Re: [DEV][3.2] Topic/Post Reactions(like, happy, thanks, angry)

Post by niwes » Sat Apr 01, 2017 4:40 pm

null2 wrote:
Sat Apr 01, 2017 2:07 pm
niwes wrote:
Sat Apr 01, 2017 11:08 am
hej there nice extention i like it ;)

but i get on my testboard the HTTP ERROR 500 when i click in acp on Extentions ,im using php7.1
the lang. fix dont work for me
Set your php to 5.6, make changes in acp and set again to 7.1
i wait for next version :twisted:

thx Steve :ugeek:

User avatar
JupiterGPL
Registered User
Posts: 126
Joined: Thu Jun 08, 2006 4:52 pm
Contact:

Re: [DEV][3.2] Topic/Post Reactions(like, happy, thanks, angry)

Post by JupiterGPL » Sat Apr 01, 2017 6:14 pm

HELP!

I just wanted to check this EXT out and when I went to install it, it timed out and now I cannot access my Admin pane!

I am getting the following error.

[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/di/container_builder.php on line 146: require(./../cache/production/autoload_dbdbe80dc7030ae9bd39ee30cca82130.php): failed to open stream: No such file or directory

Locked

Return to “Abandoned Extensions”