[ABD] Emoji Picker 0.2.5

Any abandoned Extensions will be moved to this forum.

WARNING: Extensions in this forum are not currently being supported or maintained by the original Extension author. Proceed at your own risk.
Forum rules
IMPORTANT: Extension Development Forum rules

WARNING: Extensions in this forum are not currently being supported nor updated by the original Extension author. Proceed at your own risk.
User avatar
strelok-by
Registered User
Posts: 82
Joined: Fri Nov 21, 2014 10:22 am
Location: Mozyr/ Belarus
Name: Stanislav
Contact:

Re: [3.1][3.2][BETA] Emoji Picker 0.2.5

Post by strelok-by » Sat Jan 14, 2017 1:47 pm

nedka wrote:
Sat Jan 14, 2017 1:09 pm
strelok-by wrote:
Sat Jan 14, 2017 12:48 pm
there was a problem with a quick reply, there is a new version of it, and Emoji is not compatible with it
https://github.com/BoardTools/QuickRepl ... evelop-2.x

BBcode work - good ;)
Setup:
- phpBB 3.2.0
- SE Square Left 3.2.0-RC1
- Advanced BBCode Box 3.1.3
- Emoji Picker 0.2.5
- QuickReply Reloaded 2.0.0-dev2 (master today version, just have downloaded from your link)

Results:

With BBCode Box:
Image

Without BBCode Box:
Image

Buttons still are working :(
I have a floating form of response, and it is not disclosed in the writing of the text in it.
without Emoji
Image
On Emoji
Image

as the form is not working properly it can be seen at the same time
my setup is forum:
phpBB 3.2.0
SE Square Left 3.2.0 release
Advanced BBCode Box 3.2.0 DEV
Emoji Picker 0.2.5
QuickReply Reloaded 2.0.0-dev2

User avatar
nedka
Registered User
Posts: 162
Joined: Tue Jun 28, 2005 8:55 am
Location: Ho Chi Minh City
Name: Khoa Nguyen

Re: [3.1][3.2][BETA] Emoji Picker 0.2.5

Post by nedka » Sat Jan 14, 2017 2:05 pm

SalazarAG wrote:
Sat Jan 14, 2017 1:20 pm
Hi nedka! Great version, now the functions of Quick Reply Reloaded works well!

However I encountered another error. When we send a message with Quick Reply Reloaded, the page reloads with ajax and the message is sent instantly. So, after sending the message ends up appearing both quick reply editors (the Quick Reply Reloaded and EMojiPicker), see:

Image
Lol it's so funny :D SalazarAG, you can apply this fix until I review it more carefully:

For QuickReply Reloaded 1.0.2:
Open ext/boardtools/quickreply/styles/prosilver/template/quickreply_core.js
Find: (Line ~510)

Code: Select all

$('#message-box textarea').val('').attr('style', 'height: 9em;');
Add after:

Code: Select all

$('textarea#message').hide();
$('div.emojionearea-editor').html('');
For QuickReply Reloaded 2.0.0-dev2:
Open: ext/boardtools/quickreply/styles/all/template/quickreply_core.js
Find: (Line ~1409)

Code: Select all

quickreply.form.refresh();
Add after:

Code: Select all

$('textarea#message').hide();
$('div.emojionearea-editor').html('');
Remember to clear cache by the button from ACP to reset the asset version!
strelok-by wrote:
Sat Jan 14, 2017 1:47 pm
I have a floating form of response, and it is not disclosed in the writing of the text in it.
without Emoji
Image
On Emoji
Image

as the form is not working properly it can be seen at the same time
my setup is forum:
phpBB 3.2.0
SE Square Left 3.2.0 release
Advanced BBCode Box 3.2.0 DEV
Emoji Picker 0.2.5
QuickReply Reloaded 2.0.0-dev2
Thanks for your images, strelok, since this is a dev-version: QuickReply Reloaded 2.0.0-dev2 AND/OR Advanced BBCode Box 3.2.0 DEV, their developers can change code anytime, I need time to review them and will add support later. :D
VinaBB - Republic of phpBB

User avatar
Froddelaar
Registered User
Posts: 503
Joined: Tue Mar 29, 2016 3:45 am
Location: Aalst (Belgium)
Name: Andy Dm
Contact:

Re: [3.1][3.2][BETA] Emoji Picker 0.2.3

Post by Froddelaar » Sat Jan 14, 2017 2:25 pm

Hi nextgen and Froddelaar, I tested it again multi times. One or 2 times, when the network goes slow, the Emoji icon did not load correctly because the remote JS link https://cdn.rawgit.com/yuku-t/jquery-textcomplete/v1.3.4/dist/jquery.textcomplete.js is very slow in response. I guess it may be the reason. I moved this file to ext local, hope this problem has gone. Test new version and let me know.
Still nothing

Image
I'm A Stupid F*ck.. And Proud Of it!
Download +34.000 arcade extension games @ ~ https://www.froddelpower.be ~

Dutch Extension Translations @ https://github.com/Solidjeuh
Donations are always welcome @ https://www.froddelpower.be/donation

User avatar
nedka
Registered User
Posts: 162
Joined: Tue Jun 28, 2005 8:55 am
Location: Ho Chi Minh City
Name: Khoa Nguyen

Re: [3.1][3.2][BETA] Emoji Picker 0.2.3

Post by nedka » Sat Jan 14, 2017 2:33 pm

Froddelaar wrote:
Sat Jan 14, 2017 2:25 pm
Still nothing

Image
Wow, Pidgin smilies, long time no see them :D Your textarea must be put within a <div id="message-box" to match the jQuery selector div#message-box > textarea:

posting_editor.html:

Code: Select all

<div id="message-box"...
	<textarea...
</div>
Or you can add the attribute data-emojipicker="true" to any textarea or input tags:

Code: Select all

<textarea data-emojipicker="true" ...
VinaBB - Republic of phpBB

User avatar
SalazarAG
Registered User
Posts: 665
Joined: Mon Mar 30, 2015 10:48 am

Re: [3.1][3.2][BETA] Emoji Picker 0.2.5

Post by SalazarAG » Sat Jan 14, 2017 2:42 pm

nedka wrote:
Sat Jan 14, 2017 2:05 pm
SalazarAG wrote:
Sat Jan 14, 2017 1:20 pm
Hi nedka! Great version, now the functions of Quick Reply Reloaded works well!

However I encountered another error. When we send a message with Quick Reply Reloaded, the page reloads with ajax and the message is sent instantly. So, after sending the message ends up appearing both quick reply editors (the Quick Reply Reloaded and EMojiPicker), see:

Image
Lol it's so funny :D SalazarAG, you can apply this fix until I review it more carefully:

For QuickReply Reloaded 1.0.2:
Open ext/boardtools/quickreply/styles/prosilver/template/quickreply_core.js
Find: (Line ~510)

Code: Select all

$('#message-box textarea').val('').attr('style', 'height: 9em;');
Add after:

Code: Select all

$('textarea#message').hide();
$('div.emojionearea-editor').html('');
For QuickReply Reloaded 2.0.0-dev2:
Open: ext/boardtools/quickreply/styles/all/template/quickreply_core.js
Find: (Line ~1409)

Code: Select all

quickreply.form.refresh();
Add after:

Code: Select all

$('textarea#message').hide();
$('div.emojionearea-editor').html('');
Remember to clear cache by the button from ACP to reset the asset version!

Worked perfectly! :) Thank you very much

And there's another one really funny kkkkkkkkk

After sending a message everything is ok, but when the person wants to send another message without having reloaded the page, the message that has a few characters appears.

I do not know if it was clear, it's something like this:

- I send a message (can be an emoji)
- I send another message on the same page, with an emoji and the error appears that it is empty

It's as if the editor is empty
I'm sorry for my English. Google Translator does a bad job. :D

User avatar
strelok-by
Registered User
Posts: 82
Joined: Fri Nov 21, 2014 10:22 am
Location: Mozyr/ Belarus
Name: Stanislav
Contact:

Re: [3.1][3.2][BETA] Emoji Picker 0.2.5

Post by strelok-by » Sat Jan 14, 2017 2:43 pm

nedka wrote:
Sat Jan 14, 2017 2:05 pm

For QuickReply Reloaded 2.0.0-dev2:
Open: ext/boardtools/quickreply/styles/all/template/quickreply_core.js
Find: (Line ~1409)

Code: Select all

quickreply.form.refresh();
Add after:

Code: Select all

$('textarea#message').hide();
$('div.emojionearea-editor').html('');
Remember to clear cache by the button from ACP to reset the asset version!
strelok-by wrote:
Sat Jan 14, 2017 1:47 pm
I have a floating form of response, and it is not disclosed in the writing of the text in it.
without Emoji
Image
On Emoji
Image

as the form is not working properly it can be seen at the same time
my setup is forum:
phpBB 3.2.0
SE Square Left 3.2.0 release
Advanced BBCode Box 3.2.0 DEV
Emoji Picker 0.2.5
QuickReply Reloaded 2.0.0-dev2
Thanks for your images, strelok, since this is a dev-version: QuickReply Reloaded 2.0.0-dev2 AND/OR Advanced BBCode Box 3.2.0 DEV, their developers can change code anytime, I need time to review them and will add support later. :D
Thank you very much, everything works.

User avatar
strelok-by
Registered User
Posts: 82
Joined: Fri Nov 21, 2014 10:22 am
Location: Mozyr/ Belarus
Name: Stanislav
Contact:

Re: [3.1][3.2][BETA] Emoji Picker 0.2.5

Post by strelok-by » Sat Jan 14, 2017 3:19 pm

sooner I rejoiced once everything was fine now again a problem with Quick reply

User avatar
potku
Registered User
Posts: 705
Joined: Wed Dec 22, 2004 10:26 pm
Location: Tampere, Finland
Contact:

Re: [3.1][3.2][BETA] Emoji Picker 0.2.5

Post by potku » Sat Jan 14, 2017 3:46 pm

Nedka, I applaude your energy. You really don't waste any time with updates. :)

By the way, have you tested this with Posting Buttons? I was just thinking that maybe that might cause a conflict with Emoji Picker when it comes to posting template and custom BBCodes. They do work, yes, but they still do not show in posting template. Preview works OK, as it did before. We have the latest version of Emoji Picker.
Potku.net

"Before I speak, I have something important to say."

- Groucho Marx

User avatar
nextgen
Registered User
Posts: 2271
Joined: Mon Jul 26, 2010 10:58 pm
Location: Guatemala
Name: Melvin García
Contact:

Re: [3.1][3.2][BETA] Emoji Picker 0.2.3

Post by nextgen » Sat Jan 14, 2017 4:10 pm

nedka wrote:
Sat Jan 14, 2017 7:45 am
nextgen wrote:
Fri Jan 13, 2017 4:44 pm
Froddelaar wrote:
Fri Jan 13, 2017 3:47 pm
Not working in phpBB 3.1.10
There is no Emoji icon in the textarea field.
The same here...
Hi nextgen and Froddelaar, I tested it again multi times. One or 2 times, when the network goes slow, the Emoji icon did not load correctly because the remote JS link https://cdn.rawgit.com/yuku-t/jquery-textcomplete/v1.3.4/dist/jquery.textcomplete.js is very slow in response. I guess it may be the reason. I moved this file to ext local, hope this problem has gone. Test new version and let me know.
No, doesn't work, I get the same error I put above.

Image

I already tried it on 2 different forums and same thing happens, I tried on localhost and works well, the truth not be which can be. :lol:
メルビン・ガルシア • XeronixMy active styles for phpBBphpBB Argentina - Soporte en español🇦🇷

Please do NOT contact for support via PM or email.

User avatar
Dr.Death
QA Team
Posts: 361
Joined: Fri Apr 25, 2003 10:04 am
Location: Germany
Contact:

Re: [3.1][3.2][BETA] Emoji Picker 0.2.5

Post by Dr.Death » Sat Jan 14, 2017 7:43 pm

Hi,

I have the same issue as nextgen, same error, no smilie I could click on, but the same errors in hmtl/css code.... (Using phpBB 3.2.0 / prosilver)
Doc.

User avatar
nedka
Registered User
Posts: 162
Joined: Tue Jun 28, 2005 8:55 am
Location: Ho Chi Minh City
Name: Khoa Nguyen

Re: [3.1][3.2][BETA] Emoji Picker 0.2.5

Post by nedka » Sun Jan 15, 2017 2:04 am

Hi strelok, SalazarAG, potku, I will spend time on these exts to make the better compatibility. Currently I'm busy repairing my house without Internet here :lol:
Dr.Death wrote:
Sat Jan 14, 2017 7:43 pm
Hi,

I have the same issue as nextgen, same error, no smilie I could click on, but the same errors in hmtl/css code.... (Using phpBB 3.2.0 / prosilver)
nextgen wrote:
Sat Jan 14, 2017 4:10 pm
I already tried it on 2 different forums and same thing happens, I tried on localhost and works well, the truth not be which can be. :lol:
Please apply this patch until phpBB has fixed it.
Open ./phpbb/template/twig/extension.php
Find: (Line ~175)

Code: Select all

if (isset($context_vars['L_' . $key]))
Replace with:

Code: Select all

if (!is_array($key) && isset($context_vars['L_' . $key]))
I tested it again, once it appeared, the Emoji icon did not load correctly. My previous tests passed just because they loaded from cache :( This bug comes since 3.2.0-RC2+ when using Twig variable as an array, and debug mode is enabled.

@Froddelaar, if you see "phpBB Debug: Array to string..." in HTML code, just apply this patch above.
VinaBB - Republic of phpBB

User avatar
nextgen
Registered User
Posts: 2271
Joined: Mon Jul 26, 2010 10:58 pm
Location: Guatemala
Name: Melvin García
Contact:

Re: [3.1][3.2][BETA] Emoji Picker 0.2.5

Post by nextgen » Sun Jan 15, 2017 2:52 am

nedka wrote:
Sun Jan 15, 2017 2:04 am
I tested it again, once it appeared, the Emoji icon did not load correctly. My previous tests passed just because they loaded from cache :( This bug comes since 3.2.0-RC2+ when using Twig variable as an array, and debug mode is enabled.
Works now... :)
Thanks for your effort...
メルビン・ガルシア • XeronixMy active styles for phpBBphpBB Argentina - Soporte en español🇦🇷

Please do NOT contact for support via PM or email.

KenTSA
Registered User
Posts: 70
Joined: Thu Nov 27, 2014 7:11 pm
Name: Oprea Cristian
Contact:

Re: [3.1][3.2][BETA] Emoji Picker 0.2.5

Post by KenTSA » Sun Jan 15, 2017 11:50 am


User avatar
Dr.Death
QA Team
Posts: 361
Joined: Fri Apr 25, 2003 10:04 am
Location: Germany
Contact:

Re: [3.1][3.2][BETA] Emoji Picker 0.2.5

Post by Dr.Death » Sun Jan 15, 2017 12:33 pm

nedka wrote:
Sun Jan 15, 2017 2:04 am

Please apply this patch until phpBB has fixed it.
Open ./phpbb/template/twig/extension.php
Confirmed, patch is working, thanks so far!


I see now only to two http 404 errors if I enable your Extension: (but I'm not able to find the source for that messages)
[Error] Failed to load resource: the server responded with a status of 404 (Not Found) (jquery.textcomplete.min.map, line 0) --

Code: Select all

http://my.url.com/ext/vinabb/emojipicker/styles/all/theme/dist/jquery.textcomplete.min.map
[Error] Failed to load resource: the server responded with a status of 404 (Not Found) (emojionearea.min.map, line 0) --

Code: Select all

http://my.url.com/ext/vinabb/emojipicker/styles/all/theme/emojionearea.min.map

BTW: I changed some styling codes (colours) for style depending reasons and moved the file "emojionearea.min.css" to the style specific theme folder:

from:
vinabb/emojipicker/styles/all/theme/emojionearea.min.css

to:
vinabb/emojipicker/styles/prosilver/theme/emojionearea.min.css
vinabb/emojipicker/styles/mystyle/theme/emojionearea.min.css
Doc.

Miri4ever
Registered User
Posts: 392
Joined: Sat Mar 07, 2015 11:18 am

Re: [3.1][3.2][BETA] Emoji Picker 0.2.5

Post by Miri4ever » Sun Jan 15, 2017 4:24 pm

As I see working so far fine, but on dark backgrounds it produce a white background inside the posting editor. Extensions should use the colors coming from the used theme and not adding own that might conflict with white / dark or others styles.

Is there a way to make those emotes bigger inside posts and are they coming from the own server or somewhere from outthere ? I would really use those instead of the smilies. It gives a board a more professional touch at all.
Homepage: Terra Oceanica

Locked

Return to “Abandoned Extensions”

Who is online

Users browsing this forum: No registered users and 5 guests

cron