[ABD] PG Social Network

Any abandoned Extensions will be moved to this forum.

WARNING: Extensions in this forum are not currently being supported or maintained by the original Extension author. Proceed at your own risk.
Forum rules
IMPORTANT: Extension Development Forum rules

WARNING: Extensions in this forum are not currently being supported nor updated by the original Extension author. Proceed at your own risk.
User avatar
robbie787
Registered User
Posts: 62
Joined: Fri Sep 13, 2019 12:53 pm

Re: [3.3][ALPHA] PG Social Network

Post by robbie787 »

It would be great if the phpbb community got more involved in this project help him out. It has the potential become a great extension for any community. If anyone knows how to fix the bugs fork and raise issues on the github page.
User avatar
robbie787
Registered User
Posts: 62
Joined: Fri Sep 13, 2019 12:53 pm

Re: [3.3][ALPHA] PG Social Network

Post by robbie787 »

Just noticed something even more scary.. you disable the pg social extension and it breaks your forum. :o I'm stuck with it until a fix comes.
User avatar
Elias
Registered User
Posts: 5139
Joined: Sat Feb 25, 2006 4:31 pm
Location: In the Water!
Name: Elias

Re: [3.3][ALPHA] PG Social Network

Post by Elias »

It broke my board when I installed the extension.
It fixed itself when I purged the cache.

Not sure if this will work for you.
I didn’t try disabling the extension.
"Mystery creates wonder, and wonder is the basis of man's desire to understand." - Neil Armstrong
|Installing Extensions|Writing Extensions|Extension Validation Policy|
User avatar
robbie787
Registered User
Posts: 62
Joined: Fri Sep 13, 2019 12:53 pm

Re: [3.3][ALPHA] PG Social Network

Post by robbie787 »

Elias wrote:
Tue May 05, 2020 6:00 pm
It broke my board when I installed the extension.
It fixed itself when I purged the cache.

Not sure if this will work for you.
I didn’t try disabling the extension.
cleared cache and everything.. try disabling it and see if you get a mass of errors. The board breaks, but if you re-enable it again manually the board comes back.
chfs
Registered User
Posts: 237
Joined: Mon Feb 04, 2013 10:01 am

Re: [3.3][ALPHA] PG Social Network

Post by chfs »

I'm sorry for my english. :?
User avatar
robbie787
Registered User
Posts: 62
Joined: Fri Sep 13, 2019 12:53 pm

Re: [3.3][ALPHA] PG Social Network

Post by robbie787 »

chfs wrote:
Tue May 05, 2020 6:30 pm
PGreca get inspired

https://github.com/phpBB-Social-Network ... aster/root
That github is 8yrs old. Not much can be taken from it now sadly.
User avatar
robbie787
Registered User
Posts: 62
Joined: Fri Sep 13, 2019 12:53 pm

Re: [3.3][ALPHA] PG Social Network

Post by robbie787 »

Problem with the avatar is the avatar is coded to use 2 directories.. There was no need to do it. It would of been better to just reflect the uploaded avatar from phpbb like in mchat extension, using 2 directories buggered it all up.

This really could take a lot from mchat extension.
User avatar
Elias
Registered User
Posts: 5139
Joined: Sat Feb 25, 2006 4:31 pm
Location: In the Water!
Name: Elias

Re: [3.3][ALPHA] PG Social Network

Post by Elias »

robbie787 wrote:
Tue May 05, 2020 6:19 pm
Elias wrote:
Tue May 05, 2020 6:00 pm
It broke my board when I installed the extension.
It fixed itself when I purged the cache.

Not sure if this will work for you.
I didn’t try disabling the extension.
cleared cache and everything.. try disabling it and see if you get a mass of errors. The board breaks, but if you re-enable it again manually the board comes back.
I was able to disabled the extension with no issue.
"Mystery creates wonder, and wonder is the basis of man's desire to understand." - Neil Armstrong
|Installing Extensions|Writing Extensions|Extension Validation Policy|
User avatar
robbie787
Registered User
Posts: 62
Joined: Fri Sep 13, 2019 12:53 pm

Re: [3.3][ALPHA] PG Social Network

Post by robbie787 »

Elias wrote:
Wed May 06, 2020 12:22 pm
robbie787 wrote:
Tue May 05, 2020 6:19 pm
Elias wrote:
Tue May 05, 2020 6:00 pm
It broke my board when I installed the extension.
It fixed itself when I purged the cache.

Not sure if this will work for you.
I didn’t try disabling the extension.
cleared cache and everything.. try disabling it and see if you get a mass of errors. The board breaks, but if you re-enable it again manually the board comes back.
I was able to disabled the extension with no issue.
I managed to fix and uninstall it, a certain tag was in the mysql database that did not uninstall with the extension. I have disabled the pg social extension. I will come back in a couple of weeks to see if any progress has been made. I am going to go live with my board on monday, I don't see any fixes by then tbh.
User avatar
3Di
Former Team Member
Posts: 16151
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milano 🇮🇹 Frankfurt 🇩🇪
Name: Marco
Contact:

Re: [3.3][ALPHA] PG Social Network

Post by 3Di »

You should not really deploy an extension in development at all onto a production site, that's the thumb of rules. :ugeek:
🆓 Free support for our extensions also provided here: phpBB Studio
🚀 Looking for a specific feature or alternative option? We will rock you!
Please PM me only to request paid works. Thx. Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user º Extensions, Scripts, MOD porting, Update/Upgrades
User avatar
robbie787
Registered User
Posts: 62
Joined: Fri Sep 13, 2019 12:53 pm

Re: [3.3][ALPHA] PG Social Network

Post by robbie787 »

3Di wrote:
Wed May 06, 2020 1:58 pm
You should not really deploy an extension in development at all onto a production site, that's the thumb of rules. :ugeek:
You are absolutely right! But I backed up the whole forum before I tested and installed it.
User avatar
3Di
Former Team Member
Posts: 16151
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milano 🇮🇹 Frankfurt 🇩🇪
Name: Marco
Contact:

Re: [3.3][ALPHA] PG Social Network

Post by 3Di »

Use a test-bed for anything, trust me.
🆓 Free support for our extensions also provided here: phpBB Studio
🚀 Looking for a specific feature or alternative option? We will rock you!
Please PM me only to request paid works. Thx. Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user º Extensions, Scripts, MOD porting, Update/Upgrades
User avatar
robbie787
Registered User
Posts: 62
Joined: Fri Sep 13, 2019 12:53 pm

Re: [3.3][ALPHA] PG Social Network

Post by robbie787 »

3Di wrote:
Wed May 06, 2020 2:13 pm
Use a test-bed for anything, trust me.
You are pretty awesome at coding on here. Would you care to give PGreca a hand with the avatar on github? I looked at your website and there is another extension I may hire you for / I will drop a message tomorrow for a quote.
User avatar
3Di
Former Team Member
Posts: 16151
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milano 🇮🇹 Frankfurt 🇩🇪
Name: Marco
Contact:

Re: [3.3][ALPHA] PG Social Network

Post by 3Di »

I took the dare to intervene only because I saw that the use of extensions still in development can damage a site permanently, then you ask for help but it is not always possible to provide it. I didn't mean to overwhelm the subject. I don't know exactly what you're talking about at the moment but I think you know how to contact us.
🆓 Free support for our extensions also provided here: phpBB Studio
🚀 Looking for a specific feature or alternative option? We will rock you!
Please PM me only to request paid works. Thx. Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user º Extensions, Scripts, MOD porting, Update/Upgrades
User avatar
robbie787
Registered User
Posts: 62
Joined: Fri Sep 13, 2019 12:53 pm

Re: [3.3][ALPHA] PG Social Network

Post by robbie787 »

3Di wrote:
Wed May 06, 2020 2:26 pm
I took the dare to intervene only because I saw that the use of extensions still in development can damage a site permanently, then you ask for help but it is not always possible to provide it. I didn't mean to overwhelm the subject. I don't know exactly what you're talking about at the moment but I think you know how to contact us.
ok
Locked

Return to “Abandoned Extensions”