Another "No route found for GET /" Error

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
rAdic
Registered User
Posts: 426
Joined: Mon Apr 25, 2005 11:32 pm
Contact:

Re: Another "No route found for GET /" Error

Post by rAdic » Sun Apr 16, 2017 12:59 am

that is good to know that it probably was the software installer as I suepected from the start. I did meaniton it earlier but it probably got lost in all the other issues.

Anyway I have found a small problem, I'm not sure what is the issue, I have not done anything to the install yet to cause it. What happens is when I go to admin > extensions page I see this and I tried refreshing the page but it still appears and the page does not work:

General Error
Cannot find module ./../includes/acp/\board3\portal\acp\portal_module.php

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/functions_module.php
LINE: 573
CALL: trigger_error()

FILE: [ROOT]/adm/index.php
LINE: 82
CALL: p_master->load_active()
it looks to be something with the portal mod that was installed on the previous version before the upgrade.

Maybe there are tables left over that I need to delete?

This is my database structure, does this look right?:


--

Code: Select all

phpbb3_acl_groups
phpbb3_acl_options
phpbb3_acl_roles
phpbb3_acl_roles_data
phpbb3_acl_users
phpbb3_attachments
phpbb3_autogroups_rules
phpbb3_autogroups_types
phpbb3_banlist
phpbb3_bbcodes
phpbb3_bookmarks
phpbb3_bots
phpbb3_captcha_answers
phpbb3_captcha_questions
phpbb3_config
phpbb3_config_text
phpbb3_confirm
phpbb3_disallow
phpbb3_drafts
phpbb3_ext
phpbb3_extensions
phpbb3_extension_groups
phpbb3_forums
phpbb3_forums_access
phpbb3_forums_track
phpbb3_forums_watch
phpbb3_groups
phpbb3_icons
phpbb3_lang
phpbb3_log
phpbb3_login_attempts
phpbb3_migrations
phpbb3_moderator_cache
phpbb3_mods
phpbb3_modules
phpbb3_notifications
phpbb3_notification_types
phpbb3_oauth_accounts
phpbb3_oauth_states
phpbb3_oauth_tokens
phpbb3_pages
phpbb3_pages_links
phpbb3_pages_pages_links
phpbb3_poll_options
phpbb3_poll_votes
phpbb3_portal_config
phpbb3_portal_modules
phpbb3_posts
phpbb3_ppde_currency
phpbb3_ppde_donation_pages
phpbb3_ppde_txn_log
phpbb3_privmsgs
phpbb3_privmsgs_folder
phpbb3_privmsgs_rules
phpbb3_privmsgs_to
phpbb3_profile_fields
phpbb3_profile_fields_data
phpbb3_profile_fields_lang
phpbb3_profile_lang
phpbb3_qa_confirm
phpbb3_ranks
phpbb3_reports
phpbb3_reports_reasons
phpbb3_search_results
phpbb3_search_wordlist
phpbb3_search_wordmatch
phpbb3_sessions
phpbb3_sessions_keys
phpbb3_sfnc_feeds
phpbb3_sitelist
phpbb3_smilies
phpbb3_styles
phpbb3_teampage
phpbb3_topics
phpbb3_topics_posted
phpbb3_topics_track
phpbb3_topics_watch
phpbb3_users
phpbb3_user_group
phpbb3_user_notifications
phpbb3_warnings
phpbb3_words
phpbb3_zebra
The Australian Forums - Australia Discussion Forum - Discuss Australia topics or generally anything

User avatar
Lumpy Burgertushie
Registered User
Posts: 63196
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Another "No route found for GET /" Error

Post by Lumpy Burgertushie » Sun Apr 16, 2017 1:33 am

you must have files left over as well . make sure there is no trace of any 3.0 MODs in the database or in your files.

when you upgraded you should have removed all of the 3.0 files except for the config.php file and those folders it tells you to keep.

that means that there would be no files calling on MODs .

you also should have run the toolkit and the database cleaner to remove all traces of any tables etc. that were not part of the default install of 3.0

apparently that did not happen for whatever reason.

so, yes, right there in that list it shows several tables that belong to the portal MOD.
there may also be other places withing tables that relate to the portal MOD. probably in the modules table.

so, make your backup first and then go through the database and remove anything that has the word portal in it.

make sure you have no files on the server that belong to any MODs especially the portal MOD.

good luck,
robert
I am available for custom work on a donation basis. Please send me a PM with your needs.
Premium phpBB 3.2 Styles by PlanetStyles.net

New phpbb 3.0 support site

rAdic
Registered User
Posts: 426
Joined: Mon Apr 25, 2005 11:32 pm
Contact:

Re: Another "No route found for GET /" Error

Post by rAdic » Sun Apr 16, 2017 4:55 am

you must have files left over as well .
When I uploaded the site it was a brand new clean install of 3.2 with none of my files.

anyway I will run through the database and see if I can clean it up manually, I did see that option for the toolkit and the database cleaner but I had pressed submit and could not go back.

thanks a lot, will update later
The Australian Forums - Australia Discussion Forum - Discuss Australia topics or generally anything

rAdic
Registered User
Posts: 426
Joined: Mon Apr 25, 2005 11:32 pm
Contact:

Re: Another "No route found for GET /" Error

Post by rAdic » Sun Apr 16, 2017 5:13 am

So I found 2 tables with Portal in the name so I deleted those. I also looked in the Modules table and I found 3 rows that look like this one below, should I delete these 3 rows and do I need to check other tables?:

Code: Select all

219 	1 	1 	\board3\portal\acp\portal_module 	acp 	217 	295 	296 	ACP_PORTAL
	
The Australian Forums - Australia Discussion Forum - Discuss Australia topics or generally anything

User avatar
Lumpy Burgertushie
Registered User
Posts: 63196
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Another "No route found for GET /" Error

Post by Lumpy Burgertushie » Sun Apr 16, 2017 5:22 am

yes.

rob ert
I am available for custom work on a donation basis. Please send me a PM with your needs.
Premium phpBB 3.2 Styles by PlanetStyles.net

New phpbb 3.0 support site

rAdic
Registered User
Posts: 426
Joined: Mon Apr 25, 2005 11:32 pm
Contact:

Re: Another "No route found for GET /" Error

Post by rAdic » Sun Apr 16, 2017 5:37 am

So I did that and went through each table but unfortunately the same error is still there, I tried in another browser as well,

Maybe I need to revert to an older backup and reinstall the previous phpbb version and start again? Although I might lose some data so I would prefer to try to fix this one.
The Australian Forums - Australia Discussion Forum - Discuss Australia topics or generally anything

rAdic
Registered User
Posts: 426
Joined: Mon Apr 25, 2005 11:32 pm
Contact:

Re: Another "No route found for GET /" Error

Post by rAdic » Sun Apr 16, 2017 5:40 am

How can I check what version the backup file is, can I search for something in the file?
The Australian Forums - Australia Discussion Forum - Discuss Australia topics or generally anything

User avatar
Lumpy Burgertushie
Registered User
Posts: 63196
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Another "No route found for GET /" Error

Post by Lumpy Burgertushie » Sun Apr 16, 2017 2:48 pm

did you purge the cache?
'
try that.

as for the backup, if you are talking about the database backup then you can open it in a good text editor, find the config table and find the version number.



robert
I am available for custom work on a donation basis. Please send me a PM with your needs.
Premium phpBB 3.2 Styles by PlanetStyles.net

New phpbb 3.0 support site

rAdic
Registered User
Posts: 426
Joined: Mon Apr 25, 2005 11:32 pm
Contact:

Re: Another "No route found for GET /" Error

Post by rAdic » Mon Apr 17, 2017 9:59 am

I purged the cache but the same error is there. I also can not even see my site in firefox.

Code: Select all

General Error

Module not accessible

BACKTRACE


FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/functions_module.php
LINE: 565
CALL: trigger_error()

FILE: [ROOT]/adm/index.php
LINE: 82
CALL: p_master->load_active()
The Australian Forums - Australia Discussion Forum - Discuss Australia topics or generally anything

User avatar
Lumpy Burgertushie
Registered User
Posts: 63196
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Another "No route found for GET /" Error

Post by Lumpy Burgertushie » Mon Apr 17, 2017 1:47 pm

I see your board in firefox just fine. I run an old version of FF

try refreshing the browser ctrl+f5


robert
I am available for custom work on a donation basis. Please send me a PM with your needs.
Premium phpBB 3.2 Styles by PlanetStyles.net

New phpbb 3.0 support site

rAdic
Registered User
Posts: 426
Joined: Mon Apr 25, 2005 11:32 pm
Contact:

Re: Another "No route found for GET /" Error

Post by rAdic » Fri Apr 21, 2017 9:21 am

So I deleted it all and installed a clean install of 3.1.10. I then uploaded the portal mod. I disabled the mod and renabed it. I went to the extensions page and it no longer has the error.

I will now attempt to update to 3.2 and try it again....
The Australian Forums - Australia Discussion Forum - Discuss Australia topics or generally anything

rAdic
Registered User
Posts: 426
Joined: Mon Apr 25, 2005 11:32 pm
Contact:

Re: Another "No route found for GET /" Error

Post by rAdic » Fri Apr 21, 2017 12:22 pm

DELETED previous

anyway I uploaded it now

where is the page that shows how to do a full upgrade?
The Australian Forums - Australia Discussion Forum - Discuss Australia topics or generally anything

User avatar
Mick
Support Team Member
Support Team Member
Posts: 17374
Joined: Fri Aug 29, 2008 9:49 am

Re: Another "No route found for GET /" Error

Post by Mick » Fri Apr 21, 2017 2:51 pm

rAdic wrote:
Fri Apr 21, 2017 12:22 pm
where is the page that shows how to do a full upgrade?
https://www.phpbb.com/support/docs/en/3 ... upgrade31/
"The more connected we get the more alone we become" - Kyle Broflovski

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: No registered users and 14 guests