Missing file errors during install?

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
Culito
Registered User
Posts: 5
Joined: Mon Dec 18, 2017 12:00 am

Missing file errors during install?

Post by Culito » Mon Dec 18, 2017 12:21 am

Support Request Template
What version of phpBB are you using? phpBB 3.2.1
What is your board's URL? http://drunkagain.com/sewr/forum
Who do you host your board with? GoDaddy
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Update from a previous version of phpBB
Is registration required to reproduce this issue? No
Do you have any MODs installed? No
Do you have any extensions installed? No
What version of phpBB3 did you update from? unsure (last install in 2013)
What styles do you currently have installed? default
What language(s) is your board currently using? american english
Which database type/version are you using? MySQL
What is your level of experience? Novice
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? Board broke somehow, possible hack or other error / crash. Last install was in 2013, so not sure what version I was using (I was pretty hands-off, just let it run.)
Here's what I've done so far:
-Tried updating to newest version (3.2.1) using the guide on this site.
-Hosting company had to update SQL to 5.4
-backed up old database, restored database to a fresh 5.4 version
-created new config.php using guide on this site (unsure if done correctly)
-checked file permissions using guide on this site (unsure if done correctly)

Does not get past error (see below) when trying to update / install.

Thanks all!

Please describe your problem.

Fatal error: Uncaught exception 'InvalidArgumentException' with message 'The file "installer/config.yml" does not exist (in: ).' in /home/content/26/3795826/html/sewr/forum/vendor/symfony/config/FileLocator.php:69 Stack trace: #0 /home/content/26/3795826/html/sewr/forum/vendor/symfony/dependency-injection/Loader/YamlFileLoader.php(42):Symfony\Component\Config\FileLocator->locate('installer/confi...') #1 /home/content/26/3795826/html/sewr/forum/phpbb/di/container_builder.php(185): Symfony\Component\DependencyInjection\Loader\YamlFileLoader->load('installer/confi...') #2 /home/content/26/3795826/html/sewr/forum/install/startup.php(143): phpbb\di\container_builder->get_container() #3 /home/content/26/3795826/html/sewr/forum/install/app.php(30): require('/home/content/2...') #4 {main} thrown in /home/content/26/3795826/html/sewr/forum/vendor/symfony/config/FileLocator.php on line 69
Generated by SRT Generator

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 49241
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Missing file errors during install?

Post by stevemaury » Mon Dec 18, 2017 3:04 am

As the message says, config/installer/config.yml is missing. Upload it from the download on your local computer.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. PM or email me.

All unsolicited PMs will be ignored.

Culito
Registered User
Posts: 5
Joined: Mon Dec 18, 2017 12:00 am

Re: Missing file errors during install?

Post by Culito » Mon Dec 18, 2017 5:14 am

stevemaury wrote:
Mon Dec 18, 2017 3:04 am
As the message says, config/installer/config.yml is missing. Upload it from the download on your local computer.
Thanks...
I guess I'm not sure where to look in the 3.2.1 Zip package I downloaded. There is no vendor/symphony/config/installer in the local folder...would it have been missing from the package...?

User avatar
david63
Jr. Extension Validator
Posts: 14455
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: Missing file errors during install?

Post by david63 » Mon Dec 18, 2017 6:26 am

You should have a folder called config in the root of your board and that is where you should be looking. Just re-upload this folder, but do not confuse it with the file config.php
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

Culito
Registered User
Posts: 5
Joined: Mon Dec 18, 2017 12:00 am

Re: Missing file errors during install?

Post by Culito » Mon Dec 18, 2017 2:49 pm

Hmm, there is a config folder under /phpbb. The only main directories in the root folder are:

adm
assets
bin
cache
docs
download
ext
includes
install
language
phpbb
styles
vendor


There is a config folder under phpbb, which I re-uploaded, with no change.

User avatar
david63
Jr. Extension Validator
Posts: 14455
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: Missing file errors during install?

Post by david63 » Mon Dec 18, 2017 2:52 pm

You are missing several folders in the root of your board

config
files
images
store


You need to upload them from the original download.
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

Culito
Registered User
Posts: 5
Joined: Mon Dec 18, 2017 12:00 am

Re: Missing file errors during install?

Post by Culito » Tue Dec 19, 2017 3:51 am

Got it. I guess I deleted that folder from the original download.

I can get to the installer now, but if I click a tab (update or convert) I get a No input file specified error.

And, if I navigate to the forum, I get a Table 'sewrbase2.phpbb_users' doesn't exist [1146] error, which, in fact, is why I figured I should upgrade the whole shebang in the first place. Checking the database, the phpbb_users table isn't there. Of course I don't have a database backup.

So...unsure where to go from here.

Thanks!

Culito
Registered User
Posts: 5
Joined: Mon Dec 18, 2017 12:00 am

Re: Missing file errors during install?

Post by Culito » Tue Dec 19, 2017 4:04 am

Update: it appears that several other tables are missing, so starting from scratch and yes, valuable lesson learned about backups.

Thanks all.

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: No registered users and 12 guests