not possible to use any up-to-date PHP 7 version - missing module?

Do not post support requests, bug reports or feature requests. Discuss phpBB here. Non-phpBB related discussion goes in General Discussion!
Get Involved
User avatar
Scanialady
Registered User
Posts: 200
Joined: Thu Jan 17, 2013 7:09 pm
Location: Germany
Name: Annette
Contact:

not possible to use any up-to-date PHP 7 version - missing module?

Post by Scanialady » Thu Jun 21, 2018 4:55 pm

I moved my sites to another hoster. Before they all run with PHP 7.1.16

Now on the new server I can not use any version of PHP 7 (available 7.0.30-7.1.18-7.2.6)
With all of them I get an error with phpBB-backups:
If I use "save on server" I get error 500 (no server error log available)

If I use "download" I get:

Code: Select all

the website under https://forum.ladyscommunity.de/adm/index.php?i=acp_database&sid=xxxxxxxxxxxxxxxxxxxxxxxxx0&mode=backup&action=download may be temporarily unavailable or permanently moved to a new web address.
ERR_INVALID_RESPONSE
is there a module of PHP missing? A wrong setting on php.ini? Can someone guide me?
with 5.6.36 all is ok
Webseite, Blog, Wiki
JV-Arcade / phpBB-Arcade / dmzx-Extensions Übersetzungsteam, andere deutsche Übersetzungen - german language files

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 49487
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: not possible to use any up-to-date PHP 7 version - missing module?

Post by stevemaury » Thu Jun 21, 2018 5:10 pm

This would seem to be a host issue; not a phpBB issue.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. PM or email me.

All unsolicited PMs will be ignored.

User avatar
Scanialady
Registered User
Posts: 200
Joined: Thu Jan 17, 2013 7:09 pm
Location: Germany
Name: Annette
Contact:

Re: not possible to use any up-to-date PHP 7 version - missing module?

Post by Scanialady » Thu Jun 21, 2018 5:16 pm

I think so, but it seems that my host is not able to find out. I am sure one of you can identify the missing or wrong setting or module that phpBB needs to work.
Webseite, Blog, Wiki
JV-Arcade / phpBB-Arcade / dmzx-Extensions Übersetzungsteam, andere deutsche Übersetzungen - german language files

User avatar
david63
Jr. Extension Validator
Posts: 14653
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: not possible to use any up-to-date PHP 7 version - missing module?

Post by david63 » Thu Jun 21, 2018 8:14 pm

Could it be a server permissions/owner issue?
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
3Di
Registered User
Posts: 12899
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: not possible to use any up-to-date PHP 7 version - missing module?

Post by 3Di » Thu Jun 21, 2018 10:39 pm

Are you using Chrome?

What about mod security?
Want to compensate me for my interest? Donate
Please PM me only to request paid works. Thx.
Extensions, Scripts, MOD porting, Update/Upgrades
My development's activity º PhpStorm's proud user

User avatar
Mick
Support Team Member
Support Team Member
Posts: 19996
Joined: Fri Aug 29, 2008 9:49 am
Location: Cardiff

Re: not possible to use any up-to-date PHP 7 version - missing module?

Post by Mick » Fri Jun 22, 2018 6:36 am

Scanialady wrote:
Thu Jun 21, 2018 4:55 pm
I moved my sites to another hoster. Before they all run with PHP 7.1.16
Presumably you’re paying for this service but, even if you aren’t, it’s down to them. If they truly don’t know send them to php.net.
Scanialady wrote:
Thu Jun 21, 2018 4:55 pm
is there a module of PHP missing? A wrong setting on php.ini?
Theres no server support available at phpBB.com, everybody and his dog is using PHP 7+ without an issue on a myriad of different servers around the world so why can’t these people set it up properly for you?
"The more connected we get the more alone we become" - Kyle Broflovski

There are no ‘threads’ in phpBB, they are topics.

User avatar
Scanialady
Registered User
Posts: 200
Joined: Thu Jan 17, 2013 7:09 pm
Location: Germany
Name: Annette
Contact:

Re: not possible to use any up-to-date PHP 7 version - missing module?

Post by Scanialady » Fri Jun 22, 2018 7:56 pm

david63 wrote:
Thu Jun 21, 2018 8:14 pm
Could it be a server permissions/owner issue?
I asked them first for this. They say no. All is fine.
3Di wrote:
Thu Jun 21, 2018 10:39 pm
Are you using Chrome?

What about mod security?
mod security was the second I asked for. On my cpanel the setting is "off" - but is it really off? They say yes. All is fine.
I am using Chrome, Iron or Firefox, today this, today that. But the server should work with all, no? Which browser do you think would make a difference?
Mick wrote:
Fri Jun 22, 2018 6:36 am
everybody and his dog is using PHP 7+ without an issue on a myriad of different servers around the world so why can’t these people set it up properly for you?
Thats the question... Yes, I pay for it, and it seems to be too much. 50 mails - and no success.
Webseite, Blog, Wiki
JV-Arcade / phpBB-Arcade / dmzx-Extensions Übersetzungsteam, andere deutsche Übersetzungen - german language files

User avatar
canonknipser
Registered User
Posts: 1600
Joined: Thu Sep 08, 2011 4:16 am
Location: Germany
Name: Frank Jakobs
Contact:

Re: not possible to use any up-to-date PHP 7 version - missing module?

Post by canonknipser » Fri Jun 22, 2018 8:45 pm

Did you check the permissions for the store directory, because database backups are stored there? Should be at least 755, better 777 depending on server setup.
Did your host check the permissions for the server's temp directory assigned to your account?
Greetings, Frank
phpbb.de support team member
English is not my native language - no support via PM or mail
New arrival - Extensions and scripts for phpBB

User avatar
Scanialady
Registered User
Posts: 200
Joined: Thu Jan 17, 2013 7:09 pm
Location: Germany
Name: Annette
Contact:

Re: not possible to use any up-to-date PHP 7 version - missing module?

Post by Scanialady » Sat Jun 23, 2018 8:20 am

canonknipser wrote:
Fri Jun 22, 2018 8:45 pm
Did you check the permissions for the store directory, because database backups are stored there? Should be at least 755, better 777 depending on server setup.
Did your host check the permissions for the server's temp directory assigned to your account?
I did and they say, they did... It works all with 5.6.36 - all problems are with 7.x so I don't believe it is a browser problem (error 500 is a server caused error) or a folder chmod on my ftp.

It works with 5.6.36 - shouldnt there not be the same chmod on server side? tmp and so on?
I wonder which php modules have to be active and which php.ini settings to get phpbb to work normal with PHP 7.x Some of them I can set.
Can someone list it for me?
Webseite, Blog, Wiki
JV-Arcade / phpBB-Arcade / dmzx-Extensions Übersetzungsteam, andere deutsche Übersetzungen - german language files

User avatar
david63
Jr. Extension Validator
Posts: 14653
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: not possible to use any up-to-date PHP 7 version - missing module?

Post by david63 » Sat Jun 23, 2018 8:32 am

Scanialady wrote:
Fri Jun 22, 2018 7:56 pm
Yes, I pay for it
Then tell them to sort it out - it is a server configuration problem.

If they cannot fix it then tell them what they do with their hosting and go somewhere else. If they cannot get something like this right then you are only going to get more problems with them over time.
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
Scanialady
Registered User
Posts: 200
Joined: Thu Jan 17, 2013 7:09 pm
Location: Germany
Name: Annette
Contact:

Re: not possible to use any up-to-date PHP 7 version - missing module?

Post by Scanialady » Sat Jun 23, 2018 9:20 pm

I am sure you are right, but that does not help in any way just now ;-)
I don't get my money back. And they say the server is good and phpBB is the problem - so I need more knowledge to point them to the right direction. May be it is something I can set by myself or I can ask them to switch it on or off. If I know what it is. It is not depending on my board or on extensions, the same problem is with a fresh new installed phpBB without any extension or forum or posting.
Webseite, Blog, Wiki
JV-Arcade / phpBB-Arcade / dmzx-Extensions Übersetzungsteam, andere deutsche Übersetzungen - german language files

User avatar
GanstaZ
Registered User
Posts: 415
Joined: Wed Oct 11, 2017 10:29 pm
Location: Zverse

Re: not possible to use any up-to-date PHP 7 version - missing module?

Post by GanstaZ » Sat Jun 23, 2018 9:48 pm

How can someone point you to a right direction, if even you don't have full access to ini file/s? To find out something that is related to a php 7+ configuration problem (server issue/wrong configuration), you can do this manually on a local server & get lucky. You may try uncle google.. but even if you get an answer it may be an assumption and not a right answer.
"When answer lies in the question,.. question becomes redundant!"

User avatar
Lumpy Burgertushie
Registered User
Posts: 64880
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: not possible to use any up-to-date PHP 7 version - missing module?

Post by Lumpy Burgertushie » Sat Jun 23, 2018 10:39 pm

as you say, it is not anything to do with phpbb. It is a server setup problem and if they can't figure it out you need to change hosting.

we can't help you point them in the right direction because we are not server setup/php setup experts, they are supposed to know how to setup their server programs properly.
if you really think you need to tell them how to do thier job then you should probably go to a site that supports server software. or maybe go to php.net to see if they can help you help your host support.

have you contacted level two support at your host? the first level only know how to open the manual and tell you it is not their problem.


robert
I am available for custom work on a donation basis. Please send me a PM with your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

OK, so what's the speed of dark?

User avatar
Ger
Recognised Extension Developer
Posts: 1674
Joined: Wed Jan 02, 2008 7:35 pm
Location: 192.168.1.100
Contact:

Re: not possible to use any up-to-date PHP 7 version - missing module?

Post by Ger » Mon Jun 25, 2018 7:58 am

Scanialady wrote:
Thu Jun 21, 2018 4:55 pm
no server error log available
That's odd. Any PHP error would be in the PHP error log, any apache or nginx error should be in the main server error log. Since a 500 error states it's a server error you should have either of those. Maybe not for you in you hosting control panel but your host should definitely have it.

Also: have you tried a simple default phpBB setup for checking? Try to download a vanilla 3.2 package and install. Does that even work?
My extensions:
Simple CMS, Feed post bot, Avatar Resize, Modbreak, Magic OGP, Live topic update, Modern Quote, Quoted Where (GDPR) and Autoresponder.
Newest: FAQ manager for 3.2

Like my work? Buy me a coffee to keep it coming. :ugeek:
-Available for custom work-

User avatar
Scanialady
Registered User
Posts: 200
Joined: Thu Jan 17, 2013 7:09 pm
Location: Germany
Name: Annette
Contact:

Re: not possible to use any up-to-date PHP 7 version - missing module?

Post by Scanialady » Wed Jun 27, 2018 6:00 am

Ger wrote:
Mon Jun 25, 2018 7:58 am
That's odd. Any PHP error would be in the PHP error log, any apache or nginx error should be in the main server error log. Since a 500 error states it's a server error you should have either of those. Maybe not for you in you hosting control panel but your host should definitely have it.
Yes. But I can not see it.
Ger wrote:
Mon Jun 25, 2018 7:58 am
Also: have you tried a simple default phpBB setup for checking? Try to download a vanilla 3.2 package and install. Does that even work?
As I said some postings before: I tried and no.
Webseite, Blog, Wiki
JV-Arcade / phpBB-Arcade / dmzx-Extensions Übersetzungsteam, andere deutsche Übersetzungen - german language files

Post Reply

Return to “phpBB Discussion”

Who is online

Users browsing this forum: ichiro [Crawler], Lumpy Burgertushie, Tbot [Bot] and 25 guests