Installing 3.2 in a test forum

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
User avatar
John connor
Registered User
Posts: 2054
Joined: Fri Nov 14, 2014 5:14 pm
Location: U S Of A
Name: Aaron
Contact:

Installing 3.2 in a test forum

Post by John connor » Sun Dec 25, 2016 4:54 pm

I used the update package, went to mywebsite/install to install. It told me I needed to delete a huge amount of files as they were not part of the old version. I didn't do this and just went ahead with the update anyway. Of course things aren't working right and I have what looks like a style/CSS issue.

Couple of questions:

Is there a list of all the files I need to remove since I don't have that list anymore?

Is there an easier way to try 3.2 without having to delete all those files manually?

User avatar
david63
Registered User
Posts: 16068
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: Installing 3.2 in a test forum

Post by david63 » Sun Dec 25, 2016 6:19 pm

Just upload all the files and run the database update.
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
John connor
Registered User
Posts: 2054
Joined: Fri Nov 14, 2014 5:14 pm
Location: U S Of A
Name: Aaron
Contact:

Re: Installing 3.2 in a test forum

Post by John connor » Sun Dec 25, 2016 8:32 pm

So don't use the update method?

Edit-

So I used the phpBB-3.2.0-RC2 zip file and uploaded all of its content to my FTP. I went to mywebsite/install and updated the database and I still have bad CSS or something else going on. You can view the test board here:
removed by me

I will next delete everything and reupload the phpBB-3.2.0-RC2 files.
Last edited by John connor on Mon Dec 26, 2016 12:39 am, edited 1 time in total.

User avatar
John connor
Registered User
Posts: 2054
Joined: Fri Nov 14, 2014 5:14 pm
Location: U S Of A
Name: Aaron
Contact:

Re: Installing 3.2 in a test forum

Post by John connor » Mon Dec 26, 2016 12:25 am

Update. I deleted all the phpBB files and uploaded all of the phpBB-3.2.0-RC2 files. I still have this funky CSS/style issue.

I am for sure using 3.2 as shown here: http://imgur.com/Oo3ONYh

Edit-

Found the issue! Was CloudFlare's cache causing the style and CSS to act up. Once I cleared the cache all is normal. Now I can test 3.2 with all my extensions and what not.

Question: What is the Production folder in the cache folder?

User avatar
david63
Registered User
Posts: 16068
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: Installing 3.2 in a test forum

Post by david63 » Mon Dec 26, 2016 8:47 am

John connor wrote:Question: What is the Production folder in the cache folder?
It is where all the cached files reside. In phpBB 3.2 there can, and will be, several folders within the cached folder - normally production and install, but over time others may appear depending on your configuration and/or what the developers decide to do.

There is no problem with this - if you need to clear the phpBB cache you just delete that folder, without the need of deleting individual files, and it will be re-created
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
pierredu
Registered User
Posts: 918
Joined: Thu Nov 01, 2012 8:04 am
Location: Paris (France)

Re: Installing 3.2 in a test forum

Post by pierredu » Mon Dec 26, 2016 8:31 pm

Thanks for telling us the truth.
I had not yet read this exposed clearly.
What about a debug option, for instance ?

User avatar
3Di
Former Team Member
Posts: 13664
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: Installing 3.2 in a test forum

Post by 3Di » Mon Dec 26, 2016 9:01 pm

pierredu wrote:Thanks for telling us the truth.
I had not yet read this exposed clearly.
What about a debug option, for instance ?
https://area51.phpbb.com/phpBB/viewtopi ... 06#p290406
https://tracker.phpbb.com/browse/PHPBB3-14602

That should be available on production environments I think, 3.2.0 Gold will be.
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
👨‍🏫 | Take a tour to | The Studio | 👨‍🏫

User avatar
John connor
Registered User
Posts: 2054
Joined: Fri Nov 14, 2014 5:14 pm
Location: U S Of A
Name: Aaron
Contact:

Re: Installing 3.2 in a test forum

Post by John connor » Tue Dec 27, 2016 2:31 am

david63 wrote:
John connor wrote:Question: What is the Production folder in the cache folder?
It is where all the cached files reside. In phpBB 3.2 there can, and will be, several folders within the cached folder - normally production and install, but over time others may appear depending on your configuration and/or what the developers decide to do.

There is no problem with this - if you need to clear the phpBB cache you just delete that folder, without the need of deleting individual files, and it will be re-created

Thanks for the answer. I wasn't sure if I should delete that folder or not. I did clear the cache in the board and that folder with its contents remained.

User avatar
John connor
Registered User
Posts: 2054
Joined: Fri Nov 14, 2014 5:14 pm
Location: U S Of A
Name: Aaron
Contact:

Re: Installing 3.2 in a test forum

Post by John connor » Tue Dec 27, 2016 7:25 am

I seem to get an error above the page for attachment settings under posting.

Code: Select all

[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions_acp.php on line 590: file_exists(): open_basedir restriction in effect. File(/usr/bin/) is not within the allowed path(s): (/home/systechf:/usr/lib/php:/usr/php4/lib/php:/usr/local/lib/php:/usr/local/php4/lib/php:/tmp)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions_acp.php on line 595: file_exists(): open_basedir restriction in effect. File(/usr/bin/) is not within the allowed path(s): (/home/systechf:/usr/lib/php:/usr/php4/lib/php:/usr/local/lib/php:/usr/local/php4/lib/php:/tmp)

Is this a known issue in RC2?

User avatar
david63
Registered User
Posts: 16068
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: Installing 3.2 in a test forum

Post by david63 » Tue Dec 27, 2016 7:36 am

John connor wrote:Is this a known issue in RC2?
I think that the error is caused by a server misconfiguration open_basedir restriction in effect
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
John connor
Registered User
Posts: 2054
Joined: Fri Nov 14, 2014 5:14 pm
Location: U S Of A
Name: Aaron
Contact:

Re: Installing 3.2 in a test forum

Post by John connor » Tue Dec 27, 2016 12:19 pm

Sent a support request with my host. I'm wondering if it's Suhosin as I use a shared account.

User avatar
Scanialady
Registered User
Posts: 265
Joined: Thu Jan 17, 2013 7:09 pm
Location: Germany
Name: Annette
Contact:

Re: Installing 3.2 in a test forum

Post by Scanialady » Tue Dec 27, 2016 3:03 pm

You are not alone with your problem - shared hosting seems to restrict open_basedir often

viewtopic.php?p=14578296#p14578296
Webseite, Blog, Wiki Deutsche Übersetzungen - german language files
My 2 cents: Whether an extension is in the CDB says nothing about its quality. It is more important to read the support topics for it. Better to avoid authors who do not answer support questions themselves, who do not update their stuff, and who do not fix bugs for years.

User avatar
John connor
Registered User
Posts: 2054
Joined: Fri Nov 14, 2014 5:14 pm
Location: U S Of A
Name: Aaron
Contact:

Re: Installing 3.2 in a test forum

Post by John connor » Tue Dec 27, 2016 5:21 pm

I asked my host and they do have that restriction. This needs to be resolved otherwise shard accounts won't have the ability to use 3.2.

User avatar
John connor
Registered User
Posts: 2054
Joined: Fri Nov 14, 2014 5:14 pm
Location: U S Of A
Name: Aaron
Contact:

Re: Installing 3.2 in a test forum

Post by John connor » Wed Dec 28, 2016 2:58 am

My host says that the script shouldn't be checking for a particular binary in /usr/bin/.

Does anyone have a ticket for this at Area 51? I'm not good at creating tickets and this needs to be brought up. Other wise this new version will alienate users who use shared accounts.

User avatar
3Di
Former Team Member
Posts: 13664
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: Installing 3.2 in a test forum

Post by 3Di » Wed Dec 28, 2016 3:07 am

John connor wrote:My host says that the script shouldn't be checking for a particular binary in /usr/bin/.

Does anyone have a ticket for this at Area 51? I'm not good at creating tickets and this needs to be brought up. Other wise this new version will alienate users who use shared accounts.
The fix is work in progress.
https://tracker.phpbb.com/browse/PHPBB3-14934
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
👨‍🏫 | Take a tour to | The Studio | 👨‍🏫

Post Reply

Return to “[3.2.x] Support Forum”