Problem with "FTP - Autmatic files update"

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
User avatar
janus_zonstraal
Registered User
Posts: 4852
Joined: Sat Aug 30, 2014 1:30 pm

Re: Problem with "FTP - Autmatic files update"

Post by janus_zonstraal »

Not sure what you already did, but try to empty the browser cache with Ctrl + F5
Sorry! My English is bat ;) !!!
kronos1
Registered User
Posts: 508
Joined: Tue Aug 23, 2011 1:46 pm

Re: Problem with "FTP - Autmatic files update"

Post by kronos1 »

That has put the screen back to normal but I cannot post now.

This is the message in the ACP.
Untitled1.png
User avatar
janus_zonstraal
Registered User
Posts: 4852
Joined: Sat Aug 30, 2014 1:30 pm

Re: Problem with "FTP - Autmatic files update"

Post by janus_zonstraal »

Place the backup back from your files
Sorry! My English is bat ;) !!!
kronos1
Registered User
Posts: 508
Joined: Tue Aug 23, 2011 1:46 pm

Re: Problem with "FTP - Autmatic files update"

Post by kronos1 »

Like an idiot I never did a back up, is there anything else I can do to put it back to 3.1.10 or to continue to 3.2

This is the error message I get when I try to post.

Fatal error: Uncaught exception 'InvalidArgumentException' with message 'Invalid scheme name ''' in /home/traditio/public_html/vendor/s9e/text-formatter/src/Configurator.php:8898 Stack trace: #0 /home/traditio/public_html/vendor/s9e/text-formatter/src/Configurator.php(8524): s9e\TextFormatter\Configurator\Collections\SchemeList->normalizeValue('') #1 /home/traditio/public_html/vendor/s9e/text-formatter/src/Configurator.php(8559): s9e\TextFormatter\Configurator\Collections\NormalizedList->append('') #2 /home/traditio/public_html/vendor/s9e/text-formatter/src/Configurator.php(7739): s9e\TextFormatter\Configurator\Collections\NormalizedList->offsetSet(NULL, '') #3 /home/traditio/public_html/phpbb/textformatter/s9e/factory.php(214): s9e\TextFormatter\Configurator\UrlConfig->allowScheme('') #4 /home/traditio/public_html/phpbb/textformatter/s9e/factory.php(376): phpbb\textformatter\s9e\factory->get_configurator() #5 /home/traditio/public_html/phpbb/textformatter/s9e/parser.php(47): phpbb\textformatter\s9e\factory->regenerate() in /home/traditio/public_html/vendor/s9e/text-formatter/src/Configurator.php on line 8898
KineticTom2
Registered User
Posts: 1
Joined: Sat Jan 14, 2017 8:08 pm

Re: Problem with "FTP - Autmatic files update"

Post by KineticTom2 »

kronos1 wrote:
Sat Jan 14, 2017 12:18 pm
I have asked the host but not sure how long it will take so I removed the install file so my board can still be up and running and it now looks like this.

What can I do to put it right.

Untitled.png
I have the exact same problem with my board. The menus are screwed up, the background images cover up all the content, and the site is unusable. This 3.2 installer is a disaster for both of us.

-Tom
Paul
Infrastructure Team Leader
Infrastructure Team Leader
Posts: 26842
Joined: Sat Dec 04, 2004 3:44 pm
Location: The netherlands.
Name: Paul Sohier
Contact:

Re: Problem with "FTP - Autmatic files update"

Post by Paul »

KineticTom2, can you open a new topic? While it might look like a simular issue, it is lots easier to help if we keep things seperated.
Knock knock
Race condition
Who's there?

My BlogMy Photosmy phpBB Extensionscustom phpBB work & Development
User avatar
janus_zonstraal
Registered User
Posts: 4852
Joined: Sat Aug 30, 2014 1:30 pm

Re: Problem with "FTP - Autmatic files update"

Post by janus_zonstraal »

Like an idiot I never did a back up, is there anything else I can do to put it back to 3.1.10 or to continue to 3.2
Try to download a 3.1.10 package from here and upload it (except config.php and the /install/ folder )
https://www.phpbb.com/downloads/3.1/
Sorry! My English is bat ;) !!!
kronos1
Registered User
Posts: 508
Joined: Tue Aug 23, 2011 1:46 pm

Re: Problem with "FTP - Autmatic files update"

Post by kronos1 »

Everything seems to be working now, I deleted my config_php_file.php and it let carry on with the 3.2 update and I never received the time out message again.

3.2 seems to be working ok now.
capitalismx
Registered User
Posts: 23
Joined: Tue Mar 15, 2016 4:24 pm

Re: Problem with "FTP - Autmatic files update"

Post by capitalismx »

kronos1 wrote:
Sat Jan 14, 2017 11:00 am
Lumpy Burgertushie wrote:
Mon Jan 09, 2017 4:08 pm
the ONLY reason to be trying to use the auto update method is if you have been editing the core phpbb files for some reason.

if not, then the best way to upgrade any version of phpbb is a file replacement.

Upgrading from phpbb 3.1.x/3.2.x or updating to newest phpbb 3.2.x

Backup up your board's files and database
  • Go to the admin panel of your current board and purge the cache.
  • Download the full package of 3.2. click here 3.2.x Full Package
  • Unzip it to your computer, now remove the file named config.php
  • Upload all the rest of the files and folders into your forum's directory (Note: you don't want to overwrite your original config.php file)
  • Browse to yourdomain.com/yourphpbb/install/ then click the update tab. Click update.
  • Delete the folder named /install/
I am updating from 3.1.10 to 3.2 and have followed the above but when I click on update tab I receive the "The installer detected a timeout". What do I need to do now.
I click on update tab I receive the "403 error Access denied.".
I have no idea what to do now, total lost.
capitalismx
Registered User
Posts: 23
Joined: Tue Mar 15, 2016 4:24 pm

Re: Problem with "FTP - Autmatic files update"

Post by capitalismx »

kronos1 wrote:
Sat Jan 14, 2017 11:00 am
Lumpy Burgertushie wrote:
Mon Jan 09, 2017 4:08 pm
the ONLY reason to be trying to use the auto update method is if you have been editing the core phpbb files for some reason.

if not, then the best way to upgrade any version of phpbb is a file replacement.

Upgrading from phpbb 3.1.x/3.2.x or updating to newest phpbb 3.2.x

Backup up your board's files and database
  • Go to the admin panel of your current board and purge the cache.
  • Download the full package of 3.2. click here 3.2.x Full Package
  • Unzip it to your computer, now remove the file named config.php
  • Upload all the rest of the files and folders into your forum's directory (Note: you don't want to overwrite your original config.php file)
  • Browse to yourdomain.com/yourphpbb/install/ then click the update tab. Click update.
  • Delete the folder named /install/
I am updating from 3.1.10 to 3.2 and have followed the above but when I click on update tab I receive the "The installer detected a timeout". What do I need to do now.
I click on update tab I receive the "403 error Access denied.".
I have no idea what to do now, total lost.
User avatar
RMcGirr83
Former Team Member
Posts: 21587
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr

Re: Problem with "FTP - Autmatic files update"

Post by RMcGirr83 »

Paul wrote:
Sat Jan 14, 2017 8:15 pm
can you open a new topic? While it might look like a simular issue, it is lots easier to help if we keep things seperated.
Appreciate the extensions/mods/support then buy me a beerImage
Former Modifications/Extensions Team Member | My extensions | github | All requests for support via PM will be ignored
ledgands
Registered User
Posts: 9
Joined: Tue Sep 04, 2007 7:22 am

Re: Problem with "FTP - Autmatic files update"

Post by ledgands »

This is very annoying.

I am having a terrible time with the update from 3.1.10 to 3.2.0

I had the time out error when trying to evaluation the files. So i deleted the shop/install_config.php file and managed to get past that stage. I then tried to proceed to the next step...updating the database and the same thing happened again.

I have my execution timeout set to 250s.

Why doesn't this work? My error says that this processes has also timed out!!!

Thanks for any advice
zappo1
Registered User
Posts: 1
Joined: Sat Feb 18, 2017 6:03 pm

Re: Problem with "FTP - Autmatic files update"

Post by zappo1 »

Stuck in a broken update, my board looked as screwed as kronos1s....

This is what finally worked:
- upload and overwrite the complete 3.2 files to the old board EXCEPT config.php!
- if exist, delete /store/install_config.php and /store/io_lock.lock
- start install process by browsing mysite/install
- then, since all files are version 3.2n already choose "update database only"
- delete /install folder
- and in case you just updated you servers php to V7.x: make sure line 4 in config.php points to database type mysqli rather than mysql:
$dbms = 'mysqli';
- done :-)
RolandoSmith
Registered User
Posts: 4
Joined: Sat Mar 18, 2017 3:30 pm

Re: Problem with "FTP - Autmatic files update"

Post by RolandoSmith »

I've been right through all this and still get the timeout error.
Last thing I did was to delete the io_lock.lock file
RolandoSmith
Registered User
Posts: 4
Joined: Sat Mar 18, 2017 3:30 pm

Re: Problem with "FTP - Autmatic files update"

Post by RolandoSmith »

All sorted now.
Post Reply

Return to “[3.2.x] Support Forum”