Page 1 of 3

Problem with "FTP - Autmatic files update"

Posted: Sun Jan 08, 2017 8:42 am
by Mathieu M.
Hello here,

I'm faced to a problem I never encountered before ! For the first time, I choose the FTP automatic files update to convert from 3.2.0-rc2 to 3.2.0 and when I submit "Update files", I get this error :

The installer detected a timeout

The installer has detected a timeout, you may try to refresh the page, which may lead to data corruption. We suggest that you either increase your timeout settings or try to use the CLI.
Well, I tried to return to install index, but impossible to choose the manual files update, it's automatically choose the FTP automatic files update now... I tried to clear cache from FTP and my browser but nothing happens.

Do you have an idea ?


Thanks ! 👍

Re: Problem with "FTP - Autmatic files update"

Posted: Sun Jan 08, 2017 9:19 am
by divingbrit
I had the very same problem, there is a post that gives the answer,but I can't find it the moment
I think I had to go to the /store dir and remove an config file. Unfortunately if you get a successful install, which I did, you no longer see this file
You could wait and see if others have the same problem

Best of luck

Re: Problem with "FTP - Autmatic files update"

Posted: Sun Jan 08, 2017 10:25 am
by RMcGirr83
Yes there is a file that can be deleted and will allow the update process to start from square one. Can't remember the name of it off the top of my head but I do know it is a php file and I do know it is not the io_lock.lock php file.

Re: Problem with "FTP - Autmatic files update"

Posted: Sun Jan 08, 2017 10:54 am
by Mathieu M.
Ok, thanks both !

It seems to be the store/install_config.php file. I deleted it and I've accomplished the update proccess (but manually this time... don't know why the automatic way failed since my server time_execution is big enough).

Well, again... thank you ! 😄

Re: Problem with "FTP - Autmatic files update"

Posted: Sun Jan 08, 2017 12:15 pm
by divingbrit
The installer has detected a timeout, you may try to refresh the page, which may lead to data corruption. We suggest that you either increase your timeout settings or try to use the CLI.
The instructions to increase your timeout settings, or to use CLI posted previously, are not simple, and so a warning on using "FTP - Autmatic files update" might be in order. Or even a note on the installation page on how to revert back to doing an alternative method.

And also at the end of the successful process a simple note 'saying now delete or rename your install dir, and return to your board.' which was always on previous updates would help.

Re: Problem with "FTP - Autmatic files update"

Posted: Mon Jan 09, 2017 1:33 pm
by higgerz
Had this same issue, thanks for posting this up Mathieu M. - worked for me.

Re: Problem with "FTP - Autmatic files update"

Posted: Mon Jan 09, 2017 1:46 pm
by Fogbow_Foggy
I'm sorry, but if it's true that the only way to successfully upgrade from 3.1.10 to 3.2 is:
  1. upload the auto_update files after unpacking them
  2. merging as many files as possible
  3. deleting a long list of files manually
  4. trying to update the database and having it timeout and warn you that you might corrupt the database if you refresh, or you'll have to use techniques that few of us know about
  5. deleting /store/install_config.php manually
  6. doing a manual update with FTP
  7. ... and hope for the best
... then that means that 3.2 is not ready for upgrading. That's not how an automatic upgrade is supposed to work. On my thread about this problem, Lumpie Burgertushie, who's been here since 2005 and who has more than 62,000 posts, flatly denied there was an instruction to delete a long list of files. That's how messed up the auto_update from 3.1.10 to 3.2 is -- the old-timers never heard of such a thing.

I'm not going to try upgrading again until the auto_update process works like it's supposed to work.

Re: Problem with "FTP - Autmatic files update"

Posted: Mon Jan 09, 2017 4:08 pm
by Lumpy Burgertushie
the ONLY reason to be trying to use the auto update method is if you have been editing the core phpbb files for some reason.

if not, then the best way to upgrade any version of phpbb is a file replacement.

Upgrading from phpbb 3.1.x/3.2.x or updating to newest phpbb 3.2.x

Backup up your board's files and database
  • Go to the admin panel of your current board and purge the cache.
  • Download the full package of 3.2. click here 3.2.x Full Package
  • Unzip it to your computer, now remove the file named config.php
  • Upload all the rest of the files and folders into your forum's directory (Note: you don't want to overwrite your original config.php file)
  • Browse to yourdomain.com/yourphpbb/install/ then click the update tab. Click update.
  • Delete the folder named /install/

Re: Problem with "FTP - Autmatic files update"

Posted: Tue Jan 10, 2017 10:17 am
by Genebaby
I always did the auto update via FTP as it was the easiest and I didn't want to have to redo any little tweaks in code in case something got reset. Either way, it always worked for me.

Then I tried updating to 3.2 and got the error mentioned and found this thread. It didn't help much as I didn't want to do a manual method, but I was able to delete the file needed to start the process again.

This time I chose the other auto update method, can't remember now what it said, and chose zip for the file type, though I don't think that matters.

This time it worked flawlessly and I am on 3.2 on my board.

Re: Problem with "FTP - Autmatic files update"

Posted: Tue Jan 10, 2017 12:08 pm
by Aros010
Same problem here, now I need some help i'm totally lost.

Re: Problem with "FTP - Autmatic files update"

Posted: Tue Jan 10, 2017 12:17 pm
by RMcGirr83
Go to the store directory and delete the file install_config.php. You will then be able to start over at square one.

Re: Problem with "FTP - Autmatic files update"

Posted: Tue Jan 10, 2017 12:48 pm
by kber
RMcGirr83 wrote:
Tue Jan 10, 2017 12:17 pm
Go to the store directory and delete the file install_config.php. You will then be able to start over at square one.
this is help , thank you

Re: Problem with "FTP - Autmatic files update"

Posted: Sat Jan 14, 2017 11:00 am
by kronos1
Lumpy Burgertushie wrote:
Mon Jan 09, 2017 4:08 pm
the ONLY reason to be trying to use the auto update method is if you have been editing the core phpbb files for some reason.

if not, then the best way to upgrade any version of phpbb is a file replacement.

Upgrading from phpbb 3.1.x/3.2.x or updating to newest phpbb 3.2.x

Backup up your board's files and database
  • Go to the admin panel of your current board and purge the cache.
  • Download the full package of 3.2. click here 3.2.x Full Package
  • Unzip it to your computer, now remove the file named config.php
  • Upload all the rest of the files and folders into your forum's directory (Note: you don't want to overwrite your original config.php file)
  • Browse to yourdomain.com/yourphpbb/install/ then click the update tab. Click update.
  • Delete the folder named /install/
I am updating from 3.1.10 to 3.2 and have followed the above but when I click on update tab I receive the "The installer detected a timeout". What do I need to do now.

Re: Problem with "FTP - Autmatic files update"

Posted: Sat Jan 14, 2017 11:22 am
by janus_zonstraal
ask your host for a longer time out setting

Re: Problem with "FTP - Autmatic files update"

Posted: Sat Jan 14, 2017 12:18 pm
by kronos1
I have asked the host but not sure how long it will take so I removed the install file so my board can still be up and running and it now looks like this.

What can I do to put it right.
Untitled.png
Untitled.png (90.15 KiB) Viewed 4156 times