Incompatible Extensions for 3.2

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
User avatar
david63
Jr. Extension Validator
Posts: 12190
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Incompatible Extensions for 3.2

Post by david63 » Sun Jan 08, 2017 11:51 am

Perhaps it would be an idea that when an incompatible extenuation was found that it could be listed in this topic so that there is an easy reference point and those extensions can be disabled and removed before an upgrade is attempted.

I will start off with Auto Database Backup which will give errors - 3.2 compatible version here

My FAQ Manager whist will appear to work will not actually do anything.

Site Logo will not work with 3.2 prosilver - compatible version here
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email or as they will be ignored

User avatar
HiFiKabin
Community Team Member
Community Team Member
Posts: 1916
Joined: Wed May 14, 2014 9:10 am
Name: James
Contact:

Re: Incompatible Extensions for 3.2

Post by HiFiKabin » Sun Jan 08, 2017 1:50 pm

Good Idea David.

Six of my Extensions need upgrading for 3.2.0 due to the FA Icons being used. Leaving them enabled during upgrade will not cause any problems but will upset the look of the page. Links to the 3.2.0 versions below

Google Search
Header Banner
NavBar Search
Obscure Contact Us
Right Header Image
Right Random Image

janus_zonstraal
Registered User
Posts: 1170
Joined: Sat Aug 30, 2014 1:30 pm

Re: Incompatible Extensions for 3.2

Post by janus_zonstraal » Sun Jan 08, 2017 2:49 pm

Recent topics
Pages
Tapatalk
Sorry! My English is bat ;) !!!

User avatar
Scanialady
Registered User
Posts: 135
Joined: Thu Jan 17, 2013 7:09 pm
Location: Germany
Name: Annette
Contact:

Re: Incompatible Extensions for 3.2

Post by Scanialady » Sun Jan 08, 2017 2:56 pm

Board3 Portal
JV-Arcade ->4.0.RC6
JV-Shoutbox -> 1.1.1
Last edited by Scanialady on Tue Jan 10, 2017 9:07 pm, edited 1 time in total.
Webseite, Blog, Wiki
JV-Arcade / phpBB-Arcade / dmzx-Extensions Übersetzungsteam, andere deutsche Übersetzungen - german language files

divingbrit
Registered User
Posts: 86
Joined: Fri Mar 21, 2003 3:18 pm

Re: Incompatible Extensions for 3.2

Post by divingbrit » Sun Jan 08, 2017 3:16 pm

Board3 Portal ok for me
Shy but working at it

User avatar
Scanialady
Registered User
Posts: 135
Joined: Thu Jan 17, 2013 7:09 pm
Location: Germany
Name: Annette
Contact:

Re: Incompatible Extensions for 3.2

Post by Scanialady » Sun Jan 08, 2017 3:38 pm

Not the official Release 2.1.0 - you need to do changes for Board3 Portal to make it work correctly because there are style changes in classes.
Webseite, Blog, Wiki
JV-Arcade / phpBB-Arcade / dmzx-Extensions Übersetzungsteam, andere deutsche Übersetzungen - german language files

User avatar
supanet
Registered User
Posts: 217
Joined: Sat Dec 15, 2012 4:20 pm
Location: UK
Contact:

Re: Incompatible Extensions for 3.2

Post by supanet » Sun Jan 08, 2017 6:06 pm

Great idea, subscribed. ;)

juliokr
Registered User
Posts: 90
Joined: Wed Apr 13, 2016 11:21 am

Re: Incompatible Extensions for 3.2

Post by juliokr » Mon Jan 09, 2017 12:34 pm

Prime Links
http://www.absoluteanime.com/admin/mods.htm
doesn't work with 3.2 gives errors like

Code: Select all

[phpBB Debug] PHP Warning: in file [ROOT]/ext/primehalo/primelinks/event/listener.php on line 153: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead

User avatar
david63
Jr. Extension Validator
Posts: 12190
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: Incompatible Extensions for 3.2

Post by david63 » Mon Jan 09, 2017 1:00 pm

juliokr wrote:
Mon Jan 09, 2017 12:34 pm
Prime Links
That's not a specific 3.2 error it is a PHP7 error
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email or as they will be ignored

juliokr
Registered User
Posts: 90
Joined: Wed Apr 13, 2016 11:21 am

Re: Incompatible Extensions for 3.2

Post by juliokr » Mon Jan 09, 2017 1:56 pm

david63 wrote:
Mon Jan 09, 2017 1:00 pm
juliokr wrote:
Mon Jan 09, 2017 12:34 pm
Prime Links
That's not a specific 3.2 error it is a PHP7 error
No but 3.2 is supposed to work with php7.1 it should also be valid for any Extension

User avatar
david63
Jr. Extension Validator
Posts: 12190
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: Incompatible Extensions for 3.2

Post by david63 » Mon Jan 09, 2017 2:39 pm

juliokr wrote:
Mon Jan 09, 2017 1:56 pm
No but 3.2 is supposed to work with php7.1 it should also be valid for any Extension
I am not disagreeing with you but phpBB 3.2 minimum requirement is PHP 5.4 which is why it is not a specific 3.2 issue.
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email or as they will be ignored

juliokr
Registered User
Posts: 90
Joined: Wed Apr 13, 2016 11:21 am

Re: Incompatible Extensions for 3.2

Post by juliokr » Mon Jan 09, 2017 3:01 pm

david63 wrote:
Mon Jan 09, 2017 2:39 pm
juliokr wrote:
Mon Jan 09, 2017 1:56 pm
No but 3.2 is supposed to work with php7.1 it should also be valid for any Extension
I am not disagreeing with you but phpBB 3.2 minimum requirement is PHP 5.4 which is why it is not a specific 3.2 issue.
No it isn't but I think the topic is "incompatible Extensions for 3.2" and users should be warned to use extensions which will not work correctly with php7 - (it's one of the interests to update to phpBB3.2)

User avatar
spaceace
Registered User
Posts: 1710
Joined: Wed Jan 30, 2008 8:50 pm
Contact:

Re: Incompatible Extensions for 3.2

Post by spaceace » Mon Jan 09, 2017 10:29 pm

my Forum Legend extension. forum icons no longer have the proper css to display them. a temp fix can be found in the support discussion till i can get it submitted for validation app.php/db/extension/forum_legend/suppo ... 56#p525056

User avatar
potku
Registered User
Posts: 689
Joined: Wed Dec 22, 2004 10:26 pm
Location: Tampere, Finland
Contact:

Re: Incompatible Extensions for 3.2

Post by potku » Tue Jan 10, 2017 8:00 am

Great topic, subscribed. :)

It seems to me Upload Extensions isn't working with 3.2.

(Or at least I get this error:

Code: Select all

Catchable fatal error: Object of class phpbb\template\twig\twig could not be converted to string in C:\xampp\htdocs\phpBB3\phpbb\extension\metadata_manager.php on line 131
)
Potku.net

"Before I speak, I have something important to say."

- Groucho Marx

boxerman
Registered User
Posts: 34
Joined: Thu Sep 04, 2008 2:26 pm

Re: Incompatible Extensions for 3.2

Post by boxerman » Tue Jan 10, 2017 8:50 pm

Auto Back up doesn't work - destroyed my first test forum

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: stevemaury, Toxyy and 24 guests