Page 5 of 10

Re: Incompatible Extensions for 3.2

Posted: Mon Jan 16, 2017 7:22 pm
by RMcGirr83
If everyone would read the "read me first" sticky topic most of your issues wouldn't be issues.

viewtopic.php?p=14460936#faq

Re: Incompatible Extensions for 3.2

Posted: Tue Jan 17, 2017 5:46 pm
by LavIgor
I think that there's a reason to list compatible extensions instead.
Because otherwise any piece of information here can easily become irrelevant and outdated.
Or at least please note that extensions can have separate versions for the next branch of phpBB.
potku wrote:
Tue Jan 10, 2017 8:00 am
It seems to me Upload Extensions isn't working with 3.2.
BetoMex wrote:
Tue Jan 17, 2017 11:58 am
It seems to me Upload Extensions isn't working with 3.2.
It seems to me that it is mentioned on its CDB page that
Version 3.1.2 is compatible only with phpBB 3.1.x.
It has a development version and it does work on phpBB 3.2.
rocketjedi wrote:
Wed Jan 11, 2017 4:04 am
QuickReply Reloaded not working
And it is mentioned on its CDB page:
"Please note that version 1.0.2 is not compatible with phpBB 3.2.
Checkout extension's website for any updates."

I suppose that the best choice is to check out extensions' topics/pages yourself and to test the compatibility yourself before going here.
Otherwise users can see "the extension XX is incompatible" and remove it without knowing that the information is (again) outdated and irrelevant.

Re: Incompatible Extensions for 3.2

Posted: Tue Jan 17, 2017 11:59 pm
by RMcGirr83
Or users can, ***gasp***, actually read what is presented to them in the description of the extension. :roll:

Re: Incompatible Extensions for 3.2

Posted: Wed Jan 18, 2017 12:24 am
by 3Di
Or, even better, extension writers should appropriately use ext.php in order to deny the installation
a priori in some case.
Wonder how many issues there would be not, now.

Re: Incompatible Extensions for 3.2

Posted: Wed Jan 18, 2017 7:47 am
by david63
3Di wrote:
Wed Jan 18, 2017 12:24 am
Or, even better, extension writers should appropriately use ext.php in order to deny the installation
a priori in some case.
Wonder how many issues there would be not, now.
But you cannot do that respectively. This would not help with upgrading the coe and how can any extension developer know which versions an extension will not work with in the future?

Re: Incompatible Extensions for 3.2

Posted: Wed Jan 18, 2017 11:12 pm
by pappy1961
I have a problem with one of your old rank extensions David, it seem to have broken my phbb extensions ability. I go to extensions and this is all I can get....
General Error
Cannot find module ./../includes/acp/\david63\userranks\acp\userranks_module.php

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/functions_module.php
LINE: 573
CALL: trigger_error()

FILE: [ROOT]/adm/index.php
LINE: 82
CALL: p_master->load_active()

Re: Incompatible Extensions for 3.2

Posted: Thu Jan 19, 2017 12:00 am
by pappy1961
Any idea how I can fix this? Cannot disable it, cannot delete its data. It is locked up. I run 3.2

EXTENSION NAME CURRENT VERSION OPTIONS ACTIONS
Enabled Extensions
Background Forum 1.0.5 Details Disable
Board Announcements 1.0.5 Details Disable
Disabled Extensions
The “david63/userranks” extension is not valid.
The requested file could not be found: ./../ext/david63/userranks/composer.json

and....

General Error
Cannot find module ./../includes/acp/\david63\userranks\acp\userranks_module.php

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/functions_module.php
LINE: 573
CALL: trigger_error()

FILE: [ROOT]/adm/index.php
LINE: 82
CALL: p_master->load_active()

Re: Incompatible Extensions for 3.2

Posted: Thu Jan 19, 2017 7:58 am
by janus_zonstraal
Can you disable the extension?

Or disable/remove the modules from that extension.

Re: Incompatible Extensions for 3.2

Posted: Thu Jan 19, 2017 9:14 am
by Mick
pappy1961 wrote:
Thu Jan 19, 2017 12:00 am
Any idea how I can fix this?
Extensions are supported by their authors so you need to post in the discussion/support area for the extension.

Re: Incompatible Extensions for 3.2

Posted: Fri Jan 20, 2017 1:27 am
by pappy1961
Would love to Mick.. just cant find that particular spot...... :?:

Re: Incompatible Extensions for 3.2

Posted: Fri Jan 20, 2017 2:39 am
by denysr

Re: Incompatible Extensions for 3.2

Posted: Sun Jan 22, 2017 10:50 am
by kaspir
Auto Groups 1.0.1 - seems to be throwing Fatal Error when visiting UCP-> "Edit Notification Options"
phpBB Directory 1.0.0 - seems to be throwing Fatal Error when visiting UCP-> "Edit Notification Options"
Board Rules 1.1.4 - seems to be throwing Fatal Error when visiting UCP-> "Edit Notification Options"

Just the ones I noticed, I did a general search through this topic before posting. And think I noticed that the authors are aware of Board Rules.

Re: Incompatible Extensions for 3.2

Posted: Sun Jan 22, 2017 8:45 pm
by inuyaksa
Fixed @mention system for 3.2 at https://github.com/inuyaksa/mentions

Re: Incompatible Extensions for 3.2

Posted: Tue Jan 24, 2017 9:58 pm
by NorthWoodMediaWorks
Anyone else think a sticky topic like this for Styles in 3.2 might fly? Just sayin'

Cheers :)

Re: Incompatible Extensions for 3.2

Posted: Wed Jan 25, 2017 3:03 am
by «THÖMÅS®©»
Will any of these be updated for 3.2 or will there be similar mods that have the same functions made?