3.1.1.0 to 3.2 Error - SOLVED

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
kenghower
Registered User
Posts: 4
Joined: Tue Jan 10, 2017 10:16 am

3.1.1.0 to 3.2 Error - SOLVED

Post by kenghower » Tue Jan 10, 2017 10:20 am

I've upgraded this board many times...it's been running since 2003. I just did the automatic upgrade. I had a lot of files to delete according to the list....so I did. Once done, the upgrade was smooth and completed and gave me the ACP link.

I got in fine to the ACP, but when I clicked the board index...I received this error

Code: Select all

[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/di/container_builder.php on line 146: require(./cache/production/autoload_4335734bbdd20f586549a504dff5f80c.php): failed to open stream: No such file or directory

Fatal error: require(): Failed opening required './cache/production/autoload_4335734bbdd20f586549a504dff5f80c.php' (include_path='.:/usr/lib/php5.6') in /homepages/4/d92252027/htdocs/board/phpbb/di/container_builder.php on line 146
I checked..cache is 777. I deleted the install folder.
Last edited by kenghower on Sat Jan 14, 2017 5:14 pm, edited 1 time in total.

User avatar
Aros010
Registered User
Posts: 23
Joined: Fri Jul 29, 2016 10:47 pm
Location: Miami, Florida
Name: Aros Row
Contact:

Re: 3.1.1.0 to 3.2 Error

Post by Aros010 » Tue Jan 10, 2017 12:20 pm

Wow I didn't know this version was so hard to update, I got all the errors i'm reading in this forum. :roll:

kenghower
Registered User
Posts: 4
Joined: Tue Jan 10, 2017 10:16 am

Re: 3.1.1.0 to 3.2 Error

Post by kenghower » Tue Jan 10, 2017 11:16 pm

I guess I'll do the full update and hope.

User avatar
Mick
Support Team Member
Support Team Member
Posts: 19366
Joined: Fri Aug 29, 2008 9:49 am
Location: Cardiff
Contact:

Re: 3.1.1.0 to 3.2 Error

Post by Mick » Wed Jan 11, 2017 10:12 am

kenghower wrote:
Tue Jan 10, 2017 11:16 pm
I guess I'll do the full update and hope.
Which is the correct way to go.
"The more connected we get the more alone we become" - Kyle Broflovski

There are no ‘threads’ in phpBB, they are topics.
Forza Garibaldi

User avatar
bsolah
Registered User
Posts: 86
Joined: Sun Feb 19, 2006 12:32 am
Location: Melbourne, Australia
Contact:

Re: 3.1.1.0 to 3.2 Error

Post by bsolah » Wed Jan 11, 2017 10:37 am

I've done the full update and it won't work, I can't update the database coz it times out and no one can tell me how to remove the timeout function
Image

User avatar
JimA
Community Team Leader
Community Team Leader
Posts: 7246
Joined: Thu Jul 31, 2008 5:54 am
Location: The Netherlands
Name: Jim Mossing Holsteyn
Contact:

Re: 3.1.1.0 to 3.2 Error

Post by JimA » Wed Jan 11, 2017 1:00 pm

bsolah wrote:
Wed Jan 11, 2017 10:37 am
I've done the full update and it won't work, I can't update the database coz it times out and no one can tell me how to remove the timeout function
Please don't hijack another user's topic with your own support questions.
If you feel that your topic might have accidentally gone unnoticed, feel free to bump it after six hours.
Image Jim Mossing Holsteyn - Community Team Leader
Knowledge Base | Documentation | Board rules

If you're having any questions about the rules/customs of this website, feel free to drop me a PM.

User avatar
bsolah
Registered User
Posts: 86
Joined: Sun Feb 19, 2006 12:32 am
Location: Melbourne, Australia
Contact:

Re: 3.1.1.0 to 3.2 Error

Post by bsolah » Wed Jan 11, 2017 2:14 pm

JimA wrote:
Wed Jan 11, 2017 1:00 pm
bsolah wrote:
Wed Jan 11, 2017 10:37 am
I've done the full update and it won't work, I can't update the database coz it times out and no one can tell me how to remove the timeout function
Please don't hijack another user's topic with your own support questions.
If you feel that your topic might have accidentally gone unnoticed, feel free to bump it after six hours.
Sorry was merely responding the people's suggestions to do the full update don't necessarily work, that's what I was told and it didn't fix it. It might not fix the OP's problem.
Image

User avatar
JimA
Community Team Leader
Community Team Leader
Posts: 7246
Joined: Thu Jul 31, 2008 5:54 am
Location: The Netherlands
Name: Jim Mossing Holsteyn
Contact:

Re: 3.1.1.0 to 3.2 Error

Post by JimA » Wed Jan 11, 2017 2:32 pm

kenghower wrote:
Tue Jan 10, 2017 10:20 am
I've upgraded this board many times...it's been running since 2003. I just did the automatic upgrade. I had a lot of files to delete according to the list....so I did. Once done, the upgrade was smooth and completed and gave me the ACP link.

I got in fine to the ACP, but when I clicked the board index...I received this error

Code: Select all

[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/di/container_builder.php on line 146: require(./cache/production/autoload_4335734bbdd20f586549a504dff5f80c.php): failed to open stream: No such file or directory

Fatal error: require(): Failed opening required './cache/production/autoload_4335734bbdd20f586549a504dff5f80c.php' (include_path='.:/usr/lib/php5.6') in /homepages/4/d92252027/htdocs/board/phpbb/di/container_builder.php on line 146
I checked..cache is 777. I deleted the install folder.
This error suggests a caching problem. Could you check if your cache folder is writable?
It should have 777 CHMOD permissions, for more info: phpBB3 Chmod Permissions

In addition, try deleting the entire contents of the cache/production folder.
Image Jim Mossing Holsteyn - Community Team Leader
Knowledge Base | Documentation | Board rules

If you're having any questions about the rules/customs of this website, feel free to drop me a PM.

User avatar
Lumpy Burgertushie
Registered User
Posts: 64478
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: 3.1.1.0 to 3.2 Error

Post by Lumpy Burgertushie » Wed Jan 11, 2017 5:07 pm

and, check your config.php file and if you are using mysql change it to mysqli to see if that solves the time out problem.


robert
I am available for custom work on a donation basis. Please send me a PM with your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

kenghower
Registered User
Posts: 4
Joined: Tue Jan 10, 2017 10:16 am

Re: 3.1.1.0 to 3.2 Error

Post by kenghower » Sat Jan 14, 2017 5:12 pm

Fixed:

So if you receive this error. I copied my config file and deleted every file from server except for those listed on the Full Update instructions.

Once I copied over all the new files from the full package except those listed in the instructions, and it was immediately working again. I didn't need to run the install, because the DB was updated from the automatic update.

kenghower
Registered User
Posts: 4
Joined: Tue Jan 10, 2017 10:16 am

Re: 3.1.1.0 to 3.2 Error

Post by kenghower » Sat Jan 14, 2017 5:14 pm

JimA wrote:
Wed Jan 11, 2017 2:32 pm
This error suggests a caching problem. Could you check if your cache folder is writable?
It should have 777 CHMOD permissions, for more info: phpBB3 Chmod Permissions

In addition, try deleting the entire contents of the cache/production folder.

Thanks Jim. This probably was the issue, which of course went away when I deleted every folder (except those listed on the full install instructions.

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: Froddelaar, phpbbX and 22 guests