Parse Error on updating from previous version

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
swithland
Registered User
Posts: 7
Joined: Wed Jan 11, 2017 4:19 am

Parse Error on updating from previous version

Post by swithland »

Support Request Template
What version of phpBB are you using? phpBB 3.2.0
What is your board's URL? www.theccchk.com/forum
Who do you host your board with? hoster901.com
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Update from a previous version of phpBB3
Is registration required to reproduce this issue? No
Do you have any MODs installed? No
Do you have any extensions installed? No
What version of phpBB3 did you update from? phpBB 3.0-B1
What styles do you currently have installed? No answer given
What language(s) is your board currently using? No answer given
Which database type/version are you using? I Don't Know
What is your level of experience? Please select your answer
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? I updated from a previous version using the update package and uploaded the entire contents of the Install and the Vendor folders.
Please describe your problem. After uploading these folders, and following the link in the update instructions I got the following :


Parse error: syntax error, unexpected '[' in /home/theccchk/www/www/forum/vendor/react/promise/src/functions.php on line 15
Generated by SRT Generator

User avatar
JoshyPHP
Code Contributor
Posts: 1079
Joined: Mon Jul 11, 2011 12:28 am

Re: Parse Error on updating from previous version

Post by JoshyPHP »

Looks like you're still using PHP 5.3. Ask your host to switch to a more recent version.
I wrote the thing that does BBCodes in 3.2.

swithland
Registered User
Posts: 7
Joined: Wed Jan 11, 2017 4:19 am

Re: Parse Error on updating from previous version

Post by swithland »

Many thanks for your help on this. Ive managed to get upgraded to PHP 7 and it all works fine now.

swithland
Registered User
Posts: 7
Joined: Wed Jan 11, 2017 4:19 am

Re: Parse Error on updating from previous version

Post by swithland »

OH NO !!

Because I have upgraded to PHP 7.0 ( to make the updated 3.2 forum woik ) our main website no longer works - it was designed to work on PHP 5.4 as this was the same as required by our former forum before we upgraded to the 3.2 version.

Is there any way I can degrade to the old forum....Ive now deleted all the old files thinking all was fine !!

Thanks
Charles

swithland
Registered User
Posts: 7
Joined: Wed Jan 11, 2017 4:19 am

Re: Parse Error on updating from previous version

Post by swithland »

Sorry my mistake....i meant to say PHP 5.6 was the old version that was not working with the new 3.2 forum....is there a way to make the forum work on PHP 5.6 ?

User avatar
janus_zonstraal
Registered User
Posts: 3950
Joined: Sat Aug 30, 2014 1:30 pm

Re: Parse Error on updating from previous version

Post by janus_zonstraal »

phpbb3.2 is perfectly working on 5.6
Sorry! My English is bat ;) !!!

swithland
Registered User
Posts: 7
Joined: Wed Jan 11, 2017 4:19 am

Re: Parse Error on updating from previous version

Post by swithland »

ive just changed out PHP version back to 5.6 so that our main website works again. Unfortunately the forum no longer works :

www.theccchk.com/forum

So why cant I get it work on PHP 5.6 ?

User avatar
janus_zonstraal
Registered User
Posts: 3950
Joined: Sat Aug 30, 2014 1:30 pm

Re: Parse Error on updating from previous version

Post by janus_zonstraal »

Did you purge the cache folder?
except index.html and .htaccess.
Sorry! My English is bat ;) !!!

swithland
Registered User
Posts: 7
Joined: Wed Jan 11, 2017 4:19 am

Re: Parse Error on updating from previous version

Post by swithland »

I had not empied the Cache folder. Ive now done that leaving just the following :


Folder : Installer
Folder : production
Folder : twig
File : .htaccess
File : index.htm

When I load the main page, im still getting the following coming up :

Parse error: syntax error, unexpected '[' in /home/theccchk/www/www/forum/vendor/react/promise/src/functions.php on line 15

Do you know where this is still going wrong ? It worked fine when I was on PHP 7.0, but when I went back to PHP 5.4 so that my main website works, the forum does not !

User avatar
Lumpy Burgertushie
Registered User
Posts: 67063
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Parse Error on updating from previous version

Post by Lumpy Burgertushie »

no, delete everything from the cache folder except for the htaccess and the index files.


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

swithland
Registered User
Posts: 7
Joined: Wed Jan 11, 2017 4:19 am

Re: Parse Error on updating from previous version

Post by swithland »

It all appears to be working now on the PHP 5.6. Many thanks for your kind assistance :-)

abcEzy
Registered User
Posts: 232
Joined: Mon May 09, 2005 6:48 pm

Re: Parse Error on updating from previous version

Post by abcEzy »

I tried all above, and it worked on 3.2.0, but when i tried to update to 3.2.1 after updating the pHP version, it dont work, same 500 error, updating the php to 7 or 7.1 didnt work either.

any other suggestions, nothing my cache folder as described here to delete either

User avatar
janus_zonstraal
Registered User
Posts: 3950
Joined: Sat Aug 30, 2014 1:30 pm

Re: Parse Error on updating from previous version

Post by janus_zonstraal »

nothing my cache folder as described here to delete either
That is "almost" impossible, did you refresh the window?
Sorry! My English is bat ;) !!!

Post Reply

Return to “[3.2.x] Support Forum”