3.1.9 to 3.2: "The installer detected a timeout" error

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
danny94
Registered User
Posts: 7
Joined: Tue May 10, 2016 2:14 pm

Re: 3.1.9 to 3.2: "The installer detected a timeout" error

Post by danny94 » Mon Jan 16, 2017 1:58 pm

Paul wrote:
Mon Jan 16, 2017 12:07 pm
It is in store/ :)
Ups, my fault. Misunderstood. Now it worked i choose direct file or something like that ;D.

Thanks.

richey
Registered User
Posts: 612
Joined: Mon Feb 18, 2002 4:26 pm
Location: now@Cyberspace
Contact:

Re: 3.1.9 to 3.2: "The installer detected a timeout" error

Post by richey » Thu Feb 23, 2017 4:48 pm

Can anyone help me please ... I have the same problem (also updating from 3.1.9 to 3.2.0, PHP 5.6.30).
I have already uploaded the corrected ftp_file_uploader.php file, but it still gives me the timeout error.
I don't think the timeout value (which one actually is it) of php.ini is the reason, as all timeout values in my php.ini are set to 60 (seconds) and the script doesn't even run for 1 minute.

The file updates seem to have worked fine so far, this is happening during database update.
Luckily, I have a dump backup I can restore... :roll: :shock:

thanks!
r
.

KB_Thailand
Registered User
Posts: 55
Joined: Mon Feb 03, 2014 2:02 am
Location: Thailand
Name: Ken
Contact:

Re: 3.1.9 to 3.2: "The installer detected a timeout" error

Post by KB_Thailand » Mon Apr 03, 2017 9:13 am

I am having the same error, and the posts in this thread do not make much sense to someone who does not live and breath phpBB upgrades! I waited two months after the release so that these type of issues would be worked out. Unfortunately, I was overly optimistic.

Upgrading from 3.1.10 and get the timeout error.
Tried upping PHP version to 7.1 - no change.
There is no ftp_file_uploader.php in store/ that I can find so no way to edit.

The instructions in ACP say to unzip the update file and copy vendor/ and install/ to the main board directory. I did that via SFTP, and the files are residing on the server. Why does it even NEED FTP now?

Thankfully just dropping the PHP back to 5.6.30, deleting the install folder, and re-uploading the vendor/ and docs/ directories from the backup brought my site back up.

Would someone please post an update to this thread when this issue is resolved so that I may do the upgrade?

Thanks,
KB
“Reason is poor propaganda when opposed by the yammering, unceasing lies of shrewd and evil and self-serving men."
-- Robert A. Heinlein

User avatar
janus_zonstraal
Registered User
Posts: 3466
Joined: Sat Aug 30, 2014 1:30 pm

Re: 3.1.9 to 3.2: "The installer detected a timeout" error

Post by janus_zonstraal » Mon Apr 03, 2017 9:30 am

The instructions in ACP say to unzip the update file and copy vendor/ and install/ to the main board directory. I did that via SFTP, and the files are residing on the server. Why does it even NEED FTP now?
It is better to use this method
viewtopic.php?f=556&t=2376856#convert3
Sorry! My English is bat ;) !!!

KB_Thailand
Registered User
Posts: 55
Joined: Mon Feb 03, 2014 2:02 am
Location: Thailand
Name: Ken
Contact:

Re: 3.1.9 to 3.2: "The installer detected a timeout" error

Post by KB_Thailand » Mon Apr 03, 2017 11:57 am

janus_zonstraal wrote:
Mon Apr 03, 2017 9:30 am
The instructions in ACP say to unzip the update file and copy vendor/ and install/ to the main board directory. I did that via SFTP, and the files are residing on the server. Why does it even NEED FTP now?
It is better to use this method
viewtopic.php?f=556&t=2376856#convert3
Many thanks! I figured it would come down to a new install after reading up on the changes. :)

Is there anywhere we can go to see a vanilla, out of the box version of 3.2? I have a few custom things on my forum and want to see what I am changing to before pulling the trigger on the update now that I have read up a bit on what the changes are.

Thanks again for the useful link! :)
KB
“Reason is poor propaganda when opposed by the yammering, unceasing lies of shrewd and evil and self-serving men."
-- Robert A. Heinlein

KB_Thailand
Registered User
Posts: 55
Joined: Mon Feb 03, 2014 2:02 am
Location: Thailand
Name: Ken
Contact:

Re: 3.1.9 to 3.2: "The installer detected a timeout" error

Post by KB_Thailand » Mon Apr 03, 2017 11:58 am

janus_zonstraal wrote:
Mon Apr 03, 2017 9:30 am
The instructions in ACP say to unzip the update file and copy vendor/ and install/ to the main board directory. I did that via SFTP, and the files are residing on the server. Why does it even NEED FTP now?
It is better to use this method
viewtopic.php?f=556&t=2376856#convert3
Many thanks! I figured it would come down to a new install after reading up on the changes. :)

Is there anywhere we can go to see a vanilla, out of the box version of 3.2? I have a few custom things on my forum and want to see what I am changing to before pulling the trigger on the update now that I have read up a bit on what the changes are.

Thanks again for the useful link! :)
KB

Not sure why this double posted, but please delete the first one. ;)
“Reason is poor propaganda when opposed by the yammering, unceasing lies of shrewd and evil and self-serving men."
-- Robert A. Heinlein

User avatar
janus_zonstraal
Registered User
Posts: 3466
Joined: Sat Aug 30, 2014 1:30 pm

Re: 3.1.9 to 3.2: "The installer detected a timeout" error

Post by janus_zonstraal » Mon Apr 03, 2017 12:03 pm

Why not making a copy of your board and try the update out on that one?
Sorry! My English is bat ;) !!!

KB_Thailand
Registered User
Posts: 55
Joined: Mon Feb 03, 2014 2:02 am
Location: Thailand
Name: Ken
Contact:

Re: 3.1.9 to 3.2: "The installer detected a timeout" error

Post by KB_Thailand » Mon Apr 03, 2017 12:13 pm

janus_zonstraal wrote:
Mon Apr 03, 2017 12:03 pm
Why not making a copy of your board and try the update out on that one?
Thanks for the suggestion. I may do that if the changes appear to be in depth enough to justify the time and effort. I am pretty sure the custom code will go bye-bye with the upgrade, and from what I have read, probably the mod for autoparsing and embedding video url's also. If so, I may put off doing this upgrade for a while.

KB
“Reason is poor propaganda when opposed by the yammering, unceasing lies of shrewd and evil and self-serving men."
-- Robert A. Heinlein

User avatar
david63
Registered User
Posts: 16414
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: 3.1.9 to 3.2: "The installer detected a timeout" error

Post by david63 » Mon Apr 03, 2017 12:17 pm

KB_Thailand wrote:
Mon Apr 03, 2017 11:58 am
s there anywhere we can go to see a vanilla, out of the box version of 3.2?
This site is pretty much vanilla phpBB 3.2 except for the style - or you could look at area51 as that uses prosilver
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
Lumpy Burgertushie
Registered User
Posts: 66569
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: 3.1.9 to 3.2: "The installer detected a timeout" error

Post by Lumpy Burgertushie » Mon Apr 03, 2017 8:41 pm

the are no MODs in phpbb 3.1 , it uses extensions just like 3.2 does. having said that, depending on what extension you are talking about ( the embedding of videos) it may still work in 3.2, many if not most extensions do.

as far as your custom changes, if you mean changes to the style, yes you will lose them because 3.1 styles do not work in 3.2 very well, if at all. you would have to redo those edits to a similar 3.2 style.


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

KB_Thailand
Registered User
Posts: 55
Joined: Mon Feb 03, 2014 2:02 am
Location: Thailand
Name: Ken
Contact:

Re: 3.1.9 to 3.2: "The installer detected a timeout" error

Post by KB_Thailand » Tue Apr 04, 2017 1:12 am

david63 wrote:
Mon Apr 03, 2017 12:17 pm
This site is pretty much vanilla phpBB 3.2 except for the style - or you could look at area51 as that uses prosilver
Thanks David. I did look at Area 51 and it appears to be fairly close to 3.1.10, so may try copying the site and doing the upgrade to the copy and seeing what I get. :) The code change is minor, just adding a New Posts link on the front/main page instead of under the Quick Links dropdown. viewtopic.php?p=14011276#p14011276

KB
Last edited by KB_Thailand on Tue Apr 04, 2017 1:17 am, edited 1 time in total.
“Reason is poor propaganda when opposed by the yammering, unceasing lies of shrewd and evil and self-serving men."
-- Robert A. Heinlein

KB_Thailand
Registered User
Posts: 55
Joined: Mon Feb 03, 2014 2:02 am
Location: Thailand
Name: Ken
Contact:

Re: 3.1.9 to 3.2: "The installer detected a timeout" error

Post by KB_Thailand » Tue Apr 04, 2017 1:15 am

Lumpy Burgertushie wrote:
Mon Apr 03, 2017 8:41 pm
the are no MODs in phpbb 3.1 , it uses extensions just like 3.2 does. having said that, depending on what extension you are talking about ( the embedding of videos) it may still work in 3.2, many if not most extensions do.

as far as your custom changes, if you mean changes to the style, yes you will lose them because 3.1 styles do not work in 3.2 very well, if at all. you would have to redo those edits to a similar 3.2 style.


robert
Sorry Robert, I used the wrong terminology. The extension is s9e/mediaembed. It is very popular with my (limited) user base, so important to keep for now. The change is posted above to David, and is a minor code change in 3.1, so hopefully will still work in 3.2. :)

Thanks to both you and David for the responses! :)

KB
“Reason is poor propaganda when opposed by the yammering, unceasing lies of shrewd and evil and self-serving men."
-- Robert A. Heinlein

User avatar
david63
Registered User
Posts: 16414
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: 3.1.9 to 3.2: "The installer detected a timeout" error

Post by david63 » Tue Apr 04, 2017 5:21 am

KB_Thailand wrote:
Tue Apr 04, 2017 1:12 am
I did look at Area 51 and it appears to be fairly close to 3.1.10,
Area51 is 3.2 at a minimum (possibly 3.3)
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
Nikola
Registered User
Posts: 284
Joined: Fri Jun 12, 2015 11:47 am
Name: Nikola

Re: 3.1.9 to 3.2: "The installer detected a timeout" error

Post by Nikola » Thu Apr 13, 2017 10:28 am

Okay so, I've had same issue when I was updating. What you can do (it will work 100%) is to be very patient.

1. Backup the files and the database before doing update
2. Please note that some extension won't work in phpBB 3.2 so disable them one by one (david correction)
3. That will disable all extensions you have.
4. Run the installer/updater to phpbb 3.2
5. When you get timeout message don't delete anything from the files such as lock file.
6. Don't reload that TAB before error about timeout appears (this is very crucial)
7. Wait for error to appear then reload the tab. It might take 10 times, it might take 200 times but it will work eventually.
8. Go back to extensions and enable one by one (data from them won't be gone don't worry) Every time you enable the ext clear cache leaving only index and htaccess file. There is a quite number of extensions done for 3.2. Use those.
- Once it's done you will see success message and probably some errors like "undefined offset on a certain line" and auth.php. Regardless, your board should be fully functional after that. Make sure to repair the DB if needed. Keep in mind that you need to keep trying. Don't reload the tab before timeout message appeared.
Last edited by Nikola on Thu Apr 13, 2017 2:52 pm, edited 1 time in total.
"What would happen if the autism gene was eliminated from the genetic pool?

You would have a bunch of people standing around in a cave, chatting and socializing and not getting anything done."

- Dr. Temple Grandin, A Personal Look at Autism and Asperger's Syndrome.

User avatar
david63
Registered User
Posts: 16414
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: 3.1.9 to 3.2: "The installer detected a timeout" error

Post by david63 » Thu Apr 13, 2017 10:39 am

Nikola wrote:
Thu Apr 13, 2017 10:28 am
... so run the following query:

Code: Select all

UPDATE phpbb_ext SET ext_active = 0;
3. That will disable all extensions you have.
That will NOT necessarily disable your extensions it will only remove them from the enabled list of extensions - and doing this will, with some extensions, create problems. The correct way, when updating from 3.1.x to 3.2.x, is to manually disable each extension (I have an extension that will correctly disable all extensions in 3.2)
Nikola wrote:
Thu Apr 13, 2017 10:28 am
Every time you enable the ext clear cache leaving only index and htaccess file
There is no need to manually clear the cache after enabling an extension as part of the enable routine already clears the cache.
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

Post Reply

Return to “[3.2.x] Support Forum”