Page 1 of 4

3.1.9 to 3.2: "The installer detected a timeout" error

Posted: Wed Jan 11, 2017 4:33 am
by maria47
Hi everyone,

I've been using phpBB for years but this is the first time I have a problem that I can't solve by myself.

Everything was working fine with phpBB 3.1.9, PHP 5.5 and MySQL5.5 on my server, but my hosting was charging me around $7/month for PHP5.5 support so I've decided to upgrade to PHP 7.0 and phpBB 3.2.

The server is running PHP 7.0 already. To update to phpBB 3.2, I've tried using the automatic update package 3.1.9 -> 3.2 and doing it manually (keeping the folders images/, files/, store/, ext/, config.php and uploading the new files), but I keep getting this error:

Image

I really don't know what to do. Any idea is welcome!
Thanks! :)

Re: 3.1.9 to 3.2: "The installer detected a timeout" error

Posted: Wed Jan 11, 2017 10:39 am
by bsolah
Getting the same error. No one answers you. The IRC channel is empty. Can someone just tell us how to fix this?! It's been days.

Re: 3.1.9 to 3.2: "The installer detected a timeout" error

Posted: Fri Jan 13, 2017 11:56 am
by danieljacobson22
I'm having the same problem.

Re: 3.1.9 to 3.2: "The installer detected a timeout" error

Posted: Fri Jan 13, 2017 2:18 pm
by bsolah
danieljacobson22 wrote:
Fri Jan 13, 2017 11:56 am
I'm having the same problem.
I got it fixed

You can increase the timeout by creating a php.ini or phprc file. I did it with my host like this: https://help.dreamhost.com/hc/en-us/art ... e-via-FTP-

Re: 3.1.9 to 3.2: "The installer detected a timeout" error

Posted: Sun Jan 15, 2017 9:14 pm
by danieljacobson22
Good to hear you got it working!

I tried that though - I increased the timeout from 100 to 10000 and it still didn't work...

What did you increase the timeout to?

Re: 3.1.9 to 3.2: "The installer detected a timeout" error

Posted: Sun Jan 15, 2017 9:21 pm
by heresolong
I was getting this error also and it turned out to be because I was running PHP5.3 which doesn't support 3.2. While digging around I seem to remember a post that someone had issues with a higher version of PHP also so you might try just switching to php5.6 if that is an option on your server and see what happens.

Re: 3.1.9 to 3.2: "The installer detected a timeout" error

Posted: Mon Jan 16, 2017 1:47 am
by bsolah
I increased it to 10000 like you but I also upgraded my php to php 7, no issues.

Re: 3.1.9 to 3.2: "The installer detected a timeout" error

Posted: Mon Jan 16, 2017 5:54 am
by wkuzma
what is the lowest version of php supported by this new version
reason I ask is my provider only has it updated to version 5.6.29 and will not
go any higher

Re: 3.1.9 to 3.2: "The installer detected a timeout" error

Posted: Mon Jan 16, 2017 7:36 am
by Marc
phpBB 3.2 requires PHP 5.4.0. Using PHP 5.6 is perfectly fine. :)

Re: 3.1.9 to 3.2: "The installer detected a timeout" error

Posted: Mon Jan 16, 2017 7:42 am
by wkuzma
disreguard I installed a complete version and it works fine with 5.6.29

Now for the problem
I tired the update and at the end received the timeout error.
I tried to update a second time but I could not change my ftp settings which I think might have been wrong.
It jumps past that section to enter the ftp info.
How do I get it to the start of the update and be able to change the ftp settings?
When I hit update it skips to download files then if I hit the update at the bottom of the file list
it gives the timeout error again.

Re: 3.1.9 to 3.2: "The installer detected a timeout" error

Posted: Mon Jan 16, 2017 8:02 am
by Marc
There is unfortunately a typo in the ftp file updater which causes this timeout error to appear although there is no actual timeout. See this related pull request that will be included in the next release of phpBB 3.2: https://github.com/phpbb/phpbb/pull/4647/files

For now I'd recommend not using the FTP updater. If you want to start over again you need to remove the install_config.php file in the store folder.

Re: 3.1.9 to 3.2: "The installer detected a timeout" error

Posted: Mon Jan 16, 2017 10:39 am
by danny94
Marc wrote:
Mon Jan 16, 2017 8:02 am
There is unfortunately a typo in the ftp file updater which causes this timeout error to appear although there is no actual timeout. See this related pull request that will be included in the next release of phpBB 3.2: https://github.com/phpbb/phpbb/pull/4647/files

For now I'd recommend not using the FTP updater. If you want to start over again you need to remove the install_config.php file in the store folder.
Thanks @marc
where i can find this folder for the install_config.php file ? Can't find it.

Or where i can find this file with the typo ? So i would correct that by myself.

Re: 3.1.9 to 3.2: "The installer detected a timeout" error

Posted: Mon Jan 16, 2017 12:07 pm
by Paul
It is in store/ :)

Re: 3.1.9 to 3.2: "The installer detected a timeout" error

Posted: Mon Jan 16, 2017 12:09 pm
by Mick
Presumably it's generated when the installer's run?

Re: 3.1.9 to 3.2: "The installer detected a timeout" error

Posted: Mon Jan 16, 2017 12:21 pm
by Paul
Mick wrote:
Mon Jan 16, 2017 12:09 pm
Presumably it's generated when the installer's run?
Yep, the installer generates it, and stores it in store/