Conversion from 3.0.13

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
Oglaf90
Registered User
Posts: 5
Joined: Sun Jan 15, 2017 7:35 pm

Conversion from 3.0.13

Post by Oglaf90 » Sun Jan 15, 2017 7:38 pm

I'm using the CLI method since there's a timeout problem with the PHP updater.

Image

Unfortunately, the CLI is giving me this error -
>Table 'dbname.phpbb_config_text' doesn't exist [1146]
Isn't the database upgrader supposed to create the requisite tables? Am I missing something?

User avatar
Noxwizard
Support Team Leader
Support Team Leader
Posts: 10305
Joined: Mon Jun 27, 2005 8:41 pm
Location: Texas, USA
Name: Patrick Webster
Contact:

Re: Conversion from 3.0.13

Post by Noxwizard » Mon Jan 16, 2017 12:35 am

There is currently a bug in the CLI updater that prevents updates from 3.0 to 3.2 from working correctly. You will need to use the web-based updater or update to 3.1 first.
[Support Template] - [Read Before Posting] - [phpBB Knowledge Base]
Do not contact me for private support, please share the question in our forums.

Oglaf90
Registered User
Posts: 5
Joined: Sun Jan 15, 2017 7:35 pm

Re: Conversion from 3.0.13

Post by Oglaf90 » Mon Jan 16, 2017 1:27 am

Even with PHP's max_execution_time set to 10000, and the web server's config modified accordingly, it times out in a second. Not 10000 seconds, or 30s, but in 1s.

PHP 5.4.45 and nginx 1.6.2, and the PHP version meets the requirements, AFAIK.

Also, I remember the upgraders in the good, old days of 3.0.X reloaded themselves and kept the upgrade process working (or was it the search index rebuild?).

User avatar
Paul
Infrastructure Team Leader
Infrastructure Team Leader
Posts: 24588
Joined: Sat Dec 04, 2004 3:44 pm
Location: The netherlands.
Name: Paul Sohier
Contact:

Re: Conversion from 3.0.13

Post by Paul » Mon Jan 16, 2017 9:11 am

Noxwizard wrote:
Mon Jan 16, 2017 12:35 am
There is currently a bug in the CLI updater that prevents updates from 3.0 to 3.2 from working correctly. You will need to use the web-based updater or update to 3.1 first.
You can use the install/phpbbcli.php instead of the bin/phpbbcli.php. To use the install/phpbbcli.php you need to create a yml file, based on https://github.com/phpbb/phpbb/blob/mas ... sample.yml If you want to just update the DB use type: db_only.

After that you use php phpbbcli.php update config.yml in the install/ directory. This will work from 3.0 to 3.2 directly.
Knock knock
Race condition
Who's there?

My BlogMy Photosmy phpBB Extensionscustom phpBB work & Development

Oglaf90
Registered User
Posts: 5
Joined: Sun Jan 15, 2017 7:35 pm

Re: Conversion from 3.0.13

Post by Oglaf90 » Mon Jan 16, 2017 2:24 pm

Paul wrote:
Mon Jan 16, 2017 9:11 am
You can use the install/phpbbcli.php instead of the bin/phpbbcli.php. To use the install/phpbbcli.php you need to create a yml file, based on https://github.com/phpbb/phpbb/blob/mas ... sample.yml If you want to just update the DB use type: db_only.

After that you use php phpbbcli.php update config.yml in the install/ directory. This will work from 3.0 to 3.2 directly.
Thanks! The update completed without a hitch.

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: canonknipser, Lady_G and 30 guests