Remove extensions before or after upgrading?

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
charliee
Registered User
Posts: 169
Joined: Sun Nov 06, 2011 2:49 am

Remove extensions before or after upgrading?

Post by charliee »

So, should incompatible extensions be removed before upgrading or after upgrading from 3.0.X to 3.2?

(would be nice with an official answer, a dude upgraded a forum with over 15 incompatible extensions and claims its how it should be done but i claim incompatible extensions should be removed before upgrading)

Regards
Charliee
User avatar
david63
Registered User
Posts: 19049
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Contact:

Re: Remove extensions before or after upgrading?

Post by david63 »

charliee wrote:
Mon Jan 23, 2017 5:18 am
should incompatible extensions be removed before upgrading or after upgrading from 3.0.X to 3.2?
Is that a typo? I am assuming that you mean upgrading from 3.1.x to 3.2 as there are no extensions in 3.0.

There is no need as far as the upgrade process is concerned to do anything with any installed extensions as the process will work, however if you know that an extension is incompatible then it would be prudent to disable it and upload a compatible version (if there is one) once the upgrade is complete.
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored
User avatar
HiFiKabin
Community Team Member
Community Team Member
Posts: 5255
Joined: Wed May 14, 2014 9:10 am
Location: Swearing at the PC, UK
Name: James
Contact:

Re: Remove extensions before or after upgrading?

Post by HiFiKabin »

It depends upon the degree of incompatibility.

For example, the 3.1.x auto db backup extension will crash the forum.

All of mine that are incompatible will just look odd

Others may just not work.

It all depends. If you are at all unsure check with the author (or ask on the relevant topic of course) or disable them just in case.
Post Reply

Return to “[3.2.x] Support Forum”