Missing acp_send_statistics when converting from 3.0.0 to 3.2

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
DAB942
Registered User
Posts: 12
Joined: Fri Feb 10, 2017 9:25 pm

Missing acp_send_statistics when converting from 3.0.0 to 3.2

Post by DAB942 » Fri Feb 10, 2017 9:30 pm

Support Request Template
What version of phpBB are you using? phpBB 3.0.5
What is your board's URL? http://lastdynasty.net/board
Who do you host your board with? Bluehost
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Update from a previous version of phpBB3
Is registration required to reproduce this issue? Yes
Do you have any MODs installed? No
Do you have any extensions installed? No
What version of phpBB3 did you update from? phpBB 3.0.5
What styles do you currently have installed? Prosilver
What language(s) is your board currently using? British English
Which database type/version are you using? MySQL 5
What is your level of experience? Comfortable with PHP and phpBB
What username can be used to view this issue? N/A
What password can be used to view this issue? N/A
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? Converting from 3.0.5
Please describe your problem. Receive this when converting:

A required module info file is missing: acp_send_statistics
Update database???

Reverting Schema: \phpbb\db\migration\data\v30x\release_3_0_6_rc1.
Skip ???installer.update_filesystem.download_updated_files??? task
Skip ???installer.update_filesystem.update_files??? task
Skip ???installer.update_filesystem.show_file_status??? task
Skip ???installer.update_filesystem.diff_files??? task
Skip ???installer.update_filesystem.check_task??? task
Skip ???installer.obtain_data.update_ftp_settings??? task
Skip ???installer.obtain_data.update_files??? task
Skip ???installer.obtain_data.file_updater_method??? task
Generated by SRT Generator
Last edited by DAB942 on Sun Feb 12, 2017 7:29 pm, edited 1 time in total.

DAB942
Registered User
Posts: 12
Joined: Fri Feb 10, 2017 9:25 pm

Re: Missing acp_send_statistics when converting from 3.0.0 to 3.2

Post by DAB942 » Sat Feb 11, 2017 7:55 pm

Is there another way to do the conversion -- fresh install -- import data?

User avatar
Mick
Support Team Member
Support Team Member
Posts: 21318
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket - definitely

Re: Missing acp_send_statistics when converting from 3.0.0 to 3.2

Post by Mick » Sun Feb 12, 2017 1:00 pm

Have a read of How do I convert my phpBB 3.0.x or 3.1.x board to phpBB 3.2.x? from the announcement "Frequently asked questions" at the top of this forum.
"The more connected we get the more alone we become" - Kyle Broflovski

DAB942
Registered User
Posts: 12
Joined: Fri Feb 10, 2017 9:25 pm

Re: Missing acp_send_statistics when converting from 3.0.0 to 3.2

Post by DAB942 » Sun Feb 12, 2017 8:03 pm

I read here: https://www.phpbb.com/support/docs/en/3 ... /upgrade3/

Extract the contents of the archive to your computer and open the phpBB3 directory

Delete the following files from the package:

The config.php file
The images/ directory
The files/ directory
The store/ directory

On your website, delete all files from your board EXCEPT for:

The config.php file
The images/ directory
The files/ directory
The store/ directory
Upload the contents of the phpBB3 directory from your computer to your forum's directory. You may be prompted to overwrite the remaining files. If prompted to merge or overwrite directories, choose to merge them.

And: viewtopic.php?f=556&t=2376856#convert3

Delete all of your phpBB 3.0.x/3.1.x files EXCEPT for the following:
config.php
The /ext/ directory
The /images/ directory
The /files/ directory
The /store/ directory
Upload the contents of the 3.2.x Full Package (EXCEPT for config.php) into your forum's directory.
Browse to /install/, click the Update tab, click the Update button, select "Update database only", and click Submit. Wait for the progress bar to reach 100%.
Delete the /install/ directory



They are a little different - but, I tried both ways.

Does it matter if I upload using FTP vs a file manager at the host? I uploaded the whole file and uncompressed on the server.

User avatar
david63
Registered User
Posts: 16323
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: Missing acp_send_statistics when converting from 3.0.0 to 3.2

Post by david63 » Sun Feb 12, 2017 9:32 pm

DAB942 wrote:
Sun Feb 12, 2017 8:03 pm
I uploaded the whole file and uncompressed on the server.
That method is known to sometimes cause problems. It is recommended that you unzip the package on your local machine and then ftp the unzipped files to your server.
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
3Di
Former Team Member
Posts: 13905
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: Missing acp_send_statistics when converting from 3.0.0 to 3.2

Post by 3Di » Mon Feb 13, 2017 2:17 am

DAB942 wrote:
Sat Feb 11, 2017 7:55 pm
Is there another way to do the conversion -- fresh install -- import data?
The same as per this post, only you need to go from 3.0 to 3.0.14 first.
viewtopic.php?f=556&t=2409301&p=14655761#p14655761
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
👨‍🏫 | Take a tour to | The Studio | 👨‍🏫

DAB942
Registered User
Posts: 12
Joined: Fri Feb 10, 2017 9:25 pm

Re: Missing acp_send_statistics when converting from 3.0.0 to 3.2

Post by DAB942 » Wed Feb 22, 2017 1:24 pm

I attempted the first upgrade, which seemed to work up until the end, where it won't load the forums. I've tried this several times. No love.

User avatar
Mick
Support Team Member
Support Team Member
Posts: 21318
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket - definitely

Re: Missing acp_send_statistics when converting from 3.0.0 to 3.2

Post by Mick » Wed Feb 22, 2017 1:32 pm

I notice your board isn't setting cookies properly, see Knowledge Base - Fixing incorrect cookie settings for suggestions how to fix that.
"The more connected we get the more alone we become" - Kyle Broflovski

DAB942
Registered User
Posts: 12
Joined: Fri Feb 10, 2017 9:25 pm

Re: Missing acp_send_statistics when converting from 3.0.0 to 3.2

Post by DAB942 » Wed Feb 22, 2017 11:45 pm

Thanks - I fixed that.


When updating:

Update was successful
Successfully updated all files. The next step involves checking all files again to make sure the files got updated correctly.

When I click Continue Update Now, I get:

lastdynasty.net is currently unable to handle this request.

User avatar
Lumpy Burgertushie
Registered User
Posts: 66479
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: Missing acp_send_statistics when converting from 3.0.0 to 3.2

Post by Lumpy Burgertushie » Thu Feb 23, 2017 2:06 am

I believe that is a 500 internal server error. you can usually find them in the error log found in your hosting control panel. it should tell you what is causing that error.

this:
Update was successful
Successfully updated all files. The next step involves checking all files again to make sure the files got updated correctly.
only shows up when using the autoupdate method and you should not be using that for upgrading from 3.0 to 3.2 since you have to delete all the old 3.0 files and upload all new 3.2 files.

go back and try this:
Upgrading from phpbb 3.0.x to phpbb 3.2.x
  • Your server must be running at least PHP 5.4
  • MODs for 3.0.x are incompatible with 3.2.x and their functionality will be removed in the update process.
  • Styles for 3.0.x cannot be installed or used on 3.2.x.
  1. Backup up your board's files and database
  2. Download the Support Toolkit. Install it and run the database cleaner to remove all old MODs from the database.
  3. Deactivate all styles except for prosilver
  4. Ensure that the activated spambot countermeasure is one of the standard phpBB plugins (Simple image, GD image, GD 3D image, Q&A, reCaptacha).
  5. Set British English as the only language pack
  6. Delete all of your phpBB 3.0.x files EXCEPT for the following:
    • The config.php file
    • The /images/ directory
    • The /files/ directory
  7. Download the 3.2.x Full Package to your computer and unzip it.
  8. Delete the blank config.php file from it. (Note: you don't want to overwrite your original config.php file)
  9. Upload all the remaining files/folders to your server where your old board was.
  10. Browse to yourdomain.com/yourphpbb/install/ then click the update tab. Click update database only. This could take a long time on a large board, maybe hours.
  11. Delete the folder named /install/
  12. Hold one foot in the air and spin around in a circle three times saying "I am a phpbb guru".
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

User avatar
Mick
Support Team Member
Support Team Member
Posts: 21318
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket - definitely

Re: Missing acp_send_statistics when converting from 3.0.0 to 3.2

Post by Mick » Thu Feb 23, 2017 12:06 pm

DAB942 wrote:
Wed Feb 22, 2017 11:45 pm
Thanks - I fixed that
It's still wrong, you need to remove the trailing dot .lastdynasty.net. from the Cookie domain so it's like .lastdynasty.net
"The more connected we get the more alone we become" - Kyle Broflovski

DAB942
Registered User
Posts: 12
Joined: Fri Feb 10, 2017 9:25 pm

Re: Missing acp_send_statistics when converting from 3.0.0 to 3.2

Post by DAB942 » Sat Feb 25, 2017 2:54 am

Thanks -- I forgot to go back again after I copied the old version back when the upgrade failed.

Post Reply

Return to “[3.2.x] Support Forum”