Help! phpbb2 to phpbb3 500 error using MAMP

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
ezlynx
Registered User
Posts: 81
Joined: Tue Sep 10, 2002 8:34 pm

Help! phpbb2 to phpbb3 500 error using MAMP

Post by ezlynx »

I set up MAMP because the conversion failed online. I successfully converted a small forum (both online and in MAMP) but the large forum (about 1gb) fails online and using MAMP. Changing some php settings did not help.

MAMP's default is php7. I have it on a Win7 computer with 4gb ram. The small forum converted successfully on it and appears to be functional. I can post the php.ini if you think it would help.

docs/INSTALL.html#convert
COMMON CONVERSION PROBLEMS:
"http 500 / white pages The conversion is a load-heavy procedure. Restrictions imposed by some server hosting providers can cause problems. The most common causes are: values too low for the PHP settings memory_limit and max_execution_time. Limits on the allowed CPU time are also a frequent cause for such errors, as are limits on the number of database queries allowed. If you cannot change such settings, then contact your hosting provider or run the conversion procedure on a different computer. The phpBB.com forums are also an excellent location to ask for support."

Tried changing these settings for the correct php.ini (a couple I couldn't find):
https://www.phpbb.com/customise/db/conv ... b3/faq/558

set_time_limit= 0
memory_limit = 256M
upload_max_filesize = 128M
post_max_size = 256M
max_input_time = -1
max_execution_time = -1
expect.timeout = -1
default_socket_timeout = -1

So both the memory_limit and max_execution_time were increased.

I have a few extra fields added in the database for some hacks. I am guessing they would just be ignored during the conversion process and did not cause the http 500 error.

Any suggestions for converting this large database appreciated. Other php.ini settings or any other settings, I'd be happy to try. I am stumped.

Edit: looking at the php_error.log, I see several similar failures. Seems to be around here:

Code: Select all

		$lang['INST_ERR_FATAL'] = $user->lang['CONV_ERR_FATAL'];
		$convert->p_master->error('<span style="color:red">' . $user->lang['COLLIDING_USERNAMES_FOUND'] . '</span></b><br /><br />' . $list . '<b>', __LINE__, __FILE__);
	}

This was in the error log:

Code: Select all

[19-Feb-2017 23:17:04 UTC] PHP Fatal error:  Uncaught Error: Call to a member function error() on null in C:\MAMP\htdocs\forums3\install\convertors\functions_phpbb20.php:1906
Stack trace:
#0 C:\MAMP\htdocs\forums3\install\convert\convertor.php(539) : eval()'d code(1): phpbb_check_username_collisions()
#1 C:\MAMP\htdocs\forums3\install\convert\convertor.php(539): eval()
#2 C:\MAMP\htdocs\forums3\install\convert\controller\convertor.php(370): phpbb\convert\convertor->convert_data('phpbb20')
#3 [internal function]: phpbb\convert\controller\convertor->convert('phpbb20')
#4 C:\MAMP\htdocs\forums3\vendor\symfony\http-kernel\HttpKernel.php(144): call_user_func_array(Array, Array)
#5 C:\MAMP\htdocs\forums3\vendor\symfony\http-kernel\HttpKernel.php(64): Symfony\Component\HttpKernel\HttpKernel->handleRaw(Object(phpbb\symfony_request), 1)
#6 C:\MAMP\htdocs\forums3\install\app.php(56): Symfony\Component\HttpKernel\HttpKernel->handle(Object(phpbb\symfony_request))
#7 {main}
  thrown in C:\MAMP\htdocs\forums3\install\convertors\functions_phpbb20.php on line 1906
Perhaps there is a stripped user name that matches another stripped user name? What is removed to create the stripped user? Are only letters and numbers used? No spaces? No dashes? etc.
Post Reply

Return to “[3.2.x] Support Forum”