Having Problem After User Register Sent

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
littleblackhat
Registered User
Posts: 1
Joined: Tue Feb 21, 2017 5:31 am

Having Problem After User Register Sent

Post by littleblackhat » Tue Feb 21, 2017 5:38 am

After the registration data was sent, i can see the user was registered in the acp, but the page keeps hangs on with some white words:

Code: Select all

[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/filesystem/filesystem.php on line 838: is_link(): open_basedir restriction in effect. File(/var) is not within the allowed path(s): ([ROOT]:/var/www/clients/client1/web1/private:/var/www/clients/client1/web1/tmp:/var/www/hkgcity.com/web:/srv/www/hkgcity.com/web:/usr/share/php5:/usr/share/php:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin:/dev/random:/dev/urandom)
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/filesystem/filesystem.php on line 875: is_dir(): open_basedir restriction in effect. File(/var/) is not within the allowed path(s): ([ROOT]:/var/www/clients/client1/web1/private:/var/www/clients/client1/web1/tmp:/var/www/hkgcity.com/web:/srv/www/hkgcity.com/web:/usr/share/php5:/usr/share/php:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin:/dev/random:/dev/urandom)
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/filesystem/filesystem.php on line 880: is_file(): open_basedir restriction in effect. File(/var) is not within the allowed path(s): ([ROOT]:/var/www/clients/client1/web1/private:/var/www/clients/client1/web1/tmp:/var/www/hkgcity.com/web:/srv/www/hkgcity.com/web:/usr/share/php5:/usr/share/php:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin:/dev/random:/dev/urandom)
can anybody tell me where is the problem and how to slove it?
i've see inside the words, seems like the path is php5 but i'm now using php7 with ubuntu
p.s. i'm using my own server, not shared hosting.

User avatar
david63
Registered User
Posts: 16173
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: Having Problem After User Register Sent

Post by david63 » Tue Feb 21, 2017 6:45 am

littleblackhat wrote:
Tue Feb 21, 2017 5:38 am
can anybody tell me where is the problem and how to slove it?
You, or your hosts, need to change the setting of open_basedir in your php.ini file to "none" allow access to the files.
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
zlisiecki
Registered User
Posts: 134
Joined: Fri Jan 25, 2002 1:38 pm
Location: Warsaw
Contact:

Re: Having Problem After User Register Sent

Post by zlisiecki » Sun Oct 22, 2017 10:17 pm

Yes, I have the same error. I am not allowed to change php.ini in this extent. The error appeared after accidently changing to php version 7 and changing back.

Post Reply

Return to “[3.2.x] Support Forum”