ACP very buggy after updating from 3.0.11 to 3.2.0

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
spacedaisy42
Registered User
Posts: 12
Joined: Tue Apr 18, 2017 2:43 am

ACP very buggy after updating from 3.0.11 to 3.2.0

Post by spacedaisy42 » Tue Apr 18, 2017 3:25 am

Support Request Template
What version of phpBB are you using? phpBB 3.2.0
What is your board's URL? www.mafiathesyndicate.com
Who do you host your board with? blue host
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Update from a previous version of phpBB3
Is registration required to reproduce this issue? Yes
Do you have any MODs installed? No
Do you have any extensions installed? No
What version of phpBB3 did you update from? phpBB 3.0.11
What styles do you currently have installed? prosilver
What language(s) is your board currently using? British English
Which database type/version are you using? I Don't Know
What is your level of experience? New to PHP and phpBB
What username can be used to view this issue? No answer given
What password can be used to view this issue? No answer given
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? We updated our boards from 3.0.11 to 3.2.0
Please describe your problem. The ACP seems to be considerably buggy. We were trying to set up a new forum under a new category and then deleted both. Somehow a Category from a completely different section got moved to under this deleted forum and is now missing. It can be seen in the ACP, but not edited. Additionally, I have full administrator privileges and yet there are areas of the board that I am unable to move these missing forums into despite permissions all being set properly as far as I can tell. And if I click on the Systems tab, I only see a blank white page. It happens on other tabs as well, so far I can see only things under the General tab and the Forums tab.
Generated by SRT Generator

spacedaisy42
Registered User
Posts: 12
Joined: Tue Apr 18, 2017 2:43 am

Re: ACP very buggy after updating from 3.0.11 to 3.2.0

Post by spacedaisy42 » Tue Apr 18, 2017 11:15 am

Anyone know anything about this issue?

Here is the error log:

Code: Select all

[17-Apr-2017 18:27:08 America/Denver] PHP Warning:  include(): Failed opening '/home3/mafiathe/public_html/phpBB-3.0.11/phpBB3/vendor/patchwork/utf8/src/Patchwork/Utf8/Bootup.php' for inclusion (include_path='.:/usr/php/54/usr/lib64:/usr/php/54/usr/share/pear') in /home3/mafiathe/public_html/phpBB-3.0.11/phpBB3/vendor/composer/ClassLoader.php on line 412
[17-Apr-2017 18:27:08 America/Denver] PHP Fatal error:  Class 'Patchwork\Utf8\Bootup' not found in /home3/mafiathe/public_html/phpBB-3.0.11/phpBB3/includes/utf/utf_tools.php on line 27
[17-Apr-2017 18:27:20 America/Denver] PHP Warning:  include(): Failed opening '/home3/mafiathe/public_html/phpBB-3.0.11/phpBB3/vendor/patchwork/utf8/src/Patchwork/Utf8/Bootup.php' for inclusion (include_path='.:/usr/php/54/usr/lib64:/usr/php/54/usr/share/pear') in /home3/mafiathe/public_html/phpBB-3.0.11/phpBB3/vendor/composer/ClassLoader.php on line 412
[17-Apr-2017 18:27:20 America/Denver] PHP Fatal error:  Class 'Patchwork\Utf8\Bootup' not found in /home3/mafiathe/public_html/phpBB-3.0.11/phpBB3/includes/utf/utf_tools.php on line 27
[17-Apr-2017 18:27:36 America/Denver] PHP Warning:  include(): Failed opening '/home3/mafiathe/public_html/phpBB-3.0.11/phpBB3/vendor/patchwork/utf8/src/Patchwork/Utf8/Bootup.php' for inclusion (include_path='.:/usr/php/54/usr/lib64:/usr/php/54/usr/share/pear') in /home3/mafiathe/public_html/phpBB-3.0.11/phpBB3/vendor/composer/ClassLoader.php on line 412
[17-Apr-2017 18:27:36 America/Denver] PHP Fatal error:  Class 'Patchwork\Utf8\Bootup' not found in /home3/mafiathe/public_html/phpBB-3.0.11/phpBB3/includes/utf/utf_tools.php on line 27
[17-Apr-2017 18:27:50 America/Denver] PHP Warning:  include(): Failed opening '/home3/mafiathe/public_html/phpBB-3.0.11/phpBB3/vendor/patchwork/utf8/src/Patchwork/Utf8/Bootup.php' for inclusion (include_path='.:/usr/php/54/usr/lib64:/usr/php/54/usr/share/pear') in /home3/mafiathe/public_html/phpBB-3.0.11/phpBB3/vendor/composer/ClassLoader.php on line 412
[17-Apr-2017 18:27:50 America/Denver] PHP Fatal error:  Class 'Patchwork\Utf8\Bootup' not found in /home3/mafiathe/public_html/phpBB-3.0.11/phpBB3/includes/utf/utf_tools.php on line 27
[17-Apr-2017 18:28:53 America/Denver] PHP Warning:  include(): Failed opening '/home3/mafiathe/public_html/phpBB-3.0.11/phpBB3/vendor/patchwork/utf8/src/Patchwork/Utf8/Bootup.php' for inclusion (include_path='.:/usr/php/54/usr/lib64:/usr/php/54/usr/share/pear') in /home3/mafiathe/public_html/phpBB-3.0.11/phpBB3/vendor/composer/ClassLoader.php on line 412
[17-Apr-2017 18:28:53 America/Denver] PHP Fatal error:  Class 'Patchwork\Utf8\Bootup' not found in /home3/mafiathe/public_html/phpBB-3.0.11/phpBB3/includes/utf/utf_tools.php on line 27
[17-Apr-2017 18:29:15 America/Denver] PHP Warning:  include(): Failed opening '/home3/mafiathe/public_html/phpBB-3.0.11/phpBB3/vendor/patchwork/utf8/src/Patchwork/Utf8/Bootup.php' for inclusion (include_path='.:/usr/php/54/usr/lib64:/usr/php/54/usr/share/pear') in /home3/mafiathe/public_html/phpBB-3.0.11/phpBB3/vendor/composer/ClassLoader.php on line 412
[17-Apr-2017 18:29:15 America/Denver] PHP Fatal error:  Class 'Patchwork\Utf8\Bootup' not found in /home3/mafiathe/public_html/phpBB-3.0.11/phpBB3/includes/utf/utf_tools.php on line 27
[17-Apr-2017 18:30:41 America/Denver] PHP Warning:  include(): Failed opening '/home3/mafiathe/public_html/phpBB-3.0.11/phpBB3/vendor/patchwork/utf8/src/Patchwork/Utf8/Bootup.php' for inclusion (include_path='.:/usr/php/54/usr/lib64:/usr/php/54/usr/share/pear') in /home3/mafiathe/public_html/phpBB-3.0.11/phpBB3/vendor/composer/ClassLoader.php on line 412
[17-Apr-2017 18:30:41 America/Denver] PHP Fatal error:  Class 'Patchwork\Utf8\Bootup' not found in /home3/mafiathe/public_html/phpBB-3.0.11/phpBB3/includes/utf/utf_tools.php on line 27
[17-Apr-2017 18:31:28 America/Denver] PHP Fatal error:  Class 'ProxyManager\ProxyGenerator\Assertion\CanProxyAssertion' not found in /home3/mafiathe/public_html/phpBB-3.0.11/phpBB3/vendor/ocramius/proxy-manager/src/ProxyManager/ProxyGenerator/LazyLoadingValueHolderGenerator.php on line 62
[17-Apr-2017 18:31:56 America/Denver] PHP Fatal error:  Class 'ProxyManager\ProxyGenerator\Assertion\CanProxyAssertion' not found in /home3/mafiathe/public_html/phpBB-3.0.11/phpBB3/vendor/ocramius/proxy-manager/src/ProxyManager/ProxyGenerator/LazyLoadingValueHolderGenerator.php on line 62
[17-Apr-2017 18:31:56 America/Denver] PHP Fatal error:  Class 'ProxyManager\ProxyGenerator\Assertion\CanProxyAssertion' not found in /home3/mafiathe/public_html/phpBB-3.0.11/phpBB3/vendor/ocramius/proxy-manager/src/ProxyManager/ProxyGenerator/LazyLoadingValueHolderGenerator.php on line 62
[17-Apr-2017 18:32:06 America/Denver] PHP Fatal error:  Class 'ProxyManager\ProxyGenerator\Assertion\CanProxyAssertion' not found in /home3/mafiathe/public_html/phpBB-3.0.11/phpBB3/vendor/ocramius/proxy-manager/src/ProxyManager/ProxyGenerator/LazyLoadingValueHolderGenerator.php on line 62
[17-Apr-2017 18:32:39 America/Denver] PHP Fatal error:  Class 'ProxyManager\ProxyGenerator\Assertion\CanProxyAssertion' not found in /home3/mafiathe/public_html/phpBB-3.0.11/phpBB3/vendor/ocramius/proxy-manager/src/ProxyManager/ProxyGenerator/LazyLoadingValueHolderGenerator.php on line 62
[17-Apr-2017 18:32:43 America/Denver] PHP Fatal error:  Class 'ProxyManager\ProxyGenerator\Assertion\CanProxyAssertion' not found in /home3/mafiathe/public_html/phpBB-3.0.11/phpBB3/vendor/ocramius/proxy-manager/src/ProxyManager/ProxyGenerator/LazyLoadingValueHolderGenerator.php on line 62
[17-Apr-2017 18:33:32 America/Denver] PHP Fatal error:  Class 'ProxyManager\ProxyGenerator\Assertion\CanProxyAssertion' not found in /home3/mafiathe/public_html/phpBB-3.0.11/phpBB3/vendor/ocramius/proxy-manager/src/ProxyManager/ProxyGenerator/LazyLoadingValueHolderGenerator.php on line 62
[17-Apr-2017 18:33:37 America/Denver] PHP Fatal error:  Class 'ProxyManager\ProxyGenerator\Assertion\CanProxyAssertion' not found in /home3/mafiathe/public_html/phpBB-3.0.11/phpBB3/vendor/ocramius/proxy-manager/src/ProxyManager/ProxyGenerator/LazyLoadingValueHolderGenerator.php on line 62
[17-Apr-2017 18:33:43 America/Denver] PHP Fatal error:  Class 'ProxyManager\ProxyGenerator\Assertion\CanProxyAssertion' not found in /home3/mafiathe/public_html/phpBB-3.0.11/phpBB3/vendor/ocramius/proxy-manager/src/ProxyManager/ProxyGenerator/LazyLoadingValueHolderGenerator.php on line 62
[17-Apr-2017 18:34:08 America/Denver] PHP Fatal error:  Class 'ProxyManager\ProxyGenerator\Assertion\CanProxyAssertion' not found in /home3/mafiathe/public_html/phpBB-3.0.11/phpBB3/vendor/ocramius/proxy-manager/src/ProxyManager/ProxyGenerator/LazyLoadingValueHolderGenerator.php on line 62
[17-Apr-2017 18:34:56 America/Denver] PHP Fatal error:  Class 'ProxyManager\ProxyGenerator\LazyLoadingValueHolder\PropertyGenerator\ValueHolderProperty' not found in /home3/mafiathe/public_html/phpBB-3.0.11/phpBB3/vendor/ocramius/proxy-manager/src/ProxyManager/ProxyGenerator/LazyLoadingValueHolderGenerator.php on line 74
[17-Apr-2017 18:35:35 America/Denver] PHP Fatal error:  Class 'ProxyManager\ProxyGenerator\LazyLoadingValueHolder\PropertyGenerator\ValueHolderProperty' not found in /home3/mafiathe/public_html/phpBB-3.0.11/phpBB3/vendor/ocramius/proxy-manager/src/ProxyManager/ProxyGenerator/LazyLoadingValueHolderGenerator.php on line 74
[17-Apr-2017 18:36:01 America/Denver] PHP Fatal error:  Class 'ProxyManager\ProxyGenerator\LazyLoadingValueHolder\PropertyGenerator\ValueHolderProperty' not found in /home3/mafiathe/public_html/phpBB-3.0.11/phpBB3/vendor/ocramius/proxy-manager/src/ProxyManager/ProxyGenerator/LazyLoadingValueHolderGenerator.php on line 74
[17-Apr-2017 18:36:22 America/Denver] PHP Fatal error:  Class 'ProxyManager\ProxyGenerator\LazyLoadingValueHolder\PropertyGenerator\ValueHolderProperty' not found in /home3/mafiathe/public_html/phpBB-3.0.11/phpBB3/vendor/ocramius/proxy-manager/src/ProxyManager/ProxyGenerator/LazyLoadingValueHolderGenerator.php on line 74
[17-Apr-2017 18:37:48 America/Denver] PHP Warning:  include(): Failed opening '/home3/mafiathe/public_html/phpBB-3.0.11/phpBB3/vendor/twig/twig/lib/Twig/Node/Expression/Binary/Equal.php' for inclusion (include_path='.:/usr/php/54/usr/lib64:/usr/php/54/usr/share/pear') in /home3/mafiathe/public_html/phpBB-3.0.11/phpBB3/vendor/composer/ClassLoader.php on line 412
[17-Apr-2017 18:37:48 America/Denver] PHP Fatal error:  Class 'Twig_Node_Expression_Binary_Equal' not found in /home3/mafiathe/public_html/phpBB-3.0.11/phpBB3/vendor/twig/twig/lib/Twig/ExpressionParser.php on line 52
Last edited by JimA on Tue Apr 18, 2017 11:38 am, edited 1 time in total.
Reason: Code tags added for readibility reasons

User avatar
david63
Registered User
Posts: 16189
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: ACP very buggy after updating from 3.0.11 to 3.2.0

Post by david63 » Tue Apr 18, 2017 11:36 am

It may be that you have some files missing or corrupt - try re-uploading the vendor folder from a fresh download from this site.

P.S. Please edit your above post with code tags around the error log.
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

spacedaisy42
Registered User
Posts: 12
Joined: Tue Apr 18, 2017 2:43 am

Re: ACP very buggy after updating from 3.0.11 to 3.2.0

Post by spacedaisy42 » Tue Apr 18, 2017 12:38 pm

Thanks for editing that for me, I was unaware.

spacedaisy42
Registered User
Posts: 12
Joined: Tue Apr 18, 2017 2:43 am

Re: ACP very buggy after updating from 3.0.11 to 3.2.0

Post by spacedaisy42 » Tue Apr 18, 2017 2:42 pm

Ok, now I have gotten all the tabs back in my ACP. However it still is glitching like no one's business. Any action we take seems to cause it to do some other random action. The ACP is reordering itself seemingly of it's own accord. When I try to choose somewhere to move posts from a deleted forum to (because we can't find any other way around it) the drop down menu does not reflect the way our boards are actually set up. So for instance we have a Forum titled "Mafia" with a bunch of other subforums under it. But now, for whatever reason, when I use the drop down to try and move anything the drop down shows that Forum as a subset of another subset. It is weird and I am terrified to lose any important forums. If I lose the one we have been trying to retrieve so be it, that one is less important. However, we have some forums that it would disaster to lose in some kind of weird glitch. Clearly this is a problem as we can't do anything in the ACP without fear that it will do some other huge action we didn't want.

I really appreciate all the assistance and apologize for being a total novice here.

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 50510
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: ACP very buggy after updating from 3.0.11 to 3.2.0

Post by stevemaury » Tue Apr 18, 2017 3:17 pm

The first thing to do is to backup your database. That will eliminate the possibility of losing anything. After you have done that, if you wish to PM me an admin account (and the url of your board) I will take a look.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 50510
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: ACP very buggy after updating from 3.0.11 to 3.2.0

Post by stevemaury » Tue Apr 18, 2017 4:18 pm

OK, a few things.

1. Why is the board root of phpBB3 inside a folder called phpBB-3.0.11 so that the complete URL is http://www.myboard.com/phpBB-3.0.11/phpBB3/? What do you want the URL of the board to be?

2. Why does one have to append "index.php" to get to the board? Can you post the contents of any .htaccess file you have in either public.html or /mafiasyndicate or /phpBB-3.0.11 or /phpBB3?

3. Indeed, your forum structure is messed up. For example, you have forums as children of forums both with the same name, and you have forums under categories but the category is not the parent. A quick example:
Screen Shot 2017-04-18 at 11.08.10 AM.png
4. I do not get a white screen when accessing the other tabs in the ACP. I can access them all. Try again and see if you now can.

Answer the above questions and I will give you my recommendations.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

spacedaisy42
Registered User
Posts: 12
Joined: Tue Apr 18, 2017 2:43 am

Re: ACP very buggy after updating from 3.0.11 to 3.2.0

Post by spacedaisy42 » Tue Apr 18, 2017 8:24 pm

The white screen issue was resolved by uploading the vendor files again as the original suggestion was given.

1. It's been five years since I originally set up the phpbb board and I can't recall what happened exactly but I had some issue (a mistake on my part I'm sure) that led to this and at the time I couldn't figure out how to fix it, so we found ways to live with it.

I'll get back to you on the other two questions because the third one in particular is something I have to pose to someone else. I didn't set most of this up.

spacedaisy42
Registered User
Posts: 12
Joined: Tue Apr 18, 2017 2:43 am

Re: ACP very buggy after updating from 3.0.11 to 3.2.0

Post by spacedaisy42 » Tue Apr 18, 2017 9:04 pm

Ok, I am unable to locate the .htaccess file. I thought I had made sure it was there, but we had to redo the upload twice and I may not have ensured it was there for the last upload/update process.

Regarding question 3: The person who organized it said he created a forum and then a category underneath it because it displayed better, rather than having it say "Forum" It reads, "Heist Sign Ups" at least this is what I understand. Again we are mostly just novices stumbling through so if it is inefficient or problem causing, that's why. As far as the second part, where you indicated Forums in categories that are not the parent, that occurred with those sign up threads when the Business Front (which contained all the various sign up forums) relocated itself when I was trying to delete a totally unrelated forum and category. So I believe those are a result of that.

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 50510
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: ACP very buggy after updating from 3.0.11 to 3.2.0

Post by stevemaury » Wed Apr 19, 2017 12:14 am

Files beginning with a dot are hidden files, so you must set your FTP client to show hidden files.

What you need to do is sit down with pencil and paper and diagram out exactly what categories and forums you want and then edit the forums to make it so. You can't just randomly make categories under forums.

As for the url situation, again, what do you want it to be?
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

spacedaisy42
Registered User
Posts: 12
Joined: Tue Apr 18, 2017 2:43 am

Re: ACP very buggy after updating from 3.0.11 to 3.2.0

Post by spacedaisy42 » Wed Apr 19, 2017 5:54 am

Ideally www.mafaithesyndicate.com

Here is the .htaccess file

You are right, it was hidden. I was looking again tonight when I got home from work and found it in the public_html, then came in here and saw your response. Apologies.

Code: Select all

RewriteEngine on
# Use PHP54 Single php.ini as default
AddHandler application/x-httpd-php54s .php
RewriteCond %{HTTP_HOST} ^mafiathesyndicate\.com$ [OR]
RewriteCond %{HTTP_HOST} ^www\.mafiathesyndicate\.com$
RewriteRule ^/?$ "http\:\/\/www\.mafiathesyndicate\.com\/phpBB\-3\.0\.11\/phpBB3\/" [R=301,L]


<Files 403.shtml>
order allow,deny
allow from all
</Files>

deny from 91.237.249.0/24
deny from 174.53.128.190
deny from 75.149.157.177
deny from 68.43.13.146
deny from 68.41.118.160
deny from 68.42.249.182
deny from 5.158.236.0/23
deny from 82.193.96.0/19
deny from 110.85.106.220
deny from 176.119.0.0/21
deny from 120.37.208.160
deny from 222.187.222.71
deny from 109.197.143.70
deny from 91.124.60.166
deny from 137.175.10.220
deny from 46.45.170.191
deny from 209.51.142.178
deny from 207.198.107.15
deny from 210.188.201.134
deny from 81.169.149.103
deny from 189.225.162.164
deny from 69.163.179.6
deny from 137.175.13.161
deny from 97.104.67.234
deny from 65.254.168.168
deny from 75.101.153.129
deny from 63.143.48.164
deny from 190.237.45.118
deny from 174.110.139.129
deny from 178.140.52.157
deny from 74.117.61.88
deny from 85.119.183.223
deny from 173.236.172.42
deny from 190.56.253.60
deny from 5.39.219.27
deny from 64.150.231.38
deny from 188.165.243.45
deny from 190.235.170.45
deny from 65.182.188.194
deny from 95.156.192.31
deny from 95.173.186.104
deny from 210.7.9.95
deny from 69.163.203.195
deny from 67.205.36.116
deny from 91.121.152.5
deny from 213.238.175.8
deny from 69.163.169.143
deny from 172.7.136.190
deny from 87.242.64.65
deny from 80.93.58.162
deny from 217.127.89.170
deny from 88.81.236.26
deny from 200.42.253.40
deny from 173.236.153.214
deny from 67.205.48.198
deny from 24.139.92.197
deny from 83.96.132.85
deny from 10.188.201.143
deny from 180.76.5.
deny from 180.76.6.
deny from 180.76.7.
deny from 198.2.208.2
deny from 36.233.196.18
deny from 109.86.20.46
deny from 93.114.46.11
deny from 202.232.236.66
deny from 180.76.0.
deny from 146.0.74.170
deny from 77.225.201.157
deny from 88.100.168.182
deny from 216.49.41.49
deny from 71.224.243.14
deny from 96.224.225.181
deny from 146.0.74.202
deny from 70.164.195.220
deny from 207.86.174.174
deny from 72.226.8.26
deny from 79.199.30.190
deny from 82.117.204.86
deny from 24.35.16.94
deny from 201.229.241.137
deny from 24.1.24.241
deny from 75.73.250.186
deny from 137.175.0.0/17
deny from 142.0.128.0/20
deny from 142.4.96.0/19
deny from 192.74.224.0/19
deny from 198.2.192.0/18
deny from 198.47.96.0/19
deny from 198.200.32.0/19
deny from 199.180.100.0/22
deny from 199.188.104.0/21
deny from 209.21.64.0/19
Then upon looking further, I found another .htaccess file in the phpbb3 folder. Here is that:

Code: Select all

<IfModule mod_rewrite.c>
RewriteEngine on

#
# Uncomment the statement below if URL rewriting doesn't
# work properly. If you installed phpBB in a subdirectory
# of your site, properly set the argument for the statement.
# e.g.: if your domain is test.com and you installed phpBB
# in http://www.test.com/phpBB/index.php you have to set
# the statement RewriteBase /phpBB/
#
#RewriteBase /

#
# Uncomment the statement below if you want to make use of
# HTTP authentication and it does not already work.
# This could be required if you are for example using PHP via Apache CGI.
#
#RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]

#
# The following 3 lines will rewrite URLs passed through the front controller
# to not require app.php in the actual URL. In other words, a controller is
# by default accessed at /app.php/my/controller, but can also be accessed at
# /my/controller
#
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ app.php [QSA,L]

#
# If symbolic links are not already being followed,
# uncomment the line below.
# http://anothersysadmin.wordpress.com/2008/06/10/mod_rewrite-forbidden-403-with-apache-228/
#
#Options +FollowSymLinks
</IfModule>

# With Apache 2.4 the "Order, Deny" syntax has been deprecated and moved from
# module mod_authz_host to a new module called mod_access_compat (which may be
# disabled) and a new "Require" syntax has been introduced to mod_authz_host.
# We could just conditionally provide both versions, but unfortunately Apache
# does not explicitly tell us its version if the module mod_version is not
# available. In this case, we check for the availability of module
# mod_authz_core (which should be on 2.4 or higher only) as a best guess.
<IfModule mod_version.c>
	<IfVersion < 2.4>
		<Files "config.php">
			Order Allow,Deny
			Deny from All
		</Files>
		<Files "common.php">
			Order Allow,Deny
			Deny from All
		</Files>
	</IfVersion>
	<IfVersion >= 2.4>
		<Files "config.php">
			Require all denied
		</Files>
		<Files "common.php">
			Require all denied
		</Files>
	</IfVersion>
</IfModule>
<IfModule !mod_version.c>
	<IfModule !mod_authz_core.c>
		<Files "config.php">
			Order Allow,Deny
			Deny from All
		</Files>
		<Files "common.php">
			Order Allow,Deny
			Deny from All
		</Files>
	</IfModule>
	<IfModule mod_authz_core.c>
		<Files "config.php">
			Require all denied
		</Files>
		<Files "common.php">
			Require all denied
		</Files>
	</IfModule>
</IfModule>
I feel as though I am aggravating you and I really am very sorry for that.

I'll get with my husband tomorrow about ordering the boards correctly, but again, the last time we tried to do anything in there it moved another category completely unrelated to the one we were working with and we can't figure out why. But we've backed up so if we lose stuff, we lose it.

spacedaisy42
Registered User
Posts: 12
Joined: Tue Apr 18, 2017 2:43 am

Re: ACP very buggy after updating from 3.0.11 to 3.2.0

Post by spacedaisy42 » Wed Apr 19, 2017 10:03 pm

So we were trying to reorganize it all by creating a new full structure and then move old topics into the correct place, but even creating a new category, telling it No Parent caused it to create the new category underneath something else. We are not doing this, it's doing it on its own.

Here are a few photos to illustrate our problem.

I click on Manage Forums and I see this. As you can see the second Category is "Mafia"
Image

Then I click on Mafia and this comes up, as though Mafia is somehow filed under The Business Front.
Image

I can't move The Business Front to the proper location, filed under Mafia because in this step it believes that the Mafia category is filed under it.
Image

So we said to ourselves, we'll just build a duplicate structure and move them over forum by forum and in forums that got twisted up somehow we will just move it topic by topic if we have to. We did that and at first it seemed fine. Until we used the little move it up button, then when we used that to move it up, it somehow got entangled in all the rest of the mess. So we figured, well we will just start over again, create it from scratch again and move everything over and then delete what is above it once we have that messed up structure emptied of topics.

Nope, I created a "Mafia 3" (this is my third attempt at fixing this structure) and as soon as it was created, it's already messed up. As soon as it was created, from the Manage Forums page, just like the Mafia Category, it appears as not having any parent, but when I go in to edit it, I can clearly see it is filed underneath the Basement, which shouldn't even be there to begin with.
Image

Everytime we use the ACP to try and fix the problem, it creates more problems.

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 50510
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: ACP very buggy after updating from 3.0.11 to 3.2.0

Post by stevemaury » Wed Apr 19, 2017 11:07 pm

There should be a folder in the public_html folder called 'mafiathesyndicate'. If you put the CONTENTS of the phpBB3 folder in the mafiathesyndiocate folder your url will be mafiathesyndicate.com. Or, it is possible that there is no mafiathesyndicate folder, in which case you would put the CONTENTS of the phpBB3 folder in the public_html folder.

Once you do that, comment out (put a '#' at the beginning or each line) all the lines in the .htaccess file beginning with 'Rewrite' in the first file you show.

I think you may be confusing moving forums up or down in order with whether a forum or category is or is not a parent or child of another.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

spacedaisy42
Registered User
Posts: 12
Joined: Tue Apr 18, 2017 2:43 am

Re: ACP very buggy after updating from 3.0.11 to 3.2.0

Post by spacedaisy42 » Thu Apr 20, 2017 12:54 am

We're going to take your instruction here and see if we can work out the URL issue momentarily.

In regards to the moving up vs parent/child I'll share what I did, perhaps it was the wrong thing.

I was attempting to move a category's position on the index page up, I wasn't trying to change it's status as a Parent Category with no parent of it's own. I used the button here:
Image

Did I misunderstand its function?

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 50510
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: ACP very buggy after updating from 3.0.11 to 3.2.0

Post by stevemaury » Thu Apr 20, 2017 2:06 am

No that is the function of that button, but the order of the forums is not the issue. It is their parent/child status and the fact that you have duplicate forums with the same names nested in each other. You cannot move a child forum to be the child of a non-parent.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

Post Reply

Return to “[3.2.x] Support Forum”