ACP very buggy after updating from 3.0.11 to 3.2.0

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
SokothQultuq
Registered User
Posts: 2
Joined: Thu Apr 20, 2017 2:17 am

Re: ACP very buggy after updating from 3.0.11 to 3.2.0

Post by SokothQultuq » Thu Apr 20, 2017 2:22 am

Okay, we do understand what your saying. We get it.

The problem is we cannot correct it if we wanted too because the ACP is bugging out. When we try to move something we get this:

Code: Select all

General Error
SQL ERROR [ mysqli ]

BIGINT UNSIGNED value is out of range in '(`mafiathe_syndicate`.`phpbb_forums`.`right_id` - 2)' [1690]

SQL

UPDATE phpbb_forums SET left_id = left_id - 2, right_id = right_id - 2, forum_parents = '' WHERE left_id > 17

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 999
CALL: trigger_error()

FILE: [ROOT]/phpbb/db/driver/mysqli.php
LINE: 193
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/phpbb/db/driver/factory.php
LINE: 329
CALL: phpbb\db\driver\mysqli->sql_query()

FILE: [ROOT]/includes/acp/acp_forums.php
LINE: 1455
CALL: phpbb\db\driver\factory->sql_query()

FILE: [ROOT]/includes/acp/acp_forums.php
LINE: 1333
CALL: acp_forums->move_forum()

FILE: [ROOT]/includes/acp/acp_forums.php
LINE: 199
CALL: acp_forums->update_forum_data()

FILE: [ROOT]/includes/functions_module.php
LINE: 676
CALL: acp_forums->main()

FILE: [ROOT]/adm/index.php
LINE: 82
CALL: p_master->load_active()
Anytime we try to move one of the forums. Not only does this happen but random forum boards sometimes get moved in addition. We cannot correct anything until the ACP gets worked out. Do you have any suggestions on how to restore functionality to the ACP?

Or is this the reason why we cannot move them? Is this a lost cause? What are our options?

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 50490
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: ACP very buggy after updating from 3.0.11 to 3.2.0

Post by stevemaury » Thu Apr 20, 2017 2:03 pm

You do not need to "move" forums. You need to decide what categories you want, what forums you want under them, and then do the appropriate parent/child designation. Once that is done, you can re-order them.

Your "moving" of the forums is creating errors because it is attempting to put forums in categories that are not their parent.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

spacedaisy42
Registered User
Posts: 12
Joined: Tue Apr 18, 2017 2:43 am

Re: ACP very buggy after updating from 3.0.11 to 3.2.0

Post by spacedaisy42 » Thu Apr 20, 2017 6:50 pm

Clearly there is a communication error happening here.

I would not even know how to "move" a forum without using the parent child designation in order to do so, so your response here doesn't even make any sense to me.

We did not put any forums into a forum that is not designated it's parent, that is the problem. We did completely unrelated actions and the result is that another forum suddenly appears in a forum where it does not belong.

Here are some examples of what we have seen happen:

The first time went as follows:
We created a new Category (with it's parent set as Community and Welcome Center) and a forum (with it's parent set as the new category)
We decided to eliminate the new Category and just designate the Community and Welcome Center as the new Forum's parent so we deleted both the newly created category and the newly created forum
Result: New Category and Forum deleted but somehow The Business Front Forum (whose parent was designated to be the Mafia Category) somehow appeared underneath the apparently non-existent Category we had deleted. So if I clicked on the title of that Category, the board gives me an error saying it doesn't exist, but yet it still appears there because the Business Front now appears under it. Despite the fact I never touched the Business Front

Another example:
I did not touch the Category Mafia in that whole business above, and yet now the Category Mafia, which has no parent designation according to the settings it shows when you go in to edit, appears to be both a Category with no parent and yet when you click on it, you find it is under The Business Front in the drop down. So the Mafia Category is somehow both a Category with no parent and at the same time it is the child of one of it's own child forums. We did not do this. I don't even know how you think it would be possible for someone to do this of their own accord.

Another example:
I moved another Category's (with no parent) position on the index page up using the blue up button I showed you earlier. I didn't change it's parent/child designation. It displays as having no parent in it's settings just as we set it up to be. And yet somehow it now appears in the drop down as being the child of a Category called The Burglary. We didn't do this.

Another Example:
My husband was changing the parent designations of Forums within the Mafia Category to the newly created Mafia 3 Category (which at the time was set properly and was not somehow magically a child of some other Category) and when he changed the Parent designation of the Museum of Mafioso Forum from Mafia to Mafia 3, all the topics from the Off Topic Category (completely unrelated to the Mafia Category) spread themselves out all over our boards. Some now appear in the drop down menu as children of an old Forum called "Turf Wars Prison Yard" which was part of the Museum of Mafioso Forum. Some are now appearing in the drop down as being children of Game Submissions. And a couple remained where they began. We did not do this.

So you see, you can tell us until you are blue in the face not to put forums into other forums that are not their parents, but it won't make a difference because we did not do it. In fact, I don't even know what you mean by "moving" forums without using the parent/child designation. I am not even aware of a way to do that without using the parent/child designation.

User avatar
Lumpy Burgertushie
Registered User
Posts: 66323
Joined: Mon May 02, 2005 3:11 am
Contact:

Re: ACP very buggy after updating from 3.0.11 to 3.2.0

Post by Lumpy Burgertushie » Thu Apr 20, 2017 7:25 pm

your first example is a clue to why you are having these problems. you can NOT put a category inside another category. in other words, a category does not have a parent. you create a forum of the type category.
you then create a forum of the type forum, give it the parent of that category you created.
rinse and repeat.

you do not create a category and give it a parent of another category. If you truly did that, I don't know why the board let you do that at all.


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 50490
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: ACP very buggy after updating from 3.0.11 to 3.2.0

Post by stevemaury » Thu Apr 20, 2017 7:42 pm

spacedaisy42 wrote: ↑
Thu Apr 20, 2017 6:50 pm
I would not even know how to "move" a forum without using the parent child designation in order to do so, so your response here doesn't even make any sense to me.
viewtopic.php?p=14718401#p14718401
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

SokothQultuq
Registered User
Posts: 2
Joined: Thu Apr 20, 2017 2:17 am

Re: ACP very buggy after updating from 3.0.11 to 3.2.0

Post by SokothQultuq » Fri Apr 21, 2017 1:26 am

So I think I'm starting to understand what your saying. But just so I can get an idea so we know how to do this right. For example:

Community <--- A Category
Adventure Awaits <---- Forum with "Community" as "Parent"
Darkness waits <------ Forum with "Community" as "parent"
And stirs imagination <----- If this is a sub-forum of "Darkness Waits" would it's parent be Community still? or would it's parent then be "Darkness Waits"? But I'm assuming it has to be listed as a "Forum" regardless?

Is this a safe way to do sub-forums under others if you cannot do categories under other Categories? Basically your saying that Categories are the Parents?

I'm likewise learning how to administer PHPBB myself and I'm just starting to understand this. The forums I set up are super simple. I'm trying to help SpaceDaisy with hers. While I'm sure it's frustrating because the uptake is slow, were trying to understand. We do appreciate your patience with us.

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 50490
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: ACP very buggy after updating from 3.0.11 to 3.2.0

Post by stevemaury » Fri Apr 21, 2017 2:25 am

A sub-forum's parent is a forum. There do not necessarily need to be categories. The main difference between categories and forums is that categories only contain forums - no topics. Forums can contain topics and other forums. Otherwise, your outline is correct.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

User avatar
3Di
Former Team Member
Posts: 13769
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: ACP very buggy after updating from 3.0.11 to 3.2.0

Post by 3Di » Fri Apr 21, 2017 2:39 am

It's possible to create categories subforums in the main category/forums/subforums as well, never tried though. Example: https://area51.phpbb.com/phpBB/viewforum.php?f=7
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
👨‍🏫 | Take a tour to | The Studio | 👨‍🏫

Post Reply

Return to “[3.2.x] Support Forum”