Installation Question

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
rick5150
Registered User
Posts: 263
Joined: Wed Feb 02, 2005 6:19 pm

Installation Question

Post by rick5150 » Sat May 06, 2017 11:38 pm

I have had a bear of a time installing phpBB on my new site. In the past, it has been simple, but this time, right from the get-go, Mojo kept creating databases, then giving me an error message, or it would freeze up completely. I installed manually and I can only get to the point where I am almost done the install and I get a red error message that reads "Class phpbb\notification\manager does not exist" and the installation stalls here. I cannot restart it without deleting all of the database files. Any guidance is appreciated. Thanks!

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 50409
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: Installation Question

Post by stevemaury » Sat May 06, 2017 11:57 pm

What is "Mojo"? What are "database files"?

Please fill out the Support Request Template and post it back here to enable us to assist you better.
For REALLY good and VERY inexpensive hosting CLICK HERE

I can stop all your spam. I can upgrade or update your Board. PM or email me. (Paid support)

rick5150
Registered User
Posts: 263
Joined: Wed Feb 02, 2005 6:19 pm

Re: Installation Question

Post by rick5150 » Sun May 07, 2017 10:05 am

Support Request Template
What version of phpBB are you using? phpBB 3.2.0
What is your board's URL? http://nhlawns101.com
Who do you host your board with? Bluehost
How did you install your board? I used the download package from phpBB.com
What is the most recent action performed on your board? Fresh Install
Is registration required to reproduce this issue? No
Do you have any MODs installed? No
Do you have any extensions installed? No
What styles do you currently have installed? ProSilver
What language(s) is your board currently using? English
Which database type/version are you using? MySQL 5
What is your level of experience? Comfortable with PHP and phpBB
What actions did you take (updating your board; installing a MOD, style or extension; etc.) prior to this problem becoming noticeable? Tried to use Bluehost's third party installer called Mojo Marketplace. Install failed several times, but each time it created a database and privileged user. I deleted all of these instances and came to phpBB site and downloaded the 3.0 package. Unpacked all files locally. Transferred all files to remote website server via Filezilla.
Please describe your problem. During the installation, I point my browser to Install and the process begins just fine.
1) I get through the Welcome screen and press the 'Install' button. Fine at this point.
2) I enter the administrator configuration information and press 'submit'. No problem.
3) On the database configuration page, I enter these details and click 'submit'

If I use the shared server IP address as I was instructed to do by Bluehost, I get this message "Host '69.195.***.***' is blocked because of many connection errors; unblock with 'mysqladmin flush-hosts'" and I have no idea what to do.

If I change the database server name to 'localhost' then I get to the server configuration page. This information looks good so I click 'submit' and this brings me to the e-mail page. I click 'submit' and it brings me to the 'bulletin board configuration' page. I enter the title of the site and a brief description and then click 'submit'.

I get 50% through the download to the point where the screen all activity stops. There is a red bar across the top of the screen that states "Class phpbb\notification\manager does not exist". Just under that it says "Registering bots..." Then there is a blue download status indicator that shows 50%. Finally, beneath that it says "Skip ???installer.install_database.set_up_database??? task".

If I look in the database, there are 68 tables created. If I try deleting the install file directory and accessing the site, I get this information:
Fatal error: Uncaught Error: Class 'phpbb\notification\manager' not found in /home3/nhlawnso/public_html/forum/cache/production/container_4335734bbdd20f586549a504dff5f80c.php:2716 Stack trace: #0 /home3/nhlawnso/public_html/forum/vendor/symfony/dependency-injection/Container.php(314): phpbb_cache_container->getNotificationManagerService() #1 /home3/nhlawnso/public_html/forum/vendor/symfony/dependency-injection/ContainerBuilder.php(447): Symfony\Component\DependencyInjection\Container->get('notification_ma...', 2) #2 /home3/nhlawnso/public_html/forum/cache/production/container_4335734bbdd20f586549a504dff5f80c.php(1356): Symfony\Component\DependencyInjection\ContainerBuilder->get('notification_ma...') #3 /home3/nhlawnso/public_html/forum/vendor/symfony/dependency-injection/Container.php(314): phpbb_cache_container->getCron_Task_Core_PruneNotificationsService() #4 /home3/nhlawnso/public_html/forum/vendor/symfony/dependency-injection/ContainerBuilder.php(447): Symfony\Component\DependencyInjection\Container->get('cron.task.co in /home3/nhlawnso/public_html/forum/cache/production/container_4335734bbdd20f586549a504dff5f80c.php on line 2716

I am going to clear the cache folder which now has a folder named 'production', add the install folder back and try reinstalling the vendor folder again because Symfony seems to show up a lot in the error message.
Generated by SRT Generator

rick5150
Registered User
Posts: 263
Joined: Wed Feb 02, 2005 6:19 pm

Re: Installation Question

Post by rick5150 » Mon May 08, 2017 12:47 pm

Forget it. I deleted all the phpbb files and databases and started over. When it came time to enter the Database Name Server, I chose 'localhost' over the IP address that I was told to enter by Bluehost. Finally, the installation went through.

Post Reply

Return to “[3.2.x] Support Forum”