Page 1 of 1

White page (Attachment page) in ACP

Posted: Fri May 12, 2017 3:55 pm
by ALXGS
Hi

When I try to enter in Attachment settings tab in ACP (from General tab), I get white page with this comment:

The website at http://www.facebike.gr/adm/index.php?si ... ode=attach may be temporarily down or may have been permanently moved to a new web address.
ERR_CONTENT_DECODING_FAILED

I do not know how long I have this problem, but I noticed it today.

I run phpbb 3.2 with we_clearblue style and I have many extensions.

What's going on?

Re: White page (Attachment page) in ACP

Posted: Fri May 12, 2017 5:44 pm
by .m.
@ALXGS , basically that could be a problem with the gzip compression
can you temporarily disable it at Server Settings of Board Admin Panel & check

you may also have to purge the board cache (setting available at General Tab)

And if server error log exists at your web host control panel then
its latest entries should be checked for tracing error 500 (blank page)

Re: White page (Attachment page) in ACP

Posted: Fri May 12, 2017 6:47 pm
by ALXGS
GoesOn wrote:
Fri May 12, 2017 5:20 pm
ALXGS wrote:
Fri May 12, 2017 3:55 pm
Hi

When I try to enter in Attachment settings tab in ACP (from General tab), I get white page with this comment:

The website at http://www.facebike.gr/adm/index.php?si ... ode=attach may be temporarily down or may have been permanently moved to a new web address.
ERR_CONTENT_DECODING_FAILED

I do not know how long I have this problem, but I noticed it today.

I run phpbb 3.2 with we_clearblue style and I have many extensions.

What's going on?
Can i ask how to change the color?
What color do you talk about?
.m. wrote:
Fri May 12, 2017 5:44 pm
@ALXGS , basically that could be a problem with the gzip compression
can you temporarily disable it at Server Settings of Board Admin Panel & check

you may also have to purge the board cache (setting available at General Tab)

And if server error log exists at your web host control panel then
its latest entries should be checked for tracing error 500 (blank page)
You are right! When I disable the gzip, it's ok, but I see this
attachment settings.JPG
it tell me usr/bin does not exist.

When enable again the gzip, the problem returns (white page). After that I purge the cashe but nothing happend.

Also I have problem when I try to configure some user via ACP. White page again.

I Disable all extensions one by one, and I try to see the page, but failed again.

Re: White page (Attachment page) in ACP

Posted: Sat May 13, 2017 2:22 am
by .m.
^ please contact your web host and ask to remove open_basedir restriction.

Re: White page (Attachment page) in ACP

Posted: Sat May 13, 2017 10:08 am
by ALXGS
.m. wrote:
Sat May 13, 2017 2:22 am
^ please contact your web host and ask to remove open_basedir restriction.
Thanks man... I'll do it.

Re: White page (Attachment page) in ACP

Posted: Mon May 29, 2017 2:30 pm
by ALXGS
From my web host I get this answer

(google translate)

The whole problem seems to arise from the fact that the attachments attempt to use imagemagick, which can not be fully used in shared hosting, so that it is searched for its execution on the wrong path. Because in path (/ usr / bin) you can not access it, I've changed the path in the corresponding field for the corresponding option in Attachment Settings, just to avoid showing this error and it now seems to work normally.

Yes... it works now, but when I install or uninstall some extension, I get errors in the upper side of screen, like previews errors. After refresh the page, the error not dislayed again :?
(Unfortunately I did not take printscreen of error)

Re: White page (Attachment page) in ACP

Posted: Thu Jun 01, 2017 7:06 pm
by ALXGS
Just I install an updated extension (board announcements) and the error after

Code: Select all

[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Environment.php(403) : eval()'d code on line 25: file_exists(): open_basedir restriction in effect. File(./../theme/portal.css) is not within the allowed path(s): ([ROOT]/:/tmp/)
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Environment.php(403) : eval()'d code on line 61: file_exists(): open_basedir restriction in effect. File(./../theme/portal_responsive.css) is not within the allowed path(s): ([ROOT]/:/tmp/)
What it means this?

Re: White page (Attachment page) in ACP

Posted: Fri Jun 02, 2017 7:57 am
by Mick
As per above "open_basedir" is the problem. You can check if it's active or not (the entry is a number {on} or no value {off} with my hosting package) by looking in ACP> PHP information. Your host needs to sort it out.