Page 1 of 1

Non existent topics need approval, icon doesn't dissapear

Posted: Thu Jun 15, 2017 6:28 am
by Pilxy
Hello,

I have an issue that's been going on for a while now. I have post approval turned on for the new members that join our board. It's been working just fine until a few months ago when two new members posted two topics that appeared normally in the waiting line. Their topics were approved by the moderators, but the icon showing there are new posts waiting to be approved did not dissapear as it did allways before.

I later tried to solve the issue, so I deleted those two topics but the icon remained and the topics still showed in the waiting line. I tried to delete them again but all I got is "you are not authorised to use this feature" response from the board. I was using phpBB 3.0.10 at that time.

Yesterday, I upgraded my board to 3.2.0 and the icon for topics need approval remained, but those two topics are not shown in the waiting line anymore.

Now I'm wondering if there is anthing I can do to "reset" the waiting line so the icon will dissapear? It's not an urgent issue, but it is still annoying...

I would appreciate any help.

Thanks! :)

--
p.s.: I'm using the board in a different language, so the english phrases used above may not be written entirely accurate.

Re: Non existent topics need approval, icon doesn't dissapear

Posted: Thu Jun 15, 2017 4:24 pm
by janus_zonstraal
Go to your phpMyAdmin
Open the database of your board

Go to the table

Code: Select all

phpbb_forums
Search for the column

Code: Select all

forum_topics_unapproved
(You can sort the row so that the non zero's are on top)
Set everything on 0 in that row by editing the value

Make a backup before you start ;)

Re: Non existent topics need approval, icon doesn't dissapear

Posted: Thu Jun 15, 2017 7:24 pm
by Pilxy
It worked. Thanks a lot! :D

Re: Non existent topics need approval, icon doesn't dissapear

Posted: Thu Jun 15, 2017 7:50 pm
by janus_zonstraal
De nada