404 not found

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
DWFII
Registered User
Posts: 324
Joined: Fri Oct 20, 2006 2:17 am
Name: D.W.
Contact:

404 not found

Post by DWFII » Mon Jun 19, 2017 5:51 pm

Not sure where the problem lies so I am cross-posting this.

I have Simple Mentions installed on a 3.2 board.

It seems to work properly. But...when a user gets an email notification that he has been mentioned, the link in the email results in a 404-not found error. Copying the link from the original post where the user is mentioned results in a valid link to the page But the link in the email is incorrect.

Here is what is happening.

This is the link that is in the email:
http://www.thehcc.org/forumviewtopic.php?p=41760#p41760 ...
which results in a 404

This is the valid link:
http://www.thehcc.org/forum/viewtopic.php?p=41760#p41760
as you can see everything is the same except the "/" is missing from the link that Simple Mentions sent to email.

How do I fix this?
DWFII
In the High Desert of Central Oregon

User avatar
KevC
Support Team Member
Support Team Member
Posts: 67108
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: 404 not found

Post by KevC » Mon Jun 19, 2017 5:55 pm

Support for extensions is provided by the author in the place where you downloaded it.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

User avatar
Mick
Support Team Member
Support Team Member
Posts: 17842
Joined: Fri Aug 29, 2008 9:49 am
Location: Cardiff

Re: 404 not found

Post by Mick » Mon Jun 19, 2017 5:57 pm

^^Kev
"The more connected we get the more alone we become" - Kyle Broflovski

There are no ‘threads’ in phpBB, they are topics.
Forza Garibaldi

DWFII
Registered User
Posts: 324
Joined: Fri Oct 20, 2006 2:17 am
Name: D.W.
Contact:

Re: 404 not found

Post by DWFII » Mon Jun 19, 2017 6:03 pm

KevC wrote:
Mon Jun 19, 2017 5:55 pm
Support for extensions is provided by the author in the place where you downloaded it.
That's why I said I was "cross posting" this .

Is it an extension issue or is it a problem with the way the board is sending links in email?
DWFII
In the High Desert of Central Oregon

User avatar
Mick
Support Team Member
Support Team Member
Posts: 17842
Joined: Fri Aug 29, 2008 9:49 am
Location: Cardiff

Re: 404 not found

Post by Mick » Mon Jun 19, 2017 6:06 pm

Basically, vanilla phpBB should work correctly, if it doesn't you can post in the bug tracker. Try disabling the extension and see what happens.
"The more connected we get the more alone we become" - Kyle Broflovski

There are no ‘threads’ in phpBB, they are topics.
Forza Garibaldi

DWFII
Registered User
Posts: 324
Joined: Fri Oct 20, 2006 2:17 am
Name: D.W.
Contact:

Re: 404 not found

Post by DWFII » Mon Jun 19, 2017 6:20 pm

Mick wrote:
Mon Jun 19, 2017 6:06 pm
Basically, vanilla phpBB should work correctly, if it doesn't you can post in the bug tracker. Try disabling the extension and see what happens.
How would that work? Mentions creates the only internal text that shows up in any email notification. (that may not be quite clear but the email notification is referencing something within the post)

If I or any of my users gets an email notification that a post has been made to a topic they have subscribed to, the link back to the board seems to work fine.

With Mentions, the email notification includes a line that says: "To view the post you were mentioned in use this link:" and then the link, of course.

It's actually a unique email notification as it does not contain any of the usual links to post, topic or forum.
Last edited by DWFII on Mon Jun 19, 2017 6:23 pm, edited 1 time in total.
DWFII
In the High Desert of Central Oregon

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 47786
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: 404 not found

Post by stevemaury » Mon Jun 19, 2017 6:22 pm

The point is, we don't know. The extension author should.
For REALLY good and VERY inexpensive hosting CLICK HERE

All unsolicited PMs will be ignored.

DWFII
Registered User
Posts: 324
Joined: Fri Oct 20, 2006 2:17 am
Name: D.W.
Contact:

Re: 404 not found

Post by DWFII » Mon Jun 19, 2017 6:27 pm

Well, thanks anyway.. I hope he gets back to me and answers my question in the extension discussion. Sometimes that is not always a given.

Thank you anyway--Kev Mick and Steve.
DWFII
In the High Desert of Central Oregon

User avatar
Mick
Support Team Member
Support Team Member
Posts: 17842
Joined: Fri Aug 29, 2008 9:49 am
Location: Cardiff

Re: 404 not found

Post by Mick » Mon Jun 19, 2017 6:28 pm

You can still disable the extension and do a bit of sleuthing on your own?
"The more connected we get the more alone we become" - Kyle Broflovski

There are no ‘threads’ in phpBB, they are topics.
Forza Garibaldi

DWFII
Registered User
Posts: 324
Joined: Fri Oct 20, 2006 2:17 am
Name: D.W.
Contact:

Re: 404 not found

Post by DWFII » Mon Jun 19, 2017 7:13 pm

I'm a newbie. Or that's not entirely correct, I've been using phpBB for years...but I am clueless.

I can disable the extension. But from there?...no idea.

If the author of the extension doesn't answer, disabling or even deleting it might be my only option. Too bad if it comes to that. I like the concept...same as I liked Prime Notify--nevermind.
DWFII
In the High Desert of Central Oregon

User avatar
Mick
Support Team Member
Support Team Member
Posts: 17842
Joined: Fri Aug 29, 2008 9:49 am
Location: Cardiff

Re: 404 not found

Post by Mick » Tue Jun 20, 2017 7:53 am

Installing Extensions should help you. Disabling an extension is a one minute job, if that doesn't fix your problem you can re-enable it or leave it disabled until the issue is sorted out.
"The more connected we get the more alone we become" - Kyle Broflovski

There are no ‘threads’ in phpBB, they are topics.
Forza Garibaldi

DWFII
Registered User
Posts: 324
Joined: Fri Oct 20, 2006 2:17 am
Name: D.W.
Contact:

Re: 404 not found

Post by DWFII » Tue Jun 20, 2017 4:49 pm

Mick wrote:
Tue Jun 20, 2017 7:53 am
Installing Extensions should help you. Disabling an extension is a one minute job, if that doesn't fix your problem you can re-enable it or leave it disabled until the issue is sorted out.
Well, after talking to the author...who said this problem wouldn't be fixed til the "next version", and "not anytime soon"...I took your advice and disabled Simple mentions.

Funny thing happened, however--I disabled it fine. But then when I tried to get back into my forum, all I got was a white screen.

Eventually, on the advice of a third party I manually cleared the cache on the server. That worked (for anyone with similar problems) and I believe my next step is to delete the extension altogether.

But it is a lesson...to me, at any rate...not to take author-descriptions at face value. And I should have been wary anyway, as the extension was apparently released on the 14th of May and 5 days later this problem was reported to the author for the first time. But the fix "won't be anytime soon."

Honestly...I cannot imagine how this extension can be said to be 3.2 compatible. But I'm not an expert, so what do I know? Having been released so recently, I guess that's all it can be compatible with.

Thanks again for your help...everyone.
DWFII
In the High Desert of Central Oregon

User avatar
Mick
Support Team Member
Support Team Member
Posts: 17842
Joined: Fri Aug 29, 2008 9:49 am
Location: Cardiff

Re: 404 not found

Post by Mick » Tue Jun 20, 2017 5:47 pm

DWFII wrote:
Tue Jun 20, 2017 4:49 pm
I cannot imagine how this extension can be said to be 3.2 compatible
If it's the one I just searched there's a notice "This extension is still in development. Do not use on a live board."
"The more connected we get the more alone we become" - Kyle Broflovski

There are no ‘threads’ in phpBB, they are topics.
Forza Garibaldi

DWFII
Registered User
Posts: 324
Joined: Fri Oct 20, 2006 2:17 am
Name: D.W.
Contact:

Re: 404 not found

Post by DWFII » Tue Jun 20, 2017 6:07 pm

Here's the link https://www.phpbb.com/customise/db/exte ... _mentions/ I don't see any such caveat.

And in the Extensions database it is on the first page second from the bottom right-hand side. Again no such warning.

Correct me if I'm wrong...
DWFII
In the High Desert of Central Oregon

User avatar
Mick
Support Team Member
Support Team Member
Posts: 17842
Joined: Fri Aug 29, 2008 9:49 am
Location: Cardiff

Re: 404 not found

Post by Mick » Tue Jun 20, 2017 6:09 pm

Thank you, I was looking at something else, it looks like the issue is in hand.
"The more connected we get the more alone we become" - Kyle Broflovski

There are no ‘threads’ in phpBB, they are topics.
Forza Garibaldi

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: cangor, Crizzo, elonturing, hoarybat, nhseacoast, Paul, sceptre, Yandex [Bot] and 66 guests

cron