app.php returns a 500 server error

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
User avatar
John connor
Registered User
Posts: 2119
Joined: Fri Nov 14, 2014 5:14 pm
Location: U S Of A
Name: Aaron
Contact:

app.php returns a 500 server error

Post by John connor » Tue Jun 27, 2017 10:23 pm

As it pertains to my request here: https://www.phpbb.com/customise/db/exte ... pic/179156

I have contacted my host and he tells me it's more than likely a problem with the script. This extension worked a few days ago, so I don't know why app.php is giving me trouble now. The app.php files are there in my directory. I have temporally deleted htaccess and flushed the cache and still have this not found issue.

Any ideas?

User avatar
John connor
Registered User
Posts: 2119
Joined: Fri Nov 14, 2014 5:14 pm
Location: U S Of A
Name: Aaron
Contact:

Re: app.php returns a 500 server error

Post by John connor » Sat Jul 01, 2017 8:15 am

I just tried to temp replace my current htaccess file with the one included with the current phpBB installer and still going to app.php says "Not Found."

I see this in the htaccess file.
# The following 3 lines will rewrite URLs passed through the front controller
# to not require app.php in the actual URL. In other words, a controller is
# by default accessed at /app.php/my/controller, but can also be accessed at
# /my/controller
#
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ app.php [QSA,L]
Do I have to change something perhaps?

User avatar
Mick
Support Team Member
Support Team Member
Posts: 21156
Joined: Fri Aug 29, 2008 9:49 am
Location: Watching cricket - definitely

Re: app.php returns a 500 server error

Post by Mick » Sat Jul 01, 2017 12:34 pm

If it's the same without an .htaccess file then it isn't that causing the issue.
"The more connected we get the more alone we become" - Kyle Broflovski

User avatar
david63
Registered User
Posts: 16196
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: app.php returns a 500 server error

Post by david63 » Sat Jul 01, 2017 12:49 pm

John connor wrote:
Tue Jun 27, 2017 10:23 pm
Any ideas?
Cloudflare?
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
John connor
Registered User
Posts: 2119
Joined: Fri Nov 14, 2014 5:14 pm
Location: U S Of A
Name: Aaron
Contact:

Re: app.php returns a 500 server error

Post by John connor » Sun Jul 02, 2017 2:16 am

david63 wrote:
Sat Jul 01, 2017 12:49 pm
John connor wrote:
Tue Jun 27, 2017 10:23 pm
Any ideas?
Cloudflare?
I removed the DNS temporally from CloudFlare for testing and no change. I even deleted the cache in CloudFlare and my board.

abcEzy
Registered User
Posts: 232
Joined: Mon May 09, 2005 6:48 pm

Re: app.php returns a 500 server error

Post by abcEzy » Wed Jul 12, 2017 3:24 am

Has anyone found the problem with this, and come up with a solution?

I was using 3.1.7-pl.. i downloaded the auto update, then the page returned a 500 error.
So i referred back to the install doc, i notice it says that i can still delete all the files except a few folders and the config.php file and upload the rest for the 3.2 installation. and just click the update button.

but i cant even get to that update page due to the 500 error.

any ideas, whats causing this? yes, my files are being uploaded in ACSII mode, by default.

Thanks kindly.

User avatar
janus_zonstraal
Registered User
Posts: 3269
Joined: Sat Aug 30, 2014 1:30 pm

Re: app.php returns a 500 server error

Post by janus_zonstraal » Wed Jul 12, 2017 7:00 am

For upgrading to 3.2 you have to use this method:
viewtopic.php?f=556&t=2376856#convert3
Sorry! My English is bat ;) !!!

abcEzy
Registered User
Posts: 232
Joined: Mon May 09, 2005 6:48 pm

Re: app.php returns a 500 server error

Post by abcEzy » Mon Jul 17, 2017 4:42 am

I did. still have error
janus_zonstraal wrote:
Wed Jul 12, 2017 7:00 am
For upgrading to 3.2 you have to use this method:
viewtopic.php?f=556&t=2376856#convert3

User avatar
janus_zonstraal
Registered User
Posts: 3269
Joined: Sat Aug 30, 2014 1:30 pm

Re: app.php returns a 500 server error

Post by janus_zonstraal » Mon Jul 17, 2017 6:03 am

abcEzy wrote:
Mon Jul 17, 2017 4:42 am
I did. still have error
janus_zonstraal wrote:
Wed Jul 12, 2017 7:00 am
For upgrading to 3.2 you have to use this method:
viewtopic.php?f=556&t=2376856#convert3
Please give us more info by filling in the SRT
viewtopic.php?f=556&t=2376856#srt
Sorry! My English is bat ;) !!!

infinitiv
Registered User
Posts: 166
Joined: Sat Nov 15, 2014 3:47 pm
Location: PL
Name: Ficjusz

Re: app.php returns a 500 server error

Post by infinitiv » Mon Jul 17, 2017 8:17 am

I sometimes had 500 error when I messed up something with the extensions – like syntax and such. I think that’s some implementation of phpBB security algorithms.

Post Reply

Return to “[3.2.x] Support Forum”