Several errors with update

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
User avatar
canonknipser
Registered User
Posts: 1140
Joined: Thu Sep 08, 2011 4:16 am
Location: Germany
Name: Frank Jakobs
Contact:

Re: Several errors with update

Post by canonknipser » Sat Aug 19, 2017 8:38 pm

toronto2001 wrote:
Sat Aug 19, 2017 8:17 pm
Uh oh. I checked and the ASCII thing was checked. What would that have screwed up? Some image files work, some don't but they all have extensions.
If the default "ascii for files without extension" is checked, this will screw up your attachments in the files folder (not avatars etc.)
Attachments are stored with a random filename without extension, so this setting affects them ->
toronto2001 wrote:
Sat Aug 19, 2017 8:17 pm
It's the attachments that are the biggest problem right now.
Give this a try: Copy all files from your phpbb3old/files-Folder to phpbb3/files (just overwrite, don't delete the existing files in phpbb3/files )
Greetings
Frank
phpbb.de support team member
English is not my native language
New arrival - Extensions and scripts for phpBB
no support via PM or mail

toronto2001
Registered User
Posts: 33
Joined: Tue Apr 21, 2015 6:34 pm

Re: Several errors with update

Post by toronto2001 » Sun Aug 20, 2017 12:45 am

canonknipser wrote:
Sat Aug 19, 2017 8:38 pm
toronto2001 wrote:
Sat Aug 19, 2017 8:17 pm
Uh oh. I checked and the ASCII thing was checked. What would that have screwed up? Some image files work, some don't but they all have extensions.
If the default "ascii for files without extension" is checked, this will screw up your attachments in the files folder (not avatars etc.)
Attachments are stored with a random filename without extension, so this setting affects them ->
toronto2001 wrote:
Sat Aug 19, 2017 8:17 pm
It's the attachments that are the biggest problem right now.
Give this a try: Copy all files from your phpbb3old/files-Folder to phpbb3/files (just overwrite, don't delete the existing files in phpbb3/files )
OK, got FileZilla set correctly. As for the copying of files, is that done in FileZilla? I downloaded the complete old file folder then uploaded it, overwriting anything that was double but leaving the newer ones. When I looked at a few of the files by renaming them .jpg (copied and pasted into another folder), some were complete, others looked like those photos where light has leaked onto the film.
The dates on the files inside the phpbb3old are dated well before the update but the folder itself says it was modified August 7th, the day I updated the software. I don't know if that is significant or not. The file folder that I downloaded today then uploaded contains files with today's date.
OK, so copy the 'good' files in the older file folder should work but please let me know how to do that, I mean in FileZilla or the way I did it today (download then upload in FileZilla). That didn't work so perhaps it has to be done inside the FTP program.

Thanks for the response. I'll continue working on this tomorrow.

janus_zonstraal
Registered User
Posts: 1754
Joined: Sat Aug 30, 2014 1:30 pm

Re: Several errors with update

Post by janus_zonstraal » Sun Aug 20, 2017 6:48 am

You did it the right way, (Download them en overwrite the older files )
Very strange that you can't see the new file?
Maybe purge the cache will help.
Sorry! My English is bat ;) !!!

toronto2001
Registered User
Posts: 33
Joined: Tue Apr 21, 2015 6:34 pm

Re: Several errors with update

Post by toronto2001 » Sun Aug 20, 2017 2:15 pm

janus_zonstraal wrote:
Sun Aug 20, 2017 6:48 am
You did it the right way, (Download them en overwrite the older files )
Very strange that you can't see the new file?
Maybe purge the cache will help.
OK great. As you know, we got the images back. Thanks to all for the assistance there. That tick on FileZIlla should be in the update or install instructions, written in stone! (Maybe it is but I missed it).

OK so now the problems left are the posting and PM lag and the forum email problem. The email just doesn't work at all. The lagging is a problem but the posts and PMs go through eventually but the poster/sender doesn't get a notice as the writing box screen never goes away.

Seeing as how I downloaded the main folders with FZ ticked, are there files in there that would be corrupt, I mean other than the images?

We're a tuning forum so getting the images back was vital. The other stuff is a PITA but the forum is functioning thanks to everyone's help. Very much appreciated!

toronto2001
Registered User
Posts: 33
Joined: Tue Apr 21, 2015 6:34 pm

Re: Several errors with update

Post by toronto2001 » Wed Sep 13, 2017 11:19 pm

The forum still isn't working correctly. One thing I noticed today was that deleting a registrant from the Inactive Users page worked perfectly. Activating a user from the page never works. The software hangs then stops but the user has been activated. Same for PMs and most posts. The email still doesn't work.
Is there a clue in all of this? What does deleting a user involve that activating a user doesn't, or vice versa?

toronto2001
Registered User
Posts: 33
Joined: Tue Apr 21, 2015 6:34 pm

Re: Several errors with update

Post by toronto2001 » Wed Oct 25, 2017 6:50 pm

There are still major problems with this installation/upgrade. Some posts go through immediately, others hang once you click submit and this error comes up:
___________________
This site can’t be reached

The webpage at http://gtworld.ca/posting.php?mode=reply&f=16&t=1410 might be temporarily down or it may have moved permanently to a new web address.
ERR_INVALID_RESPONSE
__________________

Member activations ALWAYS hang but deleting a registration never hangs. The activations are completed but there is no verification page. Once you open the forum in another tab, you see the member has been activated. I get this error now (new) when activating:

_______________________________

[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions_messenger.php on line 1541: stream_socket_enable_crypto(): SSL operation failed with code 1. OpenSSL Error messages: error:14090086:SSL routines:ssl3_get_server_certificate:certificate verify failed
Warning: Cannot modify header information - headers already sent by (output started at /hermes/walnaweb11a/b599/moo.simplecomputers/gtworld/phpBB3/includes/functions.php:3262) in /hermes/walnaweb11a/b599/moo.simplecomputers/gtworld/phpBB3/includes/functions.php on line 1949
Return to the index page
General Error
SQL ERROR [ mysqli ]

Incorrect string value: '\xFBx j\xB6'...' for column 'log_data' at row 1 [1366]

SQL



BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 999
CALL: trigger_error()

FILE: [ROOT]/phpbb/db/driver/mysqli.php
LINE: 193
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/phpbb/db/driver/factory.php
LINE: 329
CALL: phpbb\db\driver\mysqli->sql_query()

FILE: [ROOT]/phpbb/log/log.php
LINE: 317
CALL: phpbb\db\driver\factory->sql_query()

FILE: [ROOT]/includes/functions_messenger.php
LINE: 428
CALL: phpbb\log\log->add()

FILE: [ROOT]/includes/functions_messenger.php
LINE: 594
CALL: messenger->error()

FILE: [ROOT]/includes/functions_messenger.php
LINE: 384
CALL: messenger->msg_email()

FILE: [ROOT]/phpbb/notification/method/messenger_base.php
LINE: 110
CALL: messenger->send()

FILE: [ROOT]/phpbb/notification/method/email.php
LINE: 70
CALL: phpbb\notification\method\messenger_base->notify_using_messenger()

FILE: [ROOT]/phpbb/notification/manager.php
LINE: 383
CALL: phpbb\notification\method\email->notify()

FILE: [ROOT]/phpbb/notification/manager.php
LINE: 295
CALL: phpbb\notification\manager->add_notifications_for_users()

FILE: [ROOT]/phpbb/notification/manager.php
LINE: 266
CALL: phpbb\notification\manager->add_notifications()

FILE: [ROOT]/includes/functions_posting.php
LINE: 2290
CALL: phpbb\notification\manager->add_notifications()

FILE: [ROOT]/posting.php
LINE: 1424
CALL: submit_post()
____________________________________

I'm lost as to where to go now. If I can't find a solution here, what are my options? I now have 1500 members so I feel an enormous responsibility to them. Any solutions, suggestions, whatever would be appreciated. Thanks!

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: Badhon_raj and 11 guests

cron