unable to update 3.2.0 to 3.2.1

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
User avatar
newsmedia
Registered User
Posts: 73
Joined: Sat Sep 15, 2012 12:29 pm
Location: Ireland
Name: Keith

unable to update 3.2.0 to 3.2.1

Post by newsmedia » Sat Sep 02, 2017 11:33 pm

I have followed the upgrade instructions 100%.

After four attempts, when I go to xxxxxx/etc/install , every time all I get is an error:
This error (HTTP 500 Internal Server Error) means that the website you are visiting had a server problem which prevented the webpage from displaying.

For more information about HTTP errors, see Help
Trying to access the ACP bring the following:
Your phpBB installation has not been correctly updated. More information »

A new feature release 3.2.1 is available. Please read the release announcement to learn about what it has to offer, and how to upgrade.

Warning

Please delete, move or rename the install directory before you use your board. If this directory is still present, only the Administration Control Panel (ACP) will be accessible.
Clicking the link 'Now start the update process by pointing your browser to the install folder'.
(http://www.newsmedianews.com/mewsforum/install/app.php)
again brings up error:
This error (HTTP 500 Internal Server Error) means that the website you are visiting had a server problem which prevented the webpage from displaying.

There is no option to update the database


The board was working perfectly prior to the attempted update.

Why is there no update package for v3.2.0 to 3.2.1 ??

Rgds

Grids
Registered User
Posts: 8
Joined: Fri Sep 01, 2017 3:34 pm

Re: unable to update 3.2.0 to 3.2.1

Post by Grids » Sun Sep 03, 2017 2:03 am

Hi, looks like you have not copied all the necessary files needed to update phpBB:

Code: Select all

[phpBB Debug] "include(/home/newsmedi/public_html/mewsforum/vendor/zendframework/zend-stdlib/src/ArrayObject.php): failed to open stream: No such file or directory" in file /home/newsmedi/public_html/mewsforum/vendor/composer/ClassLoader.php on line 412[phpBB Debug] "include(): Failed opening '/home/newsmedi/public_html/mewsforum/vendor/zendframework/zend-stdlib/src/ArrayObject.php' for inclusion (include_path='.:/opt/cpanel/ea-php56/root/usr/share/pear')" in file /home/newsmedi/public_html/mewsforum/vendor/composer/ClassLoader.php on line 412

User avatar
newsmedia
Registered User
Posts: 73
Joined: Sat Sep 15, 2012 12:29 pm
Location: Ireland
Name: Keith

Re: unable to update 3.2.0 to 3.2.1

Post by newsmedia » Sun Sep 03, 2017 2:24 am

Many thanks for your feedback. However, at time of attempted updates ALL files were present on the server -I manually checked this.

I have now successfully updated to 3.2.1 — however I had to delete all files on the host system and re-upload ALL files expect the ext folder.

All seems good now.

User avatar
KevC
Support Team Member
Support Team Member
Posts: 69454
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: unable to update 3.2.0 to 3.2.1

Post by KevC » Sun Sep 03, 2017 9:35 am

For reference, when you get a server side error like that it's best to check the server error logs as they should tell you what the problem is. Most likely, one of the files or folders hadn't uploaded completely.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

Post Reply

Return to “[3.2.x] Support Forum”