Perplexing database upgrade: 3.0.4 to 3.2.1

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Peter_B
Registered User
Posts: 10
Joined: Sun Sep 17, 2017 1:20 pm

Re: Perplexing database upgrade: 3.0.4 to 3.2.1

Post by Peter_B » Thu Sep 21, 2017 10:21 am

rxu thank you for the SQL updater script links. I started logically with the 3.0 version SQL updater and set about all the SQL modifications it generated. Some of these were ALTER TABLE statements for tables missing from a 3.0.4 version but probably created by the time you reach 3.0.14. All new fields were created as required and the ALTER statements converted to CREATE statements as required. After a couple of hours I ended up with an error free database probably aligned with 3.0.14 ... :P

Onto the 3.1 SQL updater script... 11 missing tables, 8 missing fields ! Another couple of hours work :lol:
At this point I thought, OK so I do all this database updating but will I ever get past the actual file updates needed ? I left the error free 3.0 database as is and went for a full version 3.2.1 upgrade. All good until I hit the well documented 'ACP_SEND_STATISTICS' issue. I got past that by hacking the code as it's not a used module anyway these days.
Next up was the well documented 'The config setting "captcha_plugin" unexpectedly does not exist' which I couldn't get past. Back to the drawing board, I thought I would try incremental upgrades. the first was 3.0.4 to 3.0.7PLI which has been suggested in the forums to cope with the issues that 3.0.6 introduced. All is good with this until the very end where I get this error...

Unable to open file ./../store/update_3.0.4_to_3.0.7-PL1_1505987315_ded76ec21da654c3.tar.gz [gzopen - wb]

... which I suspect is due to my current situation in that I'm doing these trial upgrades on an Ubuntu virtual machine GUEST running on Win10 HOST and that error is the script trying to find the phpBB root/store directory to download to on the Win 10 host... which of course doesn't exist. I don't really know how to get around that. Any ideas would be appreciated.

Sadly it is starting to look like an upgrade of 3.0.4 to 3.2.1 is an epic undertaking. I do hate giving up but I've learned a lot on the way after many hours. I'm not beaten yet, I may try the incremental upgrades on the live server which may get me past the preceding error... who knows.

Thanks for all the advice so far. it is appreciated. I'm still open to ideas !

Peter_B
Registered User
Posts: 10
Joined: Sun Sep 17, 2017 1:20 pm

Re: Perplexing database upgrade: 3.0.4 to 3.2.1

Post by Peter_B » Thu Sep 21, 2017 8:07 pm

OK, an UPDATE on this saga...

Success :D I finally achieved and error-free upgrade from 3.0.4 to 3.2.1 !

It was in a roundabout way. The inability to do incremental upgrades on the virtual machine was due to the scripts being unable to locate the /store directory with the appropriate updated files. To get round this I did 2 incremental updates on the live server (3.0.4 --> 3.0.7PLI --> 3.0.14). I could not make a further incremental update to 3.1.11 install on this server, due to errors encountered in install/index.php.

I transferred all of the 3.0.14 installation (files + database) to the virtual machine and updated by the recommended method directly to 3.2.1, which was completely error-free.

Thank you for your advice and suggestions throughout, they did help. Please regard this issue as resolved.

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: Blacktiger63, GOLX, HiFiKabin, janus_zonstraal, JoshyPHP, keelhauler, KevC, Mannix_, vmNav2 and 20 guests