BBcode [IMG] interpreted as a [URL]

Get help with installation and running phpBB 3.2.x here. Please do not post bug reports, feature requests, or extension related questions here.
Post Reply
User avatar
Niko!
Registered User
Posts: 8
Joined: Thu Jan 22, 2015 5:27 pm
Contact:

BBcode [IMG] interpreted as a [URL]

Post by Niko! » Thu Oct 12, 2017 5:04 pm

Hello,

in my forum https://help.ticketing.one I noticed that the BBcode IMG doesn’t work: the link is interpreted as a link, and not as a picture.. so at the end i see:

Code: Select all

[img]<a href=“LINK”>LINK</a>
example: https://help.ticketing.one/viewtopic.php?f=2&t=26

No MODS installed
Extensions have been disabled but the problem still occurred (so it is not related to extensions)

Can you help me?
Thanks in advance!
...

User avatar
JoshyPHP
Code Contributor
Posts: 742
Joined: Mon Jul 11, 2011 12:28 am

Re: BBcode [IMG] interpreted as a [URL]

Post by JoshyPHP » Thu Oct 12, 2017 9:34 pm

There are global settings that disable images, and per-user settings that disable them. There may be a permission setting for it too. Check them all out.

Try posting a new message with an image. If there's an issue with an extension, you need a new post submitted after the extension has been disabled.

If images are enabled but they don't appear then you may try downloading this extension. You'll need to unpack its content into the ext/s9e/debug directory that you'll create. Then enable the extension and post a new message with a single image followed by [debug]. When viewing the post, it should display some kind of debug info where [debug] was used
I wrote the thing that does the BBCodes in 3.2. Unless it broke yours, in which case it was somebody else with a similar name.

User avatar
Niko!
Registered User
Posts: 8
Joined: Thu Jan 22, 2015 5:27 pm
Contact:

Re: BBcode [IMG] interpreted as a [URL]

Post by Niko! » Sun Oct 29, 2017 2:03 pm

Hello,

thanks for your help!

I noticed that if I disable "Do not automatically parse URLs" - the IMG bbcode works perfectly.. but once enabled, it considers the link before the img tag :roll:
...

User avatar
stevemaury
Support Team Member
Support Team Member
Posts: 47895
Joined: Thu Nov 02, 2006 12:21 am
Location: The U.P.
Name: Steve
Contact:

Re: BBcode [IMG] interpreted as a [URL]

Post by stevemaury » Sun Oct 29, 2017 3:03 pm

The correct syntax is Image . The <a href></a> is not needed.
For REALLY good and VERY inexpensive hosting CLICK HERE

All unsolicited PMs will be ignored.

User avatar
Niko!
Registered User
Posts: 8
Joined: Thu Jan 22, 2015 5:27 pm
Contact:

Re: BBcode [IMG] interpreted as a [URL]

Post by Niko! » Mon Oct 30, 2017 9:19 am

Sorry, I think you didn’t get the problem :)

If “Do not automatically parse the URL” is disabled, if i post this:

Code: Select all

[img]LINK HERE[/img]
I get this:

Code: Select all

[img]<a href=“LINK HERE”>LINL HERE</a>[/img]
but if “do not automatically parse the links” is enabled.. everything is correct :)
...

User avatar
Niko!
Registered User
Posts: 8
Joined: Thu Jan 22, 2015 5:27 pm
Contact:

Re: BBcode [IMG] interpreted as a [URL]

Post by Niko! » Tue Oct 31, 2017 4:38 pm

Bumping this too :oops: :oops:
...

User avatar
JoshyPHP
Code Contributor
Posts: 742
Joined: Mon Jul 11, 2011 12:28 am

Re: BBcode [IMG] interpreted as a [URL]

Post by JoshyPHP » Tue Oct 31, 2017 8:02 pm

There's no explanation for the behaviour you describe so without more information it's impossible to tell. Try the following instructions and maybe it will uncover something useful.
JoshyPHP wrote:
Thu Oct 12, 2017 9:34 pm
If images are enabled but they don't appear then you may try downloading this extension. You'll need to unpack its content into the ext/s9e/debug directory that you'll create. Then enable the extension and post a new message with a single image followed by [debug]. When viewing the post, it should display some kind of debug info where [debug] was used
Also, the topic you linked as an example shows an image. It's there and it's visible. If you don't see an image, you may have disabled them in your preferences.
I wrote the thing that does the BBCodes in 3.2. Unless it broke yours, in which case it was somebody else with a similar name.

Post Reply

Return to “[3.2.x] Support Forum”

Who is online

Users browsing this forum: atessa_61, Badhon_raj, canonknipser, stevemaury, Turkuaz and 22 guests